summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2010-08-13 03:06:15 +0000
committerSteve Arnold <nerdboy@gentoo.org>2010-08-13 03:06:15 +0000
commit8141eb56834443dbd8c1346e46a49ca83ef6e7b0 (patch)
treec867a1ecfc7a352159761c3739f876de5a52fec9 /dev-libs/liblist/liblist-2.3.1-r1.ebuild
parentVersion bump (diff)
downloadgentoo-2-8141eb56834443dbd8c1346e46a49ca83ef6e7b0.tar.gz
gentoo-2-8141eb56834443dbd8c1346e46a49ca83ef6e7b0.tar.bz2
gentoo-2-8141eb56834443dbd8c1346e46a49ca83ef6e7b0.zip
Updated to EAPI=3 (eprefix) and tested on ubuntu-amd64 (bug #332531).
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/liblist/liblist-2.3.1-r1.ebuild')
-rw-r--r--dev-libs/liblist/liblist-2.3.1-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/liblist/liblist-2.3.1-r1.ebuild b/dev-libs/liblist/liblist-2.3.1-r1.ebuild
new file mode 100644
index 000000000000..36e454eb0eea
--- /dev/null
+++ b/dev-libs/liblist/liblist-2.3.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/liblist/liblist-2.3.1-r1.ebuild,v 1.1 2010/08/13 03:06:15 nerdboy Exp $
+
+EAPI=3
+
+inherit multilib
+
+DESCRIPTION="This package provides generic linked-list manipulation routines, plus queues and stacks"
+HOMEPAGE="http://ohnopub.net/liblist"
+SRC_URI="ftp://ohnopublishing.net/mirror/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux ~ppc ~ppc64 ~x86"
+IUSE="doc examples static-libs"
+
+src_configure() {
+ econf $(use_enable doc docs) \
+ $(use_enable examples) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc README || die
+
+ if use examples; then
+ insinto /usr/share/doc/${P}/examples
+ doins examples/{*.c,Makefile,README} || die
+ insinto /usr/share/doc/${P}/examples/cache
+ doins examples/cache/{*.c,README} || die
+ fi
+
+ if ! use static-libs; then
+ rm -v "${ED}"/usr/$(get_libdir)/liblist.la || die
+ if use examples; then
+ rm -v "${ED}"/usr/$(get_libdir)/libcache.la || die
+ fi
+ fi
+}
+
+pkg_postinst() {
+ elog "Note the man pages for this package have been renamed to avoid"
+ elog "name collisions with some system functions, however, the libs"
+ elog "and header files have not been changed."
+ elog "The new names are llist, lcache, lqueue, and lstack."
+}