summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-04-24 17:26:54 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-04-24 17:26:54 +0000
commitd1e6a5b8524c5e4bc4ff2c1cad45f19dc3ff2ec3 (patch)
tree3a8029f21eb71f5101210e48945113150b81c2e4 /dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild
parentnew version in unstable (diff)
downloadgentoo-2-d1e6a5b8524c5e4bc4ff2c1cad45f19dc3ff2ec3.tar.gz
gentoo-2-d1e6a5b8524c5e4bc4ff2c1cad45f19dc3ff2ec3.tar.bz2
gentoo-2-d1e6a5b8524c5e4bc4ff2c1cad45f19dc3ff2ec3.zip
new version in unstable
Diffstat (limited to 'dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild')
-rw-r--r--dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild b/dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild
new file mode 100644
index 000000000000..54a1b4334e0c
--- /dev/null
+++ b/dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild,v 1.1 2003/04/24 17:26:51 robbat2 Exp $
+
+inherit libtool
+
+S=${WORKDIR}/${P}
+DESCRIPTION="libmcrypt is a library that provides uniform interface to access several encryption algorithms."
+SRC_URI="ftp://mcrypt.hellug.gr/pub/mcrypt/libmcrypt/${P}.tar.gz"
+HOMEPAGE="http://mcrypt.hellug.gr/"
+
+DEPEND=">=sys-devel/automake-1.6.1
+ >=sys-devel/libtool-1.4.1-r8"
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~x86 ~sparc ~ppc ~hppa ~alpha"
+
+src_compile() {
+
+ local myconf
+ myconf=""
+ use pic && myconf="${myconf} --with-pic"
+ econf ${myconf} || die "configure failure"
+
+ emake || die "make failure"
+}
+
+src_install () {
+
+ dodir /usr/{bin,include,lib}
+
+ einstall || die "install failure"
+
+ dodoc AUTHORS KNOWN-BUGS COPYING COPYING.LIB INSTALL NEWS README THANKS TODO ChangeLog
+ dodoc doc/README.* doc/example.c
+ prepalldocs
+}