summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-02-21 08:43:28 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-02-21 08:43:28 +0000
commit5ec885324693fb12336338dcf36e638abedb0941 (patch)
tree0c04b0dae084cde92405cd7609586975b551d010 /dev-libs/libmemcached
parentRestricting jython (diff)
downloadgentoo-2-5ec885324693fb12336338dcf36e638abedb0941.tar.gz
gentoo-2-5ec885324693fb12336338dcf36e638abedb0941.tar.bz2
gentoo-2-5ec885324693fb12336338dcf36e638abedb0941.zip
Version bump.
(Portage version: 2.2.0_alpha87/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libmemcached')
-rw-r--r--dev-libs/libmemcached/ChangeLog7
-rw-r--r--dev-libs/libmemcached/libmemcached-1.0.4.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/dev-libs/libmemcached/ChangeLog b/dev-libs/libmemcached/ChangeLog
index 2c77dafb36bb..20ea79b81e3a 100644
--- a/dev-libs/libmemcached/ChangeLog
+++ b/dev-libs/libmemcached/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libmemcached
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmemcached/ChangeLog,v 1.41 2012/01/14 17:26:47 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmemcached/ChangeLog,v 1.42 2012/02/21 08:43:28 robbat2 Exp $
+
+*libmemcached-1.0.4 (21 Feb 2012)
+
+ 21 Feb 2012; Robin H. Johnson <robbat2@gentoo.org> +libmemcached-1.0.4.ebuild:
+ Version bump.
14 Jan 2012; Kacper Kowalik <xarthisius@gentoo.org> metadata.xml:
tcmalloc is now global
diff --git a/dev-libs/libmemcached/libmemcached-1.0.4.ebuild b/dev-libs/libmemcached/libmemcached-1.0.4.ebuild
new file mode 100644
index 000000000000..7a7406efe7d1
--- /dev/null
+++ b/dev-libs/libmemcached/libmemcached-1.0.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmemcached/libmemcached-1.0.4.ebuild,v 1.1 2012/02/21 08:43:28 robbat2 Exp $
+
+EAPI="3"
+
+inherit eutils multilib
+
+DESCRIPTION="a C client library to the memcached server"
+HOMEPAGE="http://tangent.org/552/libmemcached.html"
+SRC_URI="http://launchpad.net/${PN}/1.0/${PV}/+download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~sparc-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug doc hsieh +libevent sasl static-libs tcmalloc"
+
+DEPEND="net-misc/memcached
+ virtual/perl-PodParser
+ doc? ( dev-python/sphinx )
+ libevent? ( dev-libs/libevent )
+ tcmalloc? ( dev-util/google-perftools )
+ sasl? ( virtual/gsasl )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # These tests freezes for me
+ sed -i \
+ -e "/connectionpool/d" \
+ -e "/lp:583031/d" \
+ tests/${P%.*}/mem_functions.cc || die
+}
+
+src_configure() {
+ econf \
+ --disable-dtrace \
+ --disable-libinnodb \
+ $(use_enable debug assert) \
+ $(use_with debug debug) \
+ $(use_enable hsieh hsieh_hash) \
+ $(use_enable libevent libevent) \
+ $(use_enable tcmalloc tcmalloc) \
+ $(use_with sasl libsasl-prefix) \
+ $(use_with sasl libsasl2-prefix) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake || die
+
+ if use doc; then
+ emake html-local || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ use static-libs || rm -f "${D}"/usr/$(get_libdir)/lib*.la
+
+ dodoc AUTHORS ChangeLog README THANKS TODO
+ # remove manpage to avoid collision, see bug #299330
+ rm -f "${D}"/usr/share/man/man1/memdump.* || die "Install failed"
+ newman docs/man/memdump.1 memcached_memdump.1
+ if use doc; then
+ dohtml -r docs/html/* || die
+ fi
+}