summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2010-04-06 22:06:48 +0000
committerMike Auty <ikelos@gentoo.org>2010-04-06 22:06:48 +0000
commit4f09b8e3fdfd442472c1792770911376d86e1f7b (patch)
treee4e1c00e17b79ca93a52d7f247913a97487bb65b /dev-libs/libnfc
parentConverted ebuild to EAPI2. Fixed bug #286146 and #294636. (diff)
downloadgentoo-2-4f09b8e3fdfd442472c1792770911376d86e1f7b.tar.gz
gentoo-2-4f09b8e3fdfd442472c1792770911376d86e1f7b.tar.bz2
gentoo-2-4f09b8e3fdfd442472c1792770911376d86e1f7b.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'dev-libs/libnfc')
-rw-r--r--dev-libs/libnfc/ChangeLog7
-rw-r--r--dev-libs/libnfc/libnfc-1.3.4.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-libs/libnfc/ChangeLog b/dev-libs/libnfc/ChangeLog
index f1b29d5b7b4f..c5fd94836c1f 100644
--- a/dev-libs/libnfc/ChangeLog
+++ b/dev-libs/libnfc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libnfc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnfc/ChangeLog,v 1.4 2010/02/17 15:35:38 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnfc/ChangeLog,v 1.5 2010/04/06 22:06:48 ikelos Exp $
+
+*libnfc-1.3.4 (06 Apr 2010)
+
+ 06 Apr 2010; Mike Auty <ikelos@gentoo.org> +libnfc-1.3.4.ebuild:
+ Version bump.
*libnfc-1.3.3 (17 Feb 2010)
diff --git a/dev-libs/libnfc/libnfc-1.3.4.ebuild b/dev-libs/libnfc/libnfc-1.3.4.ebuild
new file mode 100644
index 000000000000..d48520d9e832
--- /dev/null
+++ b/dev-libs/libnfc/libnfc-1.3.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnfc/libnfc-1.3.4.ebuild,v 1.1 2010/04/06 22:06:48 ikelos Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Near Field Communications (NFC) library"
+HOMEPAGE="http://www.libnfc.org/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc"
+
+CDEPEND="sys-apps/pcsc-lite
+ dev-libs/libusb"
+DEPEND="${CDEPEND}
+ doc? ( app-doc/doxygen )"
+RDEPEND="${CDEPEND}"
+
+src_compile() {
+ emake || die "Failed to compile."
+ use doc && doxygen
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Failed to install properly."
+ use doc && dohtml "${S}"/doc/html/*
+}