summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2014-03-25 10:28:37 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2014-03-25 10:28:37 +0000
commit06edddd24cdfe5bd7efef4a3a86309ac6134cd15 (patch)
treec56108570704b5c24cfb9d0c92b87857f2cc2116 /dev-libs/liborcus
parentVersion bump to 0.7 series needed by git libreoffice. (diff)
downloadgentoo-2-06edddd24cdfe5bd7efef4a3a86309ac6134cd15.tar.gz
gentoo-2-06edddd24cdfe5bd7efef4a3a86309ac6134cd15.tar.bz2
gentoo-2-06edddd24cdfe5bd7efef4a3a86309ac6134cd15.zip
Version bump to 0.7 series needed by git libreoffice.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'dev-libs/liborcus')
-rw-r--r--dev-libs/liborcus/ChangeLog10
-rw-r--r--dev-libs/liborcus/liborcus-0.7.0.ebuild45
-rw-r--r--dev-libs/liborcus/liborcus-9999.ebuild6
3 files changed, 56 insertions, 5 deletions
diff --git a/dev-libs/liborcus/ChangeLog b/dev-libs/liborcus/ChangeLog
index 1e146d78344b..7db4ed8722b2 100644
--- a/dev-libs/liborcus/ChangeLog
+++ b/dev-libs/liborcus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/liborcus
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/liborcus/ChangeLog,v 1.25 2013/12/27 08:57:34 scarabeus Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/liborcus/ChangeLog,v 1.26 2014/03/25 10:28:37 scarabeus Exp $
+
+*liborcus-0.7.0 (25 Mar 2014)
+
+ 25 Mar 2014; Tomáš Chvátal <scarabeus@gentoo.org> +liborcus-0.7.0.ebuild,
+ liborcus-9999.ebuild:
+ Version bump to 0.7 series needed by git libreoffice.
27 Dec 2013; Tomáš Chvátal <scarabeus@gentoo.org>
+files/liborcus-0.5.1-oldnamespace.patch, liborcus-0.5.1.ebuild:
diff --git a/dev-libs/liborcus/liborcus-0.7.0.ebuild b/dev-libs/liborcus/liborcus-0.7.0.ebuild
new file mode 100644
index 000000000000..304abb439145
--- /dev/null
+++ b/dev-libs/liborcus/liborcus-0.7.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/liborcus/liborcus-0.7.0.ebuild,v 1.1 2014/03/25 10:28:37 scarabeus Exp $
+
+EAPI=5
+
+EGIT_REPO_URI="git://gitorious.org/orcus/orcus.git"
+
+[[ ${PV} == 9999 ]] && GITECLASS="git-2 autotools"
+inherit eutils ${GITECLASS}
+unset GITECLASS
+
+DESCRIPTION="Standalone file import filter library for spreadsheet documents"
+HOMEPAGE="http://gitorious.org/orcus/pages/Home"
+[[ ${PV} == 9999 ]] || SRC_URI="http://kohei.us/files/orcus/src/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0/0.5"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="static-libs"
+
+RDEPEND="
+ >=dev-libs/boost-1.51.0:=
+ >=dev-libs/libixion-0.7.0:=
+"
+DEPEND="${RDEPEND}
+ >=dev-util/mdds-0.8.1
+"
+
+src_prepare() {
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+}
diff --git a/dev-libs/liborcus/liborcus-9999.ebuild b/dev-libs/liborcus/liborcus-9999.ebuild
index ae7d40f1868e..c61257b8c872 100644
--- a/dev-libs/liborcus/liborcus-9999.ebuild
+++ b/dev-libs/liborcus/liborcus-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/liborcus/liborcus-9999.ebuild,v 1.9 2013/07/10 07:46:58 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/liborcus/liborcus-9999.ebuild,v 1.10 2014/03/25 10:28:37 scarabeus Exp $
EAPI=5
@@ -15,7 +15,7 @@ HOMEPAGE="http://gitorious.org/orcus/pages/Home"
[[ ${PV} == 9999 ]] || SRC_URI="http://kohei.us/files/orcus/src/${P}.tar.bz2"
LICENSE="MIT"
-SLOT="0/0.5"
+SLOT="0/0.7"
[[ ${PV} == 9999 ]] || \
KEYWORDS="~amd64 ~arm ~ppc ~x86"
IUSE="static-libs"