summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-03 02:18:13 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-03 02:18:13 +0000
commit64bf72907497c8f505d5cefdf2139e8b0bff304d (patch)
treeacf281f3f16e459167394d99e57441e47ac34e97 /dev-libs/libsigc++/libsigc++-1.0.4-r2.ebuild
parentcleanup old portage styles (diff)
downloadgentoo-2-64bf72907497c8f505d5cefdf2139e8b0bff304d.tar.gz
gentoo-2-64bf72907497c8f505d5cefdf2139e8b0bff304d.tar.bz2
gentoo-2-64bf72907497c8f505d5cefdf2139e8b0bff304d.zip
DEBUG -> use debug
Diffstat (limited to 'dev-libs/libsigc++/libsigc++-1.0.4-r2.ebuild')
-rw-r--r--dev-libs/libsigc++/libsigc++-1.0.4-r2.ebuild20
1 files changed, 7 insertions, 13 deletions
diff --git a/dev-libs/libsigc++/libsigc++-1.0.4-r2.ebuild b/dev-libs/libsigc++/libsigc++-1.0.4-r2.ebuild
index a04e7660a3c4..a7de8afa7661 100644
--- a/dev-libs/libsigc++/libsigc++-1.0.4-r2.ebuild
+++ b/dev-libs/libsigc++/libsigc++-1.0.4-r2.ebuild
@@ -1,29 +1,23 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-1.0.4-r2.ebuild,v 1.10 2003/07/11 20:13:59 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-1.0.4-r2.ebuild,v 1.11 2003/08/03 02:18:13 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="The GLib library of C routines"
-SRC_URI="http://download.sourceforge.net/libsigc/${P}.tar.gz"
HOMEPAGE="http://libsigc.sourceforge.net/"
+SRC_URI="http://download.sourceforge.net/libsigc/${P}.tar.gz"
-SLOT="1.0"
LICENSE="GPL-2 LGPL-2.1"
+SLOT="1.0"
KEYWORDS="x86 ppc sparc hppa"
+IUSE="debug"
DEPEND="virtual/glibc"
src_compile() {
-
local myconf=""
-
- if [ "${DEBUG}" ]
- then
- myconf="--enable-debug=yes"
- else
- myconf="--enable-debug=no"
- fi
-
+ use debug \
+ && myconf="--enable-debug=yes" \
+ || myconf="--enable-debug=no"
econf ${myconf} || die
# Fix sandbox violation when old libsig++ is already installed,