summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-04 02:23:33 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-04 02:23:33 +0000
commit413b8a1457dad9f545d5ebeaaf50da905befbd3e (patch)
tree655c12804b7939c9536549ba59aa714d58ea6ef6 /dev-libs/libtommath
parentVersion bump #124867 by Alon Bar-Lev. (diff)
downloadgentoo-2-413b8a1457dad9f545d5ebeaaf50da905befbd3e.tar.gz
gentoo-2-413b8a1457dad9f545d5ebeaaf50da905befbd3e.tar.bz2
gentoo-2-413b8a1457dad9f545d5ebeaaf50da905befbd3e.zip
touchup patch so we dont link against libstdc++ #124809 by Bruce Guenter
(Portage version: 2.1_pre5-r2)
Diffstat (limited to 'dev-libs/libtommath')
-rw-r--r--dev-libs/libtommath/files/libtommath-0.36-shared-lib.patch17
-rw-r--r--dev-libs/libtommath/libtommath-0.36-r1.ebuild4
2 files changed, 14 insertions, 7 deletions
diff --git a/dev-libs/libtommath/files/libtommath-0.36-shared-lib.patch b/dev-libs/libtommath/files/libtommath-0.36-shared-lib.patch
index 4ad81df66f39..f558b620526f 100644
--- a/dev-libs/libtommath/files/libtommath-0.36-shared-lib.patch
+++ b/dev-libs/libtommath/files/libtommath-0.36-shared-lib.patch
@@ -1,18 +1,25 @@
patch by Bruce Guenter
http://bugs.gentoo.org/124692
+http://bugs.gentoo.org/124809
--- libtommath-0.36/makefile.shared
+++ libtommath-0.36/makefile.shared
-@@ -84,7 +84,10 @@
- libtool --mode=link gcc *.lo -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION)
- libtool --mode=link gcc *.o -o $(LIBNAME_S)
- ranlib $(LIBNAME_S)
+@@ -81,11 +81,13 @@
+ bn_mp_to_signed_bin_n.o bn_mp_to_unsigned_bin_n.o
+
+ $(LIBNAME): $(OBJECTS)
+- libtool --mode=link gcc *.lo -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION)
+- libtool --mode=link gcc *.o -o $(LIBNAME_S)
+- ranlib $(LIBNAME_S)
- libtool --mode=install install -c $(LIBNAME) $(LIBPATH)/$@
++ libtool --mode=link --tag=CC gcc *.lo -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION)
++ libtool --mode=link --tag=CC gcc *.o -o $(LIBNAME_S)
+
+install: $(LIBNAME) $(HEADERS)
+ install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(LIBPATH)
-+ libtool --mode=install install -c $(LIBNAME) $(DESTDIR)$(LIBPATH)/$@
install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(INCPATH)
++ libtool --mode=install install -c $(LIBNAME) $(DESTDIR)$(LIBPATH)/$(LIBNAME)
install -g $(GROUP) -o $(USER) $(HEADERS) $(DESTDIR)$(INCPATH)
+ test: $(LIBNAME) demo/demo.o
diff --git a/dev-libs/libtommath/libtommath-0.36-r1.ebuild b/dev-libs/libtommath/libtommath-0.36-r1.ebuild
index b27027c1cec5..3ed0d34593db 100644
--- a/dev-libs/libtommath/libtommath-0.36-r1.ebuild
+++ b/dev-libs/libtommath/libtommath-0.36-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/libtommath-0.36-r1.ebuild,v 1.2 2006/03/03 12:36:15 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/libtommath-0.36-r1.ebuild,v 1.3 2006/03/04 02:23:33 vapier Exp $
inherit eutils multilib
@@ -23,7 +23,7 @@ src_unpack() {
}
src_compile() {
- emake -f makefile.shared IGNORE_SPEED=1 LIBPATH="/usr/$(get_libdir)" || die
+ emake -f makefile.shared IGNORE_SPEED=1 || die
}
src_install() {