summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2014-01-06 19:16:34 +0000
committerThomas Sachau <tommy@gentoo.org>2014-01-06 19:16:34 +0000
commite7c933134c15e0212b38b6caa0b31fc31b56b6be (patch)
treecfe8febda226a8cc34b8d51916a5b6f810423fca /dev-libs/libxml2
parentFixed build with perl-5.18 (bug #497286) (diff)
downloadgentoo-2-e7c933134c15e0212b38b6caa0b31fc31b56b6be.tar.gz
gentoo-2-e7c933134c15e0212b38b6caa0b31fc31b56b6be.tar.bz2
gentoo-2-e7c933134c15e0212b38b6caa0b31fc31b56b6be.zip
Use multilib_build_binaries instead of multilib_is_native_abi, fixes build failures of multilib-portage e.g. with 32bit mesa because of missing 32bit python modules of libxml2
(Portage version: 2.2.6-r1/cvs/Linux x86_64, signed Manifest commit with key 0x35899067)
Diffstat (limited to 'dev-libs/libxml2')
-rw-r--r--dev-libs/libxml2/ChangeLog8
-rw-r--r--dev-libs/libxml2/libxml2-2.9.1-r2.ebuild10
2 files changed, 12 insertions, 6 deletions
diff --git a/dev-libs/libxml2/ChangeLog b/dev-libs/libxml2/ChangeLog
index 830583a266f2..deceb8d4e00d 100644
--- a/dev-libs/libxml2/ChangeLog
+++ b/dev-libs/libxml2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libxml2
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.405 2014/01/03 20:48:10 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.406 2014/01/06 19:16:34 tommy Exp $
+
+ 06 Jan 2014; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ libxml2-2.9.1-r2.ebuild:
+ Use multilib_build_binaries instead of multilib_is_native_abi, fixes build
+ failures of multilib-portage e.g. with 32bit mesa because of missing 32bit
+ python modules of libxml2
03 Jan 2014; Alexandre Rostovtsev <tetromino@gentoo.org>
libxml2-2.9.1-r2.ebuild:
diff --git a/dev-libs/libxml2/libxml2-2.9.1-r2.ebuild b/dev-libs/libxml2/libxml2-2.9.1-r2.ebuild
index a2550eb2bd43..fbef5c98b431 100644
--- a/dev-libs/libxml2/libxml2-2.9.1-r2.ebuild
+++ b/dev-libs/libxml2/libxml2-2.9.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.9.1-r2.ebuild,v 1.2 2014/01/03 20:48:10 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.9.1-r2.ebuild,v 1.3 2014/01/06 19:16:34 tommy Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
@@ -110,7 +110,7 @@ multilib_src_configure() {
local myconf
- if multilib_is_native_abi; then
+ if multilib_build_binaries; then
myconf="$(use_with python)
$(use_with readline)
$(use_with readline history)"
@@ -133,7 +133,7 @@ multilib_src_configure() {
multilib_src_compile() {
default
- if multilib_is_native_abi && use python; then
+ if multilib_build_binaries && use python; then
python_copy_sources
python_foreach_impl libxml2_py_emake
fi
@@ -141,14 +141,14 @@ multilib_src_compile() {
multilib_src_test() {
default
- multilib_is_native_abi && use python && python_foreach_impl libxml2_py_emake test
+ multilib_build_binaries && use python && python_foreach_impl libxml2_py_emake test
}
multilib_src_install() {
emake DESTDIR="${D}" \
EXAMPLES_DIR="${EPREFIX}"/usr/share/doc/${PF}/examples install
- if multilib_is_native_abi && use python; then
+ if multilib_build_binaries && use python; then
python_foreach_impl libxml2_py_emake DESTDIR="${D}" \
docsdir="${EPREFIX}"/usr/share/doc/${PF}/python \
exampledir="${EPREFIX}"/usr/share/doc/${PF}/python/examples \