summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-01-10 09:49:34 +0000
committerMarinus Schraal <foser@gentoo.org>2004-01-10 09:49:34 +0000
commit3f9c6bd60ed138a561309480532d9f7a0d875f6e (patch)
tree74fc4e01e0661c952f3532174b16649104cd7912 /dev-libs/libxslt/libxslt-1.1.2.ebuild
parentnew release, mark 1.1.1 x86 (diff)
downloadgentoo-2-3f9c6bd60ed138a561309480532d9f7a0d875f6e.tar.gz
gentoo-2-3f9c6bd60ed138a561309480532d9f7a0d875f6e.tar.bz2
gentoo-2-3f9c6bd60ed138a561309480532d9f7a0d875f6e.zip
new release, mark 1.1.1 x86
Diffstat (limited to 'dev-libs/libxslt/libxslt-1.1.2.ebuild')
-rw-r--r--dev-libs/libxslt/libxslt-1.1.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/libxslt/libxslt-1.1.2.ebuild b/dev-libs/libxslt/libxslt-1.1.2.ebuild
new file mode 100644
index 000000000000..4dd46498bba5
--- /dev/null
+++ b/dev-libs/libxslt/libxslt-1.1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.1.2.ebuild,v 1.1 2004/01/10 09:49:24 foser Exp $
+
+inherit libtool gnome.org
+
+IUSE="python"
+DESCRIPTION="XSLT libraries and tools"
+HOMEPAGE="http://www.xmlsoft.org/"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64"
+
+DEPEND=">=dev-libs/libxml2-2.6.3
+ python? ( dev-lang/python )"
+
+src_compile() {
+
+ elibtoolize
+
+ econf $(use_with python) || die "configure failed"
+
+ emake || die "make failed"
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ DOCS_DIR=/usr/share/doc/${PF}/python \
+ EXAMPLE_DIR=/usr/share/doc/${PF}/python/example \
+ BASE_DIR=/usr/share/doc \
+ DOC_MODULE=${PF} \
+ EXAMPLES_DIR=/usr/share/doc/${PF}/example \
+ TARGET_DIR=/usr/share/doc/${PF}/html \
+ install || die "install failed"
+
+ dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
+
+}