summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2012-12-14 21:45:32 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2012-12-14 21:45:32 +0000
commitb449510c1bc72152d9d99112f5c78b13758dbcd6 (patch)
tree8f775756afe42127db134509b1aaa0086c5e8e17 /dev-libs/nettle/nettle-2.5-r1.ebuild
parentAdd regexp-UofT to MISC-FREE license group. (diff)
downloadgentoo-2-b449510c1bc72152d9d99112f5c78b13758dbcd6.tar.gz
gentoo-2-b449510c1bc72152d9d99112f5c78b13758dbcd6.tar.bz2
gentoo-2-b449510c1bc72152d9d99112f5c78b13758dbcd6.zip
bug#405525 add support for USE static-libs
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs/nettle/nettle-2.5-r1.ebuild')
-rw-r--r--dev-libs/nettle/nettle-2.5-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/nettle/nettle-2.5-r1.ebuild b/dev-libs/nettle/nettle-2.5-r1.ebuild
new file mode 100644
index 000000000000..19cdd91c5a22
--- /dev/null
+++ b/dev-libs/nettle/nettle-2.5-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-2.5-r1.ebuild,v 1.1 2012/12/14 21:45:31 alonbl Exp $
+
+EAPI="4"
+
+inherit eutils autotools
+
+DESCRIPTION="Low-level cryptographic library"
+HOMEPAGE="http://www.lysator.liu.se/~nisse/nettle/"
+SRC_URI="http://www.lysator.liu.se/~nisse/archive/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-3 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="static-libs +gmp"
+
+DEPEND="gmp? ( dev-libs/gmp )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -e "/CFLAGS=/s: -ggdb3::" -i configure.ac || die
+ epatch "${FILESDIR}"/${PN}-2.5-missing-libm-link.patch
+ sed -i -e 's/solaris\*)/sunldsolaris*)/' configure.ac || die
+ epatch "${FILESDIR}/${P}-static-libs.patch"
+ eautoreconf
+}
+
+src_configure() {
+ # --disable-openssl bug #427526
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable gmp public-key) \
+ --disable-openssl
+}