summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-01-01 16:13:42 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-01-01 16:13:42 +0000
commite9c71ebade8f7b50561c50911f153d6ae4f318dc (patch)
tree14f9c0d77b822929b8a65ac3b223eab580037437 /dev-libs/nettle
parentNon maintainer version bump. Bug #359187. Thanks to Ondrej Grover <ondrej.gro... (diff)
downloadgentoo-2-e9c71ebade8f7b50561c50911f153d6ae4f318dc.tar.gz
gentoo-2-e9c71ebade8f7b50561c50911f153d6ae4f318dc.tar.bz2
gentoo-2-e9c71ebade8f7b50561c50911f153d6ae4f318dc.zip
Fix build failure against binutils-2.22 by jdhore (bug #396659). Dropped blockers on nonexistent dev-libs/lsh.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/nettle')
-rw-r--r--dev-libs/nettle/ChangeLog10
-rw-r--r--dev-libs/nettle/files/nettle-2.0-binutils-2.22.patch21
-rw-r--r--dev-libs/nettle/nettle-1.15.ebuild7
-rw-r--r--dev-libs/nettle/nettle-2.0.ebuild7
-rw-r--r--dev-libs/nettle/nettle-2.1.ebuild6
5 files changed, 40 insertions, 11 deletions
diff --git a/dev-libs/nettle/ChangeLog b/dev-libs/nettle/ChangeLog
index eb184af22887..ced5f81ea7da 100644
--- a/dev-libs/nettle/ChangeLog
+++ b/dev-libs/nettle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/nettle
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/ChangeLog,v 1.46 2011/12/03 13:29:58 grobian Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/ChangeLog,v 1.47 2012/01/01 16:13:42 slyfox Exp $
+
+ 01 Jan 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/nettle-2.0-binutils-2.22.patch, nettle-1.15.ebuild, nettle-2.0.ebuild,
+ nettle-2.1.ebuild:
+ Fix build failure against binutils-2.22 by jdhore (bug #396659). Dropped
+ blockers on nonexistent dev-libs/lsh.
03 Dec 2011; Fabian Groffen <grobian@gentoo.org>
+files/nettle-2.4-darwin-shlink.patch, nettle-2.4.ebuild:
diff --git a/dev-libs/nettle/files/nettle-2.0-binutils-2.22.patch b/dev-libs/nettle/files/nettle-2.0-binutils-2.22.patch
new file mode 100644
index 000000000000..072fb66dce95
--- /dev/null
+++ b/dev-libs/nettle/files/nettle-2.0-binutils-2.22.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/396659
+
+Fix build failure againsn binutils-2.22.
+Picked from upstream.
+--- nettle-2.0/x86/md5-compress.asm 2009-06-08 21:27:11.000000000 +0300
++++ nettle-2.1/x86/md5-compress.asm 2010-07-25 22:30:14.000000000 +0300
+@@ -88,7 +88,7 @@
+ movl 12(TMP), SD
+
+ C Pointer to source data.
+- C Note that if analigned, we suffer unaligned accesses
++ C Note that if unaligned, we suffer unaligned accesses
+ movl 24(%esp), INPUT
+
+ ROUND(<F1>, SA, SB, SC, SD, REF( 0), $0xd76aa478, 7)
+@@ -171,4 +171,4 @@
+ popl %ebp
+ popl %ebx
+ ret
+-EPILOGUE(_nettle_sha1_compress)
++EPILOGUE(_nettle_md5_compress)
diff --git a/dev-libs/nettle/nettle-1.15.ebuild b/dev-libs/nettle/nettle-1.15.ebuild
index 91f4cdaa2adb..ab283d1d1c76 100644
--- a/dev-libs/nettle/nettle-1.15.ebuild
+++ b/dev-libs/nettle/nettle-1.15.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-1.15.ebuild,v 1.7 2010/12/17 15:50:55 c1pher Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-1.15.ebuild,v 1.8 2012/01/01 16:13:42 slyfox Exp $
inherit eutils autotools
@@ -15,13 +15,14 @@ IUSE="gmp ssl"
DEPEND="gmp? ( dev-libs/gmp )
ssl? ( dev-libs/openssl )
- !<dev-libs/lsh-1.4.3-r1"
+ "
RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${PN}-1.14-make-as-needed.patch"
+ epatch "${FILESDIR}"/${PN}-2.0-binutils-2.22.patch #bug 396659
sed -i \
-e '/CFLAGS/s:-ggdb3::' \
configure.ac || die
diff --git a/dev-libs/nettle/nettle-2.0.ebuild b/dev-libs/nettle/nettle-2.0.ebuild
index c910510b1444..141ed4c6fbdd 100644
--- a/dev-libs/nettle/nettle-2.0.ebuild
+++ b/dev-libs/nettle/nettle-2.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-2.0.ebuild,v 1.8 2010/03/29 10:52:52 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-2.0.ebuild,v 1.9 2012/01/01 16:13:42 slyfox Exp $
EAPI=2
inherit autotools eutils
@@ -16,11 +16,12 @@ IUSE="gmp ssl"
DEPEND="gmp? ( dev-libs/gmp )
ssl? ( dev-libs/openssl )
- !<dev-libs/lsh-1.4.3-r1"
+ "
RDEPEND="${DEPEND}"
src_prepare() {
epatch "${FILESDIR}"/${P}-asneeded.patch
+ epatch "${FILESDIR}"/${P}-binutils-2.22.patch #bug 396659
sed -i \
-e '/CFLAGS/s:-ggdb3::' \
configure.ac || die
diff --git a/dev-libs/nettle/nettle-2.1.ebuild b/dev-libs/nettle/nettle-2.1.ebuild
index bce783a4a5b5..364a8804b0bb 100644
--- a/dev-libs/nettle/nettle-2.1.ebuild
+++ b/dev-libs/nettle/nettle-2.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-2.1.ebuild,v 1.12 2011/07/24 10:29:52 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-2.1.ebuild,v 1.13 2012/01/01 16:13:42 slyfox Exp $
EAPI=2
inherit autotools eutils
@@ -16,7 +16,7 @@ IUSE="gmp ssl"
DEPEND="gmp? ( dev-libs/gmp )
ssl? ( dev-libs/openssl )
- !<dev-libs/lsh-1.4.3-r1"
+ "
RDEPEND="${DEPEND}"
src_prepare() {