summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-31 23:21:34 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-31 23:21:34 +0000
commit2597b1e77bab60eb3040e93bdff471e1aa633e08 (patch)
tree7a0106e877957ad18d5ac0a6435aad2c7190e5a5 /dev-libs/openssl
parentsuperh lovin #98418 (diff)
downloadgentoo-2-2597b1e77bab60eb3040e93bdff471e1aa633e08.tar.gz
gentoo-2-2597b1e77bab60eb3040e93bdff471e1aa633e08.tar.bz2
gentoo-2-2597b1e77bab60eb3040e93bdff471e1aa633e08.zip
superh support
Diffstat (limited to 'dev-libs/openssl')
-rwxr-xr-xdev-libs/openssl/files/gentoo.config-0.9.7g5
-rw-r--r--dev-libs/openssl/files/openssl-0.9.7g-superh.patch11
-rw-r--r--dev-libs/openssl/openssl-0.9.7g.ebuild3
3 files changed, 16 insertions, 3 deletions
diff --git a/dev-libs/openssl/files/gentoo.config-0.9.7g b/dev-libs/openssl/files/gentoo.config-0.9.7g
index c3c6e63e0e6e..6f90acb27655 100755
--- a/dev-libs/openssl/files/gentoo.config-0.9.7g
+++ b/dev-libs/openssl/files/gentoo.config-0.9.7g
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/files/gentoo.config-0.9.7g,v 1.6 2005/06/13 23:10:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/files/gentoo.config-0.9.7g,v 1.7 2005/07/31 23:21:34 vapier Exp $
#
# Openssl doesn't play along nicely with cross-compiling
# like autotools based projects, so let's teach it new tricks.
@@ -89,7 +89,8 @@ linux)
powerpc64*) machine=ppc64;;
powerpc*) machine=ppc;;
sh64*) machine=elf;;
- sh*) machine=elf;;
+ sh*b* machine="elf -DB_ENDIAN";;
+ sh*) machine="elf -DL_ENDIAN";;
sparc*v7*) machine=sparcv7;;
sparc64*) machine=sparcv9;;
sparc*) machine=sparcv8;;
diff --git a/dev-libs/openssl/files/openssl-0.9.7g-superh.patch b/dev-libs/openssl/files/openssl-0.9.7g-superh.patch
new file mode 100644
index 000000000000..db27373fd252
--- /dev/null
+++ b/dev-libs/openssl/files/openssl-0.9.7g-superh.patch
@@ -0,0 +1,11 @@
+--- config
++++ config
+@@ -587,6 +587,8 @@ case "$GUESSOS" in
+ arm*b-*-linux2) OUT="linux-elf-arm"; options="$options -DB_ENDIAN" ;;
+ arm*l-*-linux2) OUT="linux-elf-arm"; options="$options -DL_ENDIAN" ;;
+ arm*-*-linux2) OUT="linux-elf-arm" ;;
++ sh*b-*-linux2) OUT="linux-generic32"; options="$options -DB_ENDIAN" ;;
++ sh*-*-linux2) OUT="linux-generic32"; options="$options -DL_ENDIAN" ;;
+ s390-*-linux2) OUT="linux-s390" ;;
+ s390x-*-linux?) OUT="linux-s390x" ;;
+ x86_64-*-linux?) OUT="linux-x86_64" ;;
diff --git a/dev-libs/openssl/openssl-0.9.7g.ebuild b/dev-libs/openssl/openssl-0.9.7g.ebuild
index 2912bbb40aec..dd8798128611 100644
--- a/dev-libs/openssl/openssl-0.9.7g.ebuild
+++ b/dev-libs/openssl/openssl-0.9.7g.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7g.ebuild,v 1.12 2005/07/08 08:12:32 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7g.ebuild,v 1.13 2005/07/31 23:21:34 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -33,6 +33,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-0.9.7g-ptr-casting.patch
epatch "${FILESDIR}"/${PN}-0.9.7g-mem-clr-ptr-cast.patch
epatch "${FILESDIR}"/${PN}-0.9.7g-ABI-compat.patch
+ epatch "${FILESDIR}"/${PN}-0.9.7g-superh.patch
# allow openssl to be cross-compiled
cp "${FILESDIR}"/gentoo.config-0.9.7g gentoo.config || die "cp cross-compile failed"