summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-10 03:21:28 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-10 03:21:28 +0000
commit4dd84a9206b16228a857f77f2f631e94bdf8eacb (patch)
tree6b8a0eaec42219ec1e086431f4c0c939df67a99c /dev-libs/openssl
parentFix by solar to prevent stack overflow in build util #99487. (diff)
downloadgentoo-2-4dd84a9206b16228a857f77f2f631e94bdf8eacb.tar.gz
gentoo-2-4dd84a9206b16228a857f77f2f631e94bdf8eacb.tar.bz2
gentoo-2-4dd84a9206b16228a857f77f2f631e94bdf8eacb.zip
dont build manpages if FEATURES=noman
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-libs/openssl')
-rw-r--r--dev-libs/openssl/openssl-0.9.7g.ebuild5
-rw-r--r--dev-libs/openssl/openssl-0.9.8.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-libs/openssl/openssl-0.9.7g.ebuild b/dev-libs/openssl/openssl-0.9.7g.ebuild
index dd8798128611..66ccf22ba519 100644
--- a/dev-libs/openssl/openssl-0.9.7g.ebuild
+++ b/dev-libs/openssl/openssl-0.9.7g.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7g.ebuild,v 1.13 2005/07/31 23:21:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7g.ebuild,v 1.14 2005/08/10 03:21:28 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -39,6 +39,9 @@ src_unpack() {
cp "${FILESDIR}"/gentoo.config-0.9.7g gentoo.config || die "cp cross-compile failed"
chmod a+rx gentoo.config
+ # Don't build manpages if we don't want them
+ has noman FEATURES && sed -i '/^install:/s:install_docs::' Makefile.org
+
case $(gcc-version) in
3.2)
filter-flags -fprefetch-loop-arrays -freduce-all-givs -funroll-loop
diff --git a/dev-libs/openssl/openssl-0.9.8.ebuild b/dev-libs/openssl/openssl-0.9.8.ebuild
index 901053937a76..7e90745d5bd0 100644
--- a/dev-libs/openssl/openssl-0.9.8.ebuild
+++ b/dev-libs/openssl/openssl-0.9.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.8.ebuild,v 1.5 2005/07/31 23:22:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.8.ebuild,v 1.6 2005/08/10 03:21:28 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -35,6 +35,9 @@ src_unpack() {
cp "${FILESDIR}"/gentoo.config-0.9.7g gentoo.config || die "cp cross-compile failed"
chmod a+rx gentoo.config
+ # Don't build manpages if we don't want them
+ has noman FEATURES && sed -i '/^install:/s:install_docs::' Makefile.org
+
case $(gcc-version) in
3.2)
filter-flags -fprefetch-loop-arrays -freduce-all-givs -funroll-loop