summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-06-13 14:32:58 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-06-13 14:32:58 +0000
commita095ca84cef3cb17a677755759d79e508b7c03e9 (patch)
tree51df2a32700ea136da91a496d8010b9e927e4b75 /dev-libs/openssl
parent~sparc happy (diff)
downloadgentoo-2-a095ca84cef3cb17a677755759d79e508b7c03e9.tar.gz
gentoo-2-a095ca84cef3cb17a677755759d79e508b7c03e9.tar.bz2
gentoo-2-a095ca84cef3cb17a677755759d79e508b7c03e9.zip
Unbreak uclibc cross-compilation and beautify the script using a case instead of a series of ifs.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-libs/openssl')
-rw-r--r--dev-libs/openssl/ChangeLog7
-rwxr-xr-xdev-libs/openssl/files/gentoo.config-0.9.7g16
2 files changed, 17 insertions, 6 deletions
diff --git a/dev-libs/openssl/ChangeLog b/dev-libs/openssl/ChangeLog
index 95df324ca9a7..684c96884d31 100644
--- a/dev-libs/openssl/ChangeLog
+++ b/dev-libs/openssl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/openssl
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.121 2005/06/13 12:05:45 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.122 2005/06/13 14:32:58 flameeyes Exp $
+
+ 13 Jun 2005; Diego Pettenò <flameeyes@gentoo.org>
+ files/gentoo.config-0.9.7g:
+ Unbreak uclibc cross-compilation and beautify the script using a case
+ instead of a series of ifs.
13 Jun 2005; Diego Pettenò <flameeyes@gentoo.org>
files/gentoo.config-0.9.7g, openssl-0.9.7g.ebuild:
diff --git a/dev-libs/openssl/files/gentoo.config-0.9.7g b/dev-libs/openssl/files/gentoo.config-0.9.7g
index a1c43aad83f8..35aec306b818 100755
--- a/dev-libs/openssl/files/gentoo.config-0.9.7g
+++ b/dev-libs/openssl/files/gentoo.config-0.9.7g
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/files/gentoo.config-0.9.7g,v 1.3 2005/06/13 12:05:45 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/files/gentoo.config-0.9.7g,v 1.4 2005/06/13 14:32:58 flameeyes Exp $
# Openssl doesn't play along nicely with cross-compiling
# like autotools based projects, so let's teach it new tricks.
@@ -11,7 +11,7 @@
case ${CHOST} in
- *-uclibc-*) system="linux";;
+ *-uclibc*) system="linux";;
*-gnu*) system="linux";;
*-freebsd*) system="FreeBSD";;
esac
@@ -21,7 +21,8 @@ if [[ ${CC} == "ccc" ]] ; then
compiler=${CC}
fi
-if [[ ${system} == "linux" ]]; then
+case ${system} in
+linux)
machine=""
case ${CHOST} in
alphaev56*) machine=alpha+bwx-${compiler};;
@@ -60,7 +61,8 @@ if [[ ${system} == "linux" ]]; then
s390*) machine=s390;;
x86_64*) machine=x86_64;;
esac
-elif [[ "${system}" == "FreeBSD" ]]; then
+;;
+FreeBSD)
machine=""
case ${CHOST} in
sparc64*) machine=sparc64;;
@@ -68,7 +70,11 @@ elif [[ "${system}" == "FreeBSD" ]]; then
alpha*) machine=alpha;;
*) machine=elf;;
esac
-fi
+;;
+*)
+ exit 0
+;;
+esac
if [ -n "${machine}" ] ; then
echo ${system}-${machine}