summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-10-25 18:53:59 +0000
committerMike Gilbert <floppym@gentoo.org>2012-10-25 18:53:59 +0000
commit10193f9566a7239741316f97f72b2e84c6e2bb31 (patch)
tree5dca7b3a7445a6b500d627d2baff40cf18748b04 /dev-libs
parentAdd a dependency over virtual/ssh for non-minimal installs (it's used by pkg_... (diff)
downloadgentoo-2-10193f9566a7239741316f97f72b2e84c6e2bb31.tar.gz
gentoo-2-10193f9566a7239741316f97f72b2e84c6e2bb31.tar.bz2
gentoo-2-10193f9566a7239741316f97f72b2e84c6e2bb31.zip
Version bump. Ebuild by Arfrever.
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/icu/ChangeLog7
-rw-r--r--dev-libs/icu/icu-50_rc.ebuild98
2 files changed, 104 insertions, 1 deletions
diff --git a/dev-libs/icu/ChangeLog b/dev-libs/icu/ChangeLog
index 20eab3f04360..31c5d7a21577 100644
--- a/dev-libs/icu/ChangeLog
+++ b/dev-libs/icu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/icu
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.208 2012/09/30 18:23:24 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.209 2012/10/25 18:53:59 floppym Exp $
+
+*icu-50_rc (25 Oct 2012)
+
+ 25 Oct 2012; Mike Gilbert <floppym@gentoo.org> +icu-50_rc.ebuild:
+ Version bump. Ebuild by Arfrever.
30 Sep 2012; Mike Gilbert <floppym@gentoo.org> -files/icu-49.1.1-bsd.patch,
-files/icu-49.1.1-regex.patch, -icu-49.1.1-r1.ebuild:
diff --git a/dev-libs/icu/icu-50_rc.ebuild b/dev-libs/icu/icu-50_rc.ebuild
new file mode 100644
index 000000000000..5f6923bd4c02
--- /dev/null
+++ b/dev-libs/icu/icu-50_rc.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-50_rc.ebuild,v 1.1 2012/10/25 18:53:59 floppym Exp $
+
+EAPI="5"
+
+inherit eutils versionator
+
+MAJOR_VERSION="$(get_version_component_range 1)"
+if [[ "${PV}" =~ ^[[:digit:]]+_rc[[:digit:]]*$ ]]; then
+ MINOR_VERSION="1"
+else
+ MINOR_VERSION="$(get_version_component_range 2)"
+fi
+
+DESCRIPTION="International Components for Unicode"
+HOMEPAGE="http://www.icu-project.org/"
+
+BASE_URI="http://download.icu-project.org/files/icu4c/${PV/_/}"
+SRC_ARCHIVE="icu4c-${PV//./_}-src.tgz"
+DOCS_ARCHIVE="icu4c-${PV//./_}-docs.zip"
+
+SRC_URI="${BASE_URI}/${SRC_ARCHIVE}
+ doc? ( ${BASE_URI}/${DOCS_ARCHIVE} )"
+
+LICENSE="BSD"
+SLOT="0/50"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="debug doc examples static-libs"
+
+DEPEND="doc? ( app-arch/unzip )"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}/source"
+
+QA_DT_NEEDED="/usr/lib.*/libicudata\.so\.${MAJOR_VERSION}\.${MINOR_VERSION}.*"
+QA_FLAGS_IGNORED="/usr/lib.*/libicudata\.so\.${MAJOR_VERSION}\.${MINOR_VERSION}.*"
+
+src_unpack() {
+ unpack "${SRC_ARCHIVE}"
+ if use doc; then
+ mkdir docs
+ pushd docs > /dev/null
+ unpack "${DOCS_ARCHIVE}"
+ popd > /dev/null
+ fi
+}
+
+src_prepare() {
+ # Do not hardcode flags into icu-config.
+ # https://ssl.icu-project.org/trac/ticket/6102
+ local variable
+ for variable in CFLAGS CPPFLAGS CXXFLAGS FFLAGS LDFLAGS; do
+ sed -i -e "/^${variable} =.*/s:@${variable}@::" config/Makefile.inc.in || die "sed failed"
+ done
+
+ sed -e "s/#define U_DISABLE_RENAMING 0/#define U_DISABLE_RENAMING 1/" -i common/unicode/uconfig.h
+
+ epatch "${FILESDIR}/${PN}-4.8.1-fix_binformat_fonts.patch"
+ epatch "${FILESDIR}/${PN}-4.8.1.1-fix_ltr.patch"
+}
+
+src_configure() {
+ econf \
+ --disable-renaming \
+ $(use_enable debug) \
+ $(use_enable examples samples) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake VERBOSE="1"
+}
+
+src_test() {
+ # INTLTEST_OPTS: intltest options
+ # -e: Exhaustive testing
+ # -l: Reporting of memory leaks
+ # -v: Increased verbosity
+ # IOTEST_OPTS: iotest options
+ # -e: Exhaustive testing
+ # -v: Increased verbosity
+ # CINTLTST_OPTS: cintltst options
+ # -e: Exhaustive testing
+ # -v: Increased verbosity
+ emake -j1 VERBOSE="1" check
+}
+
+src_install() {
+ emake DESTDIR="${D}" VERBOSE="1" install
+
+ dohtml ../readme.html
+ dodoc ../unicode-license.txt
+ if use doc; then
+ insinto /usr/share/doc/${PF}/html/api
+ doins -r "${WORKDIR}/docs/"*
+ fi
+}