summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-10-17 14:16:38 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-10-17 14:16:38 +0000
commit13ed08cb5b6aa6b15dcacadeeae5f0ff62f35398 (patch)
tree41c495bf11ddc2f611f4df5d071a3ffff846f889 /dev-libs
parentnew version (diff)
downloadgentoo-2-13ed08cb5b6aa6b15dcacadeeae5f0ff62f35398.tar.gz
gentoo-2-13ed08cb5b6aa6b15dcacadeeae5f0ff62f35398.tar.bz2
gentoo-2-13ed08cb5b6aa6b15dcacadeeae5f0ff62f35398.zip
liblapack.la installed in correct location
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/atlas/ChangeLog10
-rw-r--r--dev-libs/atlas/atlas-3.2.1-r1.ebuild68
-rw-r--r--dev-libs/atlas/files/digest-atlas-3.2.1-r11
3 files changed, 78 insertions, 1 deletions
diff --git a/dev-libs/atlas/ChangeLog b/dev-libs/atlas/ChangeLog
index f46b1f34f08b..2bc27285b1b9 100644
--- a/dev-libs/atlas/ChangeLog
+++ b/dev-libs/atlas/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/atlas
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/atlas/ChangeLog,v 1.1 2002/02/01 21:53:11 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atlas/ChangeLog,v 1.2 2002/10/17 14:16:38 seemant Exp $
+
+*atlas-3.2.1-r1 (17 Oct 2002)
+
+ 17 Oct 2002; Seemant Kulleen <seemant@gentoo.org> atlas-3.2.1-r1.ebuild
+ files/digest-atlas-3.2.1-r1 :
+
+ liblapack.a is now in /usr/lib where it belongs, instead of /usr/share/
+ Thanks to: stephen@theboulets.net (Stephen Boulet) in bug #9081.
*atlas-3.2.1 (1 Feb 2002)
diff --git a/dev-libs/atlas/atlas-3.2.1-r1.ebuild b/dev-libs/atlas/atlas-3.2.1-r1.ebuild
new file mode 100644
index 000000000000..8d6990b2bf41
--- /dev/null
+++ b/dev-libs/atlas/atlas-3.2.1-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atlas/atlas-3.2.1-r1.ebuild,v 1.1 2002/10/17 14:16:38 seemant Exp $
+
+S=${WORKDIR}/ATLAS
+DESCRIPTION="Automatically Tuned Linear Algebra Software (BLAS implementation)."
+SRC_URI="http://www.netlib.org/atlas/${PN}${PV}.tgz"
+HOMEPAGE="http://math-atlas.sourceforge.net/"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="x86 sparc sparc64"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+#Make is actually an interactive configuration step.
+#The configuration is highly sensitive to your specific machine.
+#Although it is quite good, it will default to accuracy over speed.
+#Powertweakers might want to configure interactively (also for cross-compile)
+# by uncommenting the next line and commenting the yes ""| make || die line .
+# make || die
+
+#atlas will automatically do a parallel make if possible.
+ yes "" | make || die
+
+#Let's go grab the architecture determined by the configure
+ cd ${S}/bin
+
+#There might be a better way to do this!?!
+#We can assume "Linux" for a Gentoo Linux system.
+#Need ATLAS_ARCH in src_install too.
+ ATLAS_ARCH=$(ls -d Linux*)
+
+ cd ${S}
+#This doesn't install into the live / file system.
+#It installs into ${S}/lib/Linux*
+ make install arch=${ATLAS_ARCH} || die
+
+}
+
+src_install () {
+
+ cd ${S}/lib/${ATLAS_ARCH}
+
+ insinto /usr/lib
+ dolib.a libatlas.a libcblas.a libf77blas.a libtstatlas.a
+
+#the atlas liblapack.a library is not a complete lapack library,
+#just the atlas optimizable objects. Store it some place safe
+#where we can grab it when building the complete lapack library.
+ insinto /usr/lib
+ doins liblapack.a
+
+ cd ${S}/include/${ATLAS_ARCH}
+
+ insinto /usr/include
+ doins *.h
+
+ cd ${S}
+
+ dodoc README INSTALL.txt
+ dodoc doc/*.txt
+ insinto /usr/share/doc/${P}/ps
+ doins doc/*.ps
+ dodoc bin/${ATLAS_ARCH}/INSTALL_LOG/SUMMARY.LOG
+}
diff --git a/dev-libs/atlas/files/digest-atlas-3.2.1-r1 b/dev-libs/atlas/files/digest-atlas-3.2.1-r1
new file mode 100644
index 000000000000..77bd5e430a73
--- /dev/null
+++ b/dev-libs/atlas/files/digest-atlas-3.2.1-r1
@@ -0,0 +1 @@
+MD5 713784ea1a5f3ac5b0837a79bbbe1089 atlas3.2.1.tgz 2087301