summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-28 02:12:50 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-28 02:12:50 +0000
commit1fcc204e4db83c65b5880f381edbed57f9e6f526 (patch)
treeb2db61f2ca440777fb874e6964545dea31c0390d /dev-libs
parentStable on sparc wrt security bug #77408. (diff)
downloadgentoo-2-1fcc204e4db83c65b5880f381edbed57f9e6f526.tar.gz
gentoo-2-1fcc204e4db83c65b5880f381edbed57f9e6f526.tar.bz2
gentoo-2-1fcc204e4db83c65b5880f381edbed57f9e6f526.zip
remove USE=macos cruft
(Portage version: 2.0.51-r15)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/glib/glib-2.4.4.ebuild8
-rw-r--r--dev-libs/glib/glib-2.4.5.ebuild8
-rw-r--r--dev-libs/glib/glib-2.4.6.ebuild10
-rw-r--r--dev-libs/glib/glib-2.4.7.ebuild8
-rw-r--r--dev-libs/glib/glib-2.4.8.ebuild10
-rw-r--r--dev-libs/glib/glib-2.6.0.ebuild10
-rw-r--r--dev-libs/glib/glib-2.6.1.ebuild11
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.2.0.ebuild4
-rw-r--r--dev-libs/libusb/libusb-0.1.8.ebuild4
9 files changed, 29 insertions, 44 deletions
diff --git a/dev-libs/glib/glib-2.4.4.ebuild b/dev-libs/glib/glib-2.4.4.ebuild
index 461694108760..b8f8c09ba8cb 100644
--- a/dev-libs/glib/glib-2.4.4.ebuild
+++ b/dev-libs/glib/glib-2.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.4.4.ebuild,v 1.13 2005/01/02 04:54:32 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.4.4.ebuild,v 1.14 2005/01/28 02:12:21 vapier Exp $
inherit libtool
@@ -21,9 +21,7 @@ RDEPEND="virtual/libc"
src_compile() {
- if use macos; then
- glibtoolize
- elif use ppc-macos; then
+ if use ppc-macos; then
glibtoolize
else
elibtoolize
@@ -44,7 +42,7 @@ src_install() {
make DESTDIR=${D} install || die
# Do not install charset.alias for ppc-macos since it already exists.
- if (use macos || use ppc-macos); then
+ if use ppc-macos ; then
einfo "Not installing charset.alias on macos"
rm ${D}/usr/lib/charset.alias || die "Cannot remove charset.alias from the image"
fi
diff --git a/dev-libs/glib/glib-2.4.5.ebuild b/dev-libs/glib/glib-2.4.5.ebuild
index 5b32da09b109..85ddcedcb047 100644
--- a/dev-libs/glib/glib-2.4.5.ebuild
+++ b/dev-libs/glib/glib-2.4.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.4.5.ebuild,v 1.13 2005/01/02 04:54:32 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.4.5.ebuild,v 1.14 2005/01/28 02:12:21 vapier Exp $
inherit libtool
@@ -19,9 +19,7 @@ DEPEND=">=dev-util/pkgconfig-0.14
RDEPEND="virtual/libc"
src_compile() {
- if use macos; then
- glibtoolize
- elif use ppc-macos; then
+ if use ppc-macos; then
glibtoolize
else
elibtoolize
@@ -40,7 +38,7 @@ src_install() {
make DESTDIR=${D} install || die
# Do not install charset.alias for ppc-macos since it already exists.
- if (use macos || use ppc-macos); then
+ if use ppc-macos ; then
einfo "Not installing charset.alias on macos"
rm ${D}/usr/lib/charset.alias || die "Cannot remove charset.alias from the image"
fi
diff --git a/dev-libs/glib/glib-2.4.6.ebuild b/dev-libs/glib/glib-2.4.6.ebuild
index 185393f52c12..bf71e04f9233 100644
--- a/dev-libs/glib/glib-2.4.6.ebuild
+++ b/dev-libs/glib/glib-2.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.4.6.ebuild,v 1.14 2005/01/02 04:54:32 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.4.6.ebuild,v 1.15 2005/01/28 02:12:21 vapier Exp $
inherit libtool
@@ -10,7 +10,7 @@ SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.4/${P}.tar.bz2"
LICENSE="LGPL-2"
SLOT="2"
-KEYWORDS="x86 ppc sparc mips alpha ~arm hppa amd64 ~ia64 ~ppc64 ~s390 ~ppc-macos"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ~ppc64 ~ppc-macos s390 sparc x86"
IUSE="doc"
DEPEND=">=dev-util/pkgconfig-0.14
@@ -20,9 +20,7 @@ RDEPEND="virtual/libc"
src_compile() {
- if use macos; then
- glibtoolize
- elif use ppc-macos; then
+ if use ppc-macos; then
glibtoolize
else
elibtoolize
@@ -43,7 +41,7 @@ src_install() {
make DESTDIR=${D} install || die
# Do not install charset.alias for ppc-macos since it already exists.
- if (use macos || use ppc-macos); then
+ if use ppc-macos ; then
einfo "Not installing charset.alias on macos"
rm ${D}/usr/lib/charset.alias || die "Cannot remove charset.alias from the image"
fi
diff --git a/dev-libs/glib/glib-2.4.7.ebuild b/dev-libs/glib/glib-2.4.7.ebuild
index a68b2923db76..5624623092ce 100644
--- a/dev-libs/glib/glib-2.4.7.ebuild
+++ b/dev-libs/glib/glib-2.4.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.4.7.ebuild,v 1.6 2005/01/02 04:54:32 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.4.7.ebuild,v 1.7 2005/01/28 02:12:21 vapier Exp $
inherit libtool
@@ -21,9 +21,7 @@ RDEPEND="virtual/libc"
src_compile() {
- if use macos; then
- glibtoolize
- elif use ppc-macos; then
+ if use ppc-macos; then
glibtoolize
else
elibtoolize
@@ -44,7 +42,7 @@ src_install() {
make DESTDIR=${D} install || die
# Do not install charset.alias for ppc-macos since it already exists.
- if (use macos || use ppc-macos); then
+ if use ppc-macos ; then
einfo "Not installing charset.alias on macos"
rm ${D}/usr/lib/charset.alias || die "Cannot remove charset.alias from the image"
fi
diff --git a/dev-libs/glib/glib-2.4.8.ebuild b/dev-libs/glib/glib-2.4.8.ebuild
index 0b12d4e4c435..55615ecf7575 100644
--- a/dev-libs/glib/glib-2.4.8.ebuild
+++ b/dev-libs/glib/glib-2.4.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.4.8.ebuild,v 1.8 2005/01/22 07:14:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.4.8.ebuild,v 1.9 2005/01/28 02:12:21 vapier Exp $
inherit libtool
@@ -10,7 +10,7 @@ SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.4/${P}.tar.bz2"
LICENSE="LGPL-2"
SLOT="2"
-KEYWORDS="x86 ppc sparc ~mips alpha arm hppa amd64 ia64 ~ppc64 s390 ~ppc-macos"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ~ppc64 ~ppc-macos s390 sparc x86"
IUSE="doc"
DEPEND=">=dev-util/pkgconfig-0.14
@@ -21,9 +21,7 @@ RDEPEND="virtual/libc"
src_compile() {
- if use macos; then
- glibtoolize
- elif use ppc-macos; then
+ if use ppc-macos; then
glibtoolize
else
elibtoolize
@@ -44,7 +42,7 @@ src_install() {
make DESTDIR=${D} install || die
# Do not install charset.alias for ppc-macos since it already exists.
- if (use macos || use ppc-macos); then
+ if use ppc-macos ; then
einfo "Not installing charset.alias on macos"
rm ${D}/usr/lib/charset.alias || die "Cannot remove charset.alias from the image"
fi
diff --git a/dev-libs/glib/glib-2.6.0.ebuild b/dev-libs/glib/glib-2.6.0.ebuild
index 517636542f00..9ec27cc17914 100644
--- a/dev-libs/glib/glib-2.6.0.ebuild
+++ b/dev-libs/glib/glib-2.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.6.0.ebuild,v 1.3 2005/01/02 04:54:32 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.6.0.ebuild,v 1.4 2005/01/28 02:12:21 vapier Exp $
inherit libtool
@@ -10,7 +10,7 @@ SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.6/${P}.tar.bz2"
LICENSE="LGPL-2"
SLOT="2"
-KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390 ~ppc-macos"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~ppc-macos ~s390 ~sparc ~x86"
IUSE="doc static"
DEPEND=">=dev-util/pkgconfig-0.14
@@ -21,9 +21,7 @@ RDEPEND="virtual/libc"
src_compile() {
- if use macos; then
- glibtoolize
- elif use ppc-macos; then
+ if use ppc-macos; then
glibtoolize
else
elibtoolize
@@ -44,7 +42,7 @@ src_install() {
make DESTDIR=${D} install || die
# Do not install charset.alias for ppc-macos since it already exists.
- if (use macos || use ppc-macos); then
+ if use ppc-macos ; then
einfo "Not installing charset.alias on macos"
rm ${D}/usr/lib/charset.alias || die "Cannot remove charset.alias from the image"
fi
diff --git a/dev-libs/glib/glib-2.6.1.ebuild b/dev-libs/glib/glib-2.6.1.ebuild
index a56566e63614..38421fef50e6 100644
--- a/dev-libs/glib/glib-2.6.1.ebuild
+++ b/dev-libs/glib/glib-2.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.6.1.ebuild,v 1.1 2005/01/16 21:37:31 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.6.1.ebuild,v 1.2 2005/01/28 02:12:21 vapier Exp $
inherit libtool
@@ -10,20 +10,17 @@ SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.6/${P}.tar.bz2"
LICENSE="LGPL-2"
SLOT="2"
-KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390 ~ppc-macos"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~ppc-macos ~s390 ~sparc ~x86"
IUSE="doc static"
DEPEND=">=dev-util/pkgconfig-0.14
>=sys-devel/gettext-0.11
doc? ( >=dev-util/gtk-doc-1 )"
-
RDEPEND="virtual/libc"
src_compile() {
- if use macos; then
- glibtoolize
- elif use ppc-macos; then
+ if use ppc-macos; then
glibtoolize
# else
# elibtoolize
@@ -44,7 +41,7 @@ src_install() {
make DESTDIR=${D} install || die
# Do not install charset.alias for ppc-macos since it already exists.
- if (use macos || use ppc-macos); then
+ if use ppc-macos ; then
einfo "Not installing charset.alias on macos"
rm ${D}/usr/lib/charset.alias || die "Cannot remove charset.alias from the image"
fi
diff --git a/dev-libs/libgcrypt/libgcrypt-1.2.0.ebuild b/dev-libs/libgcrypt/libgcrypt-1.2.0.ebuild
index a728a1348d59..0569feb5b9bb 100644
--- a/dev-libs/libgcrypt/libgcrypt-1.2.0.ebuild
+++ b/dev-libs/libgcrypt/libgcrypt-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.2.0.ebuild,v 1.16 2005/01/12 14:46:12 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.2.0.ebuild,v 1.17 2005/01/28 02:12:50 vapier Exp $
DESCRIPTION="general purpose crypto library based on the code used in GnuPG"
HOMEPAGE="http://www.gnupg.org/"
@@ -24,7 +24,7 @@ src_install() {
dodoc AUTHORS BUGS ChangeLog COPYING* NEWS README* THANKS TODO VERSION
# backwards compat symlinks
- if ! ( use macos || use ppc-macos ) ; then
+ if ! use ppc-macos ; then
dosym libgcrypt.so.11 /usr/lib/libgcrypt.so.7
dosym libgcrypt-pth.so.11 /usr/lib/libgcrypt-pth.so.7
dosym libgcrypt-pthread.so.11 /usr/lib/libgcrypt-pthread.so.7
diff --git a/dev-libs/libusb/libusb-0.1.8.ebuild b/dev-libs/libusb/libusb-0.1.8.ebuild
index 50902161c50e..0db2a1cc0223 100644
--- a/dev-libs/libusb/libusb-0.1.8.ebuild
+++ b/dev-libs/libusb/libusb-0.1.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libusb/libusb-0.1.8.ebuild,v 1.17 2005/01/01 20:11:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libusb/libusb-0.1.8.ebuild,v 1.18 2005/01/28 02:11:53 vapier Exp $
inherit eutils
@@ -33,7 +33,7 @@ src_compile() {
local myconf
# keep this otherwise libraries will not have .so extensions
- ( use macos || use ppc-macos ) \
+ use ppc-macos \
&& glibtoolize --force \
|| libtoolize --force