summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-02-26 04:48:28 +0000
committerTim Harder <radhermit@gentoo.org>2015-02-26 04:48:28 +0000
commit4f22862275834a8db423a12b1bda4afbd14a026e (patch)
tree29ec13299b41303de6fa93e126ab2b2223d63340 /dev-libs
parentbumping, adds py3 support too (diff)
downloadgentoo-2-4f22862275834a8db423a12b1bda4afbd14a026e.tar.gz
gentoo-2-4f22862275834a8db423a12b1bda4afbd14a026e.tar.bz2
gentoo-2-4f22862275834a8db423a12b1bda4afbd14a026e.zip
Add zlib use flag (bug #541396).
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/protobuf/ChangeLog9
-rw-r--r--dev-libs/protobuf/protobuf-2.5.0-r3.ebuild140
-rw-r--r--dev-libs/protobuf/protobuf-2.6.1-r2.ebuild141
3 files changed, 289 insertions, 1 deletions
diff --git a/dev-libs/protobuf/ChangeLog b/dev-libs/protobuf/ChangeLog
index 430d6530349c..ae7cafd1014e 100644
--- a/dev-libs/protobuf/ChangeLog
+++ b/dev-libs/protobuf/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/protobuf
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/ChangeLog,v 1.77 2015/01/26 09:37:24 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/ChangeLog,v 1.78 2015/02/26 04:48:28 radhermit Exp $
+
+*protobuf-2.6.1-r2 (26 Feb 2015)
+*protobuf-2.5.0-r3 (26 Feb 2015)
+
+ 26 Feb 2015; Tim Harder <radhermit@gentoo.org> +protobuf-2.5.0-r3.ebuild,
+ +protobuf-2.6.1-r2.ebuild:
+ Add zlib use flag (bug #541396).
26 Jan 2015; Agostino Sarubbo <ago@gentoo.org> protobuf-2.5.0-r2.ebuild:
Stable for x86, wrt bug #536794
diff --git a/dev-libs/protobuf/protobuf-2.5.0-r3.ebuild b/dev-libs/protobuf/protobuf-2.5.0-r3.ebuild
new file mode 100644
index 000000000000..e8565aa8978d
--- /dev/null
+++ b/dev-libs/protobuf/protobuf-2.5.0-r3.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/protobuf-2.5.0-r3.ebuild,v 1.1 2015/02/26 04:48:28 radhermit Exp $
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+JAVA_PKG_IUSE="source"
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_OPTIONAL=1
+
+inherit autotools-multilib eutils flag-o-matic distutils-r1 java-pkg-opt-2 elisp-common
+
+DESCRIPTION="Google's Protocol Buffers -- an efficient method of encoding structured data"
+HOMEPAGE="http://code.google.com/p/protobuf/"
+SRC_URI="http://protobuf.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0/8" # subslot = soname major version
+KEYWORDS="~amd64 ~arm -hppa ~ia64 ~mips -ppc -ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="emacs examples java python static-libs vim-syntax zlib"
+
+CDEPEND="emacs? ( virtual/emacs )
+ python? ( ${PYTHON_DEPS} )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )"
+DEPEND="${CDEPEND}
+ java? ( >=virtual/jdk-1.5 )
+ python? ( dev-python/setuptools[${PYTHON_USEDEP}] )"
+RDEPEND="${CDEPEND}
+ java? ( >=virtual/jre-1.5 )"
+
+src_prepare() {
+ append-cxxflags -DGOOGLE_PROTOBUF_NO_RTTI
+
+ epatch "${FILESDIR}"/${P}-x32.patch
+
+ # breaks Darwin, bug #472514
+ [[ ${CHOST} != *-darwin* ]] && epatch "${FILESDIR}"/${PN}-2.3.0-asneeded-2.patch
+
+ # fix build with emacs-24.4 (bug #524100)
+ epatch "${FILESDIR}"/${P}-emacs-24.4.patch
+
+ autotools-multilib_src_prepare
+
+ if use python; then
+ cd python && distutils-r1_src_prepare
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with zlib)
+ )
+ autotools-multilib_src_configure
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi; then
+ if use python; then
+ einfo "Compiling Python library ..."
+ pushd "${S}"/python >/dev/null
+ PROTOC="${BUILD_DIR}"/src/protoc distutils-r1_src_compile
+ popd >/dev/null
+ fi
+
+ if use java; then
+ einfo "Compiling Java library ..."
+ pushd "${S}" >/dev/null
+ "${BUILD_DIR}"/src/protoc --java_out=java/src/main/java --proto_path=src src/google/protobuf/descriptor.proto
+ mkdir java/build
+ pushd java/src/main/java >/dev/null
+ ejavac -d ../../../build $(find . -name '*.java') || die "java compilation failed"
+ popd >/dev/null
+ jar cf ${PN}.jar -C java/build . || die "jar failed"
+ popd >/dev/null
+ fi
+ fi
+}
+
+src_compile() {
+ autotools-multilib_src_compile
+
+ if use emacs; then
+ elisp-compile "${S}"/editors/protobuf-mode.el
+ fi
+}
+
+src_test() {
+ autotools-multilib_src_test check
+
+ if use python; then
+ pushd python >/dev/null
+ distutils-r1_src_test
+ popd >/dev/null
+ fi
+}
+
+src_install() {
+ autotools-multilib_src_install
+
+ dodoc CHANGES.txt CONTRIBUTORS.txt README.txt
+
+ if use python; then
+ pushd python >/dev/null
+ distutils-r1_src_install
+ popd >/dev/null
+ fi
+
+ if use java; then
+ java-pkg_dojar ${PN}.jar
+ use source && java-pkg_dosrc java/src/main/java/*
+ fi
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins editors/proto.vim
+ insinto /usr/share/vim/vimfiles/ftdetect/
+ doins "${FILESDIR}"/proto.vim
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} editors/protobuf-mode.el*
+ elisp-site-file-install "${FILESDIR}"/70${PN}-gentoo.el
+ fi
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-libs/protobuf/protobuf-2.6.1-r2.ebuild b/dev-libs/protobuf/protobuf-2.6.1-r2.ebuild
new file mode 100644
index 000000000000..2bdd562e4ad3
--- /dev/null
+++ b/dev-libs/protobuf/protobuf-2.6.1-r2.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/protobuf-2.6.1-r2.ebuild,v 1.1 2015/02/26 04:48:28 radhermit Exp $
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+JAVA_PKG_IUSE="source"
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_OPTIONAL=1
+
+inherit autotools-multilib eutils flag-o-matic distutils-r1 java-pkg-opt-2 elisp-common
+
+DESCRIPTION="Google's Protocol Buffers -- an efficient method of encoding structured data"
+HOMEPAGE="http://code.google.com/p/protobuf/ https://github.com/google/protobuf/"
+SRC_URI="https://github.com/google/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0/9" # subslot = soname major version
+KEYWORDS="~amd64 ~arm -hppa ~mips -ppc -ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="emacs examples java python static-libs vim-syntax zlib"
+
+CDEPEND="emacs? ( virtual/emacs )
+ python? ( ${PYTHON_DEPS} )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )"
+DEPEND="${CDEPEND}
+ java? ( >=virtual/jdk-1.5 )
+ python? (
+ dev-python/google-apputils[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${CDEPEND}
+ java? ( >=virtual/jre-1.5 )"
+
+src_prepare() {
+ append-cxxflags -DGOOGLE_PROTOBUF_NO_RTTI
+
+ # breaks Darwin, bug #472514
+ [[ ${CHOST} != *-darwin* ]] && epatch "${FILESDIR}"/${PN}-2.3.0-asneeded-2.patch
+
+ # fix build with emacs-24.4 (bug #524100)
+ epatch "${FILESDIR}"/${PN}-2.5.0-emacs-24.4.patch
+
+ autotools-multilib_src_prepare
+
+ if use python; then
+ cd python && distutils-r1_src_prepare
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with zlib)
+ )
+ autotools-multilib_src_configure
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi; then
+ if use python; then
+ einfo "Compiling Python library ..."
+ pushd "${S}"/python >/dev/null
+ PROTOC="${BUILD_DIR}"/src/protoc distutils-r1_src_compile
+ popd >/dev/null
+ fi
+
+ if use java; then
+ einfo "Compiling Java library ..."
+ pushd "${S}" >/dev/null
+ "${BUILD_DIR}"/src/protoc --java_out=java/src/main/java --proto_path=src src/google/protobuf/descriptor.proto
+ mkdir java/build
+ pushd java/src/main/java >/dev/null
+ ejavac -d ../../../build $(find . -name '*.java') || die "java compilation failed"
+ popd >/dev/null
+ jar cf ${PN}.jar -C java/build . || die "jar failed"
+ popd >/dev/null
+ fi
+ fi
+}
+
+src_compile() {
+ autotools-multilib_src_compile
+
+ if use emacs; then
+ elisp-compile "${S}"/editors/protobuf-mode.el
+ fi
+}
+
+src_test() {
+ autotools-multilib_src_test check
+
+ if use python; then
+ pushd python >/dev/null
+ distutils-r1_src_test
+ popd >/dev/null
+ fi
+}
+
+src_install() {
+ autotools-multilib_src_install
+
+ dodoc CHANGES.txt CONTRIBUTORS.txt README.md
+
+ if use python; then
+ pushd python >/dev/null
+ distutils-r1_src_install
+ popd >/dev/null
+ fi
+
+ if use java; then
+ java-pkg_dojar ${PN}.jar
+ use source && java-pkg_dosrc java/src/main/java/*
+ fi
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins editors/proto.vim
+ insinto /usr/share/vim/vimfiles/ftdetect/
+ doins "${FILESDIR}"/proto.vim
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} editors/protobuf-mode.el*
+ elisp-site-file-install "${FILESDIR}"/70${PN}-gentoo.el
+ fi
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}