summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-01-21 14:08:49 +0000
committerMarinus Schraal <foser@gentoo.org>2003-01-21 14:08:49 +0000
commit62df371ca66624e514305a10b73a675863b02c91 (patch)
tree9abf4cdd04d2d69e3511aeea1ef1c0552572e78e /dev-libs
parentchanged to -ppc since DEPENDs are -ppc (sun-jdk) (diff)
downloadgentoo-2-62df371ca66624e514305a10b73a675863b02c91.tar.gz
gentoo-2-62df371ca66624e514305a10b73a675863b02c91.tar.bz2
gentoo-2-62df371ca66624e514305a10b73a675863b02c91.zip
New version
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libxml2/ChangeLog8
-rw-r--r--dev-libs/libxml2/files/digest-libxml2-2.4.301
-rw-r--r--dev-libs/libxml2/libxml2-2.4.30.ebuild55
3 files changed, 63 insertions, 1 deletions
diff --git a/dev-libs/libxml2/ChangeLog b/dev-libs/libxml2/ChangeLog
index b74b67da43c1..59969b7c4d4e 100644
--- a/dev-libs/libxml2/ChangeLog
+++ b/dev-libs/libxml2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libxml2
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.22 2002/12/22 10:32:10 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.23 2003/01/21 14:08:49 foser Exp $
+
+*libxml2-2.4.30 (07 Jan 2003)
+
+ 07 Jan 2003; foser <foser@gentoo.org> libxml2-2.4.30.ebuild :
+ New version
+ Added stripping of all unknown CFLAGS (bug #14265)
*libxml2-2.4.28-r1 (22 Dec 2002)
diff --git a/dev-libs/libxml2/files/digest-libxml2-2.4.30 b/dev-libs/libxml2/files/digest-libxml2-2.4.30
new file mode 100644
index 000000000000..c8db87c7335f
--- /dev/null
+++ b/dev-libs/libxml2/files/digest-libxml2-2.4.30
@@ -0,0 +1 @@
+MD5 1d40d3ead987c858805b70d2fe84a6c4 libxml2-2.4.30.tar.bz2 1974050
diff --git a/dev-libs/libxml2/libxml2-2.4.30.ebuild b/dev-libs/libxml2/libxml2-2.4.30.ebuild
new file mode 100644
index 000000000000..91ff825627e6
--- /dev/null
+++ b/dev-libs/libxml2/libxml2-2.4.30.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.4.30.ebuild,v 1.1 2003/01/21 14:08:49 foser Exp $
+
+inherit eutils libtool gnome.org flag-o-matic
+
+IUSE="python readline"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Version 2 of the library to manipulate XML files"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND="sys-libs/zlib
+ python? ( dev-lang/python )
+ readline? ( sys-libs/readline )"
+
+SLOT="2"
+LICENSE="MIT"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha"
+
+src_compile() {
+ # Fix .la files of python site packages
+ elibtoolize
+
+ # fix bug 14265
+ strip-flags
+
+ local myconf=""
+
+ # This breaks gnome2 (libgnomeprint for instance fails to compile with
+ # fresh install, and existing) - <azarah@gentoo.org> (22 Dec 2002).
+ #use zlib && myconf="--with-zlib" || myconf="--without-zlib"
+
+ use python && myconf="${myconf} --with-python" \
+ || myconf="${myconf} --without-python"
+ use readline && myconf="${myconf} --with-readline" \
+ || myconf="${myconf} --without-readline"
+
+ econf --with-zlib ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make \
+ DESTDIR=${D} \
+ DOCS_DIR=/usr/share/doc/${PF}/python \
+ EXAMPLE_DIR=/usr/share/doc/${PF}/python/example \
+ BASE_DIR=/usr/share/doc \
+ DOC_MODULE=${PF} \
+ EXAMPLES_DIR=/usr/share/doc/${PF}/example \
+ TARGET_DIR=/usr/share/doc/${PF}/html \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog NEWS README
+}