summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-04-06 14:58:23 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-04-06 14:58:23 +0000
commit68788e23b6add4661302b570bd249f086e8c46c6 (patch)
tree9ea72d957cb8cb9b0336c0d243472e9112cc7185 /dev-libs
parentVersion bump. (diff)
downloadgentoo-2-68788e23b6add4661302b570bd249f086e8c46c6.tar.gz
gentoo-2-68788e23b6add4661302b570bd249f086e8c46c6.tar.bz2
gentoo-2-68788e23b6add4661302b570bd249f086e8c46c6.zip
old
(Portage version: 2.2.0_alpha99/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libffi/ChangeLog7
-rw-r--r--dev-libs/libffi/files/libffi-3.0.11_rc2-fix-ppc64-compile.patch52
-rw-r--r--dev-libs/libffi/libffi-3.0.11_rc1.ebuild59
-rw-r--r--dev-libs/libffi/libffi-3.0.11_rc2.ebuild61
-rw-r--r--dev-libs/libffi/libffi-3.0.11_rc3.ebuild4
5 files changed, 8 insertions, 175 deletions
diff --git a/dev-libs/libffi/ChangeLog b/dev-libs/libffi/ChangeLog
index 5409be0761fd..c1bb39ef3cc3 100644
--- a/dev-libs/libffi/ChangeLog
+++ b/dev-libs/libffi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libffi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libffi/ChangeLog,v 1.139 2012/04/06 14:56:42 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libffi/ChangeLog,v 1.140 2012/04/06 14:58:23 ssuominen Exp $
+
+ 06 Apr 2012; Samuli Suominen <ssuominen@gentoo.org>
+ -libffi-3.0.11_rc1.ebuild, -libffi-3.0.11_rc2.ebuild,
+ -files/libffi-3.0.11_rc2-fix-ppc64-compile.patch:
+ old
*libffi-3.0.11_rc3 (06 Apr 2012)
diff --git a/dev-libs/libffi/files/libffi-3.0.11_rc2-fix-ppc64-compile.patch b/dev-libs/libffi/files/libffi-3.0.11_rc2-fix-ppc64-compile.patch
deleted file mode 100644
index 6f02fec6754e..000000000000
--- a/dev-libs/libffi/files/libffi-3.0.11_rc2-fix-ppc64-compile.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-http://sourceware.org/ml/libffi-discuss/2012/msg00100.html
-
---- src/powerpc/ffi.c
-+++ src/powerpc/ffi.c
-@@ -146,6 +146,7 @@
- gpr_base.u = stacktop.u - ASM_NEEDS_REGISTERS - NUM_GPR_ARG_REGISTERS;
- intarg_count = 0;
- #ifndef __NO_FPRS__
-+ double double_tmp;
- fpr_base.d = gpr_base.d - NUM_FPR_ARG_REGISTERS;
- fparg_count = 0;
- copy_space.c = ((flags & FLAG_FP_ARGUMENTS) ? fpr_base.c : gpr_base.c);
-@@ -155,9 +156,9 @@
- next_arg.u = stack + 2;
-
- /* Check that everything starts aligned properly. */
-- FFI_ASSERT (((unsigned) (char *) stack & 0xF) == 0);
-- FFI_ASSERT (((unsigned) copy_space.c & 0xF) == 0);
-- FFI_ASSERT (((unsigned) stacktop.c & 0xF) == 0);
-+ FFI_ASSERT (((unsigned long) (char *) stack & 0xF) == 0);
-+ FFI_ASSERT (((unsigned long) copy_space.c & 0xF) == 0);
-+ FFI_ASSERT (((unsigned long) stacktop.c & 0xF) == 0);
- FFI_ASSERT ((bytes & 0xF) == 0);
- FFI_ASSERT (copy_space.c >= next_arg.c);
-
-@@ -211,8 +212,6 @@
-
- case FFI_TYPE_DOUBLE:
- /* With FFI_LINUX_SOFT_FLOAT doubles are handled like UINT64. */
-- if (ecif->cif->abi == FFI_LINUX_SOFT_FLOAT)
-- goto soft_double_prep;
- double_tmp = **p_argv.d;
-
- if (fparg_count >= NUM_FPR_ARG_REGISTERS)
-@@ -925,7 +924,7 @@
- */
- unsigned int smst_buffer[2];
- extended_cif ecif;
-- unsigned int rsize;
-+ unsigned int rsize = 0;
-
- ecif.cif = cif;
- ecif.avalue = avalue;
-@@ -1132,7 +1131,7 @@
-
- if (nf < 8)
- {
-- temp = pfr->d;
-+ double temp = pfr->d;
- pfr->f = (float) temp;
- avalue[i] = pfr;
- nf++;
diff --git a/dev-libs/libffi/libffi-3.0.11_rc1.ebuild b/dev-libs/libffi/libffi-3.0.11_rc1.ebuild
deleted file mode 100644
index d33e617231e1..000000000000
--- a/dev-libs/libffi/libffi-3.0.11_rc1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libffi/libffi-3.0.11_rc1.ebuild,v 1.3 2012/02/16 22:50:00 vapier Exp $
-
-EAPI=4
-
-MY_P=${P/_/-}
-
-inherit libtool multilib toolchain-funcs eutils
-
-DESCRIPTION="a portable, high level programming interface to various calling conventions."
-HOMEPAGE="http://sourceware.org/libffi/"
-SRC_URI="ftp://sourceware.org/pub/${PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug static-libs test"
-
-RDEPEND=""
-DEPEND="test? ( dev-util/dejagnu )"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- # Detect and document broken installation of sys-devel/gcc in the build.log wrt #354903
- if ! has_version ${CATEGORY}/${PN}; then
- local base="${T}/conftest"
- echo 'int main() { }' > "${base}.c"
- $(tc-getCC) -o "${base}" "${base}.c" -lffi >&/dev/null && \
- ewarn "Found a copy of second ${PN} in your system. Uninstall it before continuing."
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.0.9-x32.patch
- elibtoolize
-}
-
-src_configure() {
- use userland_BSD && export HOST="${CHOST}"
- econf \
- $(use_enable static-libs static) \
- $(use_enable debug)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc ChangeLog* README
- rm -f "${ED}"usr/lib*/${PN}.la
-}
-
-pkg_preinst() {
- preserve_old_lib /usr/$(get_libdir)/${PN}$(get_libname 5)
-}
-
-pkg_postinst() {
- preserve_old_lib_notify /usr/$(get_libdir)/${PN}$(get_libname 5)
-}
diff --git a/dev-libs/libffi/libffi-3.0.11_rc2.ebuild b/dev-libs/libffi/libffi-3.0.11_rc2.ebuild
deleted file mode 100644
index a8da863d00c8..000000000000
--- a/dev-libs/libffi/libffi-3.0.11_rc2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libffi/libffi-3.0.11_rc2.ebuild,v 1.3 2012/03/13 18:38:10 ssuominen Exp $
-
-EAPI=4
-
-MY_P=${P/_/-}
-
-inherit libtool multilib toolchain-funcs eutils
-
-DESCRIPTION="a portable, high level programming interface to various calling conventions."
-HOMEPAGE="http://sourceware.org/libffi/"
-SRC_URI="ftp://sourceware.org/pub/${PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug static-libs test"
-
-RDEPEND=""
-DEPEND="test? ( dev-util/dejagnu )"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- # Detect and document broken installation of sys-devel/gcc in the build.log wrt #354903
- if ! has_version ${CATEGORY}/${PN}; then
- local base="${T}/conftest"
- echo 'int main() { }' > "${base}.c"
- $(tc-getCC) -o "${base}" "${base}.c" -lffi >&/dev/null && \
- ewarn "Found a copy of second ${PN} in your system. Uninstall it before continuing."
- fi
-}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-3.0.9-x32.patch \
- "${FILESDIR}"/${P}-fix-ppc64-compile.patch
- elibtoolize
-}
-
-src_configure() {
- use userland_BSD && export HOST="${CHOST}"
- econf \
- $(use_enable static-libs static) \
- $(use_enable debug)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc ChangeLog* README
- rm -f "${ED}"usr/lib*/${PN}.la
-}
-
-pkg_preinst() {
- preserve_old_lib /usr/$(get_libdir)/${PN}$(get_libname 5)
-}
-
-pkg_postinst() {
- preserve_old_lib_notify /usr/$(get_libdir)/${PN}$(get_libname 5)
-}
diff --git a/dev-libs/libffi/libffi-3.0.11_rc3.ebuild b/dev-libs/libffi/libffi-3.0.11_rc3.ebuild
index d69714e7cbea..2c964256dcf1 100644
--- a/dev-libs/libffi/libffi-3.0.11_rc3.ebuild
+++ b/dev-libs/libffi/libffi-3.0.11_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libffi/libffi-3.0.11_rc3.ebuild,v 1.1 2012/04/06 14:56:42 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libffi/libffi-3.0.11_rc3.ebuild,v 1.2 2012/04/06 14:58:23 ssuominen Exp $
EAPI=4
@@ -33,7 +33,7 @@ pkg_setup() {
if [ $? -eq = 0 ]; then
eerror "The linker reported linking against -lffi to be working while it shouldn't have."
eerror "This is wrong and you should find and delete the old copy of libffi before continuing."
- die "The system is in inconsistent state with unknown libffi installed."
+ die "The system is in inconsistent state with unknown libffi installed."
fi
fi
}