summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-03-28 18:43:29 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-03-28 18:43:29 +0000
commit7f7c089b4daf37ac15fd694e76b685d829425697 (patch)
treee1323b2873376baf486cb9593e3a69dfa6f050f6 /dev-libs
parentNew ebuild for libdivecomputer, a library for communication with dive compute... (diff)
downloadgentoo-2-7f7c089b4daf37ac15fd694e76b685d829425697.tar.gz
gentoo-2-7f7c089b4daf37ac15fd694e76b685d829425697.tar.bz2
gentoo-2-7f7c089b4daf37ac15fd694e76b685d829425697.zip
Added live ebuild for testing purposes.
(Portage version: 2.1.11.59/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libdivecomputer/ChangeLog7
-rw-r--r--dev-libs/libdivecomputer/libdivecomputer-9999.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-libs/libdivecomputer/ChangeLog b/dev-libs/libdivecomputer/ChangeLog
index d51818e28307..1dc91202274d 100644
--- a/dev-libs/libdivecomputer/ChangeLog
+++ b/dev-libs/libdivecomputer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libdivecomputer
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdivecomputer/ChangeLog,v 1.1 2013/03/28 18:32:41 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdivecomputer/ChangeLog,v 1.2 2013/03/28 18:43:29 tomwij Exp $
+
+*libdivecomputer-9999 (28 Mar 2013)
+
+ 28 Mar 2013; Tom Wijsman <TomWij@gentoo.org> +libdivecomputer-9999.ebuild:
+ Added live ebuild for testing purposes.
*libdivecomputer-0.3.0 (28 Mar 2013)
diff --git a/dev-libs/libdivecomputer/libdivecomputer-9999.ebuild b/dev-libs/libdivecomputer/libdivecomputer-9999.ebuild
new file mode 100644
index 000000000000..9bcd39cbb14c
--- /dev/null
+++ b/dev-libs/libdivecomputer/libdivecomputer-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdivecomputer/libdivecomputer-9999.ebuild,v 1.1 2013/03/28 18:43:29 tomwij Exp $
+
+EAPI="5"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://libdivecomputer.git.sourceforge.net/gitroot/libdivecomputer/libdivecomputer"
+ GIT_ECLASS="git-2"
+ AUTOTOOLIZE=yes
+fi
+
+inherit eutils autotools-utils ${GIT_ECLASS}
+
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="http://www.divesoftware.org/libdc/releases/${P}.tar.gz"
+fi
+
+DESCRIPTION="Library for communication with dive computers from various manufacturers."
+HOMEPAGE="http://www.divesoftware.org/libdc"
+LICENSE="LGPL-2.1"
+
+KEYWORDS=""
+SLOT="0"
+IUSE="usb examples +static-libs"
+
+RDEPEND="usb? ( virtual/libusb )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ if [[ -n ${AUTOTOOLIZE} ]]; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ autotools-utils_src_configure
+
+ if use usb ; then
+ sed -i 's|#define HAVE_LIBUSB 1||' config.h || die "sed failed"
+ fi
+
+ if use examples ; then
+ sed -i 's|examples||' Makefile || die "sed failed"
+ fi
+}
+
+src_compile() {
+ autotools-utils_src_compile
+}
+
+src_install() {
+ autotools-utils_src_install
+}