summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-07 08:27:06 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-07 08:27:06 +0000
commit88b5848f80a84c0605265580d544501adf33f7b0 (patch)
tree2996e2a4a652c4538a4f3dad580a94c21b6b66bd /dev-libs
parentsys-fs/aufs-util: Version BUmp (diff)
downloadgentoo-2-88b5848f80a84c0605265580d544501adf33f7b0.tar.gz
gentoo-2-88b5848f80a84c0605265580d544501adf33f7b0.tar.bz2
gentoo-2-88b5848f80a84c0605265580d544501adf33f7b0.zip
dev-libs/dee: Bump EAPI and subslot depend on icu, #455900
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/dee/ChangeLog7
-rw-r--r--dev-libs/dee/dee-1.0.14-r1.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-libs/dee/ChangeLog b/dev-libs/dee/ChangeLog
index 22345a7c37d9..41e706ce944d 100644
--- a/dev-libs/dee/ChangeLog
+++ b/dev-libs/dee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/dee
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dee/ChangeLog,v 1.14 2013/02/02 22:24:27 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dee/ChangeLog,v 1.15 2013/02/07 08:27:06 jlec Exp $
+
+*dee-1.0.14-r1 (07 Feb 2013)
+
+ 07 Feb 2013; Justin Lecher <jlec@gentoo.org> +dee-1.0.14-r1.ebuild:
+ Bump EAPI and subslot depend on icu, #455900
02 Feb 2013; Agostino Sarubbo <ago@gentoo.org> dee-1.0.14.ebuild:
Add ~arm, wrt bug #449220
diff --git a/dev-libs/dee/dee-1.0.14-r1.ebuild b/dev-libs/dee/dee-1.0.14-r1.ebuild
new file mode 100644
index 000000000000..c9fad05ad67e
--- /dev/null
+++ b/dev-libs/dee/dee-1.0.14-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dee/dee-1.0.14-r1.ebuild,v 1.1 2013/02/07 08:27:06 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=y
+
+inherit autotools-utils
+
+DESCRIPTION="Provide objects allowing to create Model-View-Controller type programs across DBus"
+HOMEPAGE="https://launchpad.net/dee/"
+SRC_URI="https://launchpad.net/dee/1.0/${PV}/+download/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc debug examples +icu static-libs test"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/icu:="
+DEPEND="${RDEPEND}
+ doc? ( dev-util/gtk-doc )
+ test? (
+ dev-libs/gtx
+ dev-util/dbus-test-runner
+ )"
+
+src_prepare() {
+ sed \
+ -e '/GCC_FLAGS/s:-g::' \
+ -e 's:vapigen:vapigen-0.14:g' \
+ -i configure.ac || die
+ echo true > py-compile || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-silent-rules
+ $(use_enable debug trace-log)
+ $(use_enable test tests)
+# $(use_enable test extended-tests)
+ $(use_enable icu)
+ $(use_enable doc gtk-doc)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PN}/
+ doins -r examples
+ fi
+}