summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-10-10 11:05:36 +0000
committerJeroen Roovers <jer@gentoo.org>2011-10-10 11:05:36 +0000
commita0832eb1dc1d8d36edd59c3ca33e162bc9fd2571 (patch)
tree73c94dc2a8060252b2b317f6ea66166dc7926c3c /dev-libs
parentVersion bump. (diff)
downloadgentoo-2-a0832eb1dc1d8d36edd59c3ca33e162bc9fd2571.tar.gz
gentoo-2-a0832eb1dc1d8d36edd59c3ca33e162bc9fd2571.tar.bz2
gentoo-2-a0832eb1dc1d8d36edd59c3ca33e162bc9fd2571.zip
Version bump.
(Portage version: 2.2.0_alpha64/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libnl/ChangeLog7
-rw-r--r--dev-libs/libnl/libnl-3.2.1.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-libs/libnl/ChangeLog b/dev-libs/libnl/ChangeLog
index 2394c494427f..6cc77a511d8b 100644
--- a/dev-libs/libnl/ChangeLog
+++ b/dev-libs/libnl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libnl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnl/ChangeLog,v 1.51 2011/08/20 22:32:44 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnl/ChangeLog,v 1.52 2011/10/10 11:05:36 jer Exp $
+
+*libnl-3.2.1 (10 Oct 2011)
+
+ 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> +libnl-3.2.1.ebuild:
+ Version bump.
*libnl-3.1 (20 Aug 2011)
diff --git a/dev-libs/libnl/libnl-3.2.1.ebuild b/dev-libs/libnl/libnl-3.2.1.ebuild
new file mode 100644
index 000000000000..90cecea47492
--- /dev/null
+++ b/dev-libs/libnl/libnl-3.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnl/libnl-3.2.1.ebuild,v 1.1 2011/10/10 11:05:36 jer Exp $
+
+EAPI="4"
+
+inherit eutils multilib autotools-utils
+
+DESCRIPTION="A library for applications dealing with netlink socket"
+HOMEPAGE="http://people.suug.ch/~tgr/libnl/"
+SRC_URI="http://people.suug.ch/~tgr/libnl/files/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="static-libs"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.1-vlan-header.patch
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ use static-libs || remove_libtool_files
+
+ dodoc ChangeLog
+}