summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-28 19:31:45 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-28 19:31:45 +0000
commitc6972765ca876d4bb8c85113709af3c68702b2a6 (patch)
treef774d91f754a2c2732d11794e2b4a9fffe3868af /dev-libs
parentSwitch to CPU_FLAGS_X86. (diff)
downloadgentoo-2-c6972765ca876d4bb8c85113709af3c68702b2a6.tar.gz
gentoo-2-c6972765ca876d4bb8c85113709af3c68702b2a6.tar.bz2
gentoo-2-c6972765ca876d4bb8c85113709af3c68702b2a6.zip
Switch to CPU_FLAGS_X86.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/eina/ChangeLog8
-rw-r--r--dev-libs/eina/eina-1.7.9.ebuild12
-rw-r--r--dev-libs/eina/eina-9999.ebuild12
3 files changed, 18 insertions, 14 deletions
diff --git a/dev-libs/eina/ChangeLog b/dev-libs/eina/ChangeLog
index 1db9829ff919..1d88cdba5ca1 100644
--- a/dev-libs/eina/ChangeLog
+++ b/dev-libs/eina/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/eina
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/eina/ChangeLog,v 1.21 2013/11/11 18:28:34 tommy Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/eina/ChangeLog,v 1.22 2015/01/28 19:31:45 mgorny Exp $
+
+ 28 Jan 2015; Michał Górny <mgorny@gentoo.org> eina-1.7.9.ebuild,
+ eina-9999.ebuild:
+ Switch to CPU_FLAGS_X86.
*eina-1.7.9 (11 Nov 2013)
diff --git a/dev-libs/eina/eina-1.7.9.ebuild b/dev-libs/eina/eina-1.7.9.ebuild
index 9812d7354328..6481204dc6f2 100644
--- a/dev-libs/eina/eina-1.7.9.ebuild
+++ b/dev-libs/eina/eina-1.7.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/eina/eina-1.7.9.ebuild,v 1.1 2013/11/11 18:28:34 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/eina/eina-1.7.9.ebuild,v 1.2 2015/01/28 19:31:45 mgorny Exp $
EAPI="4"
@@ -18,7 +18,7 @@ inherit enlightenment
DESCRIPTION="Enlightenment's data types library (list, hash, etc) in C"
LICENSE="LGPL-2.1"
-IUSE="altivec debug default-mempool mmx sse sse2 static-libs test valgrind"
+IUSE="altivec debug default-mempool cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 static-libs test valgrind"
MEMPOOLS=(
@buddy
@@ -54,9 +54,9 @@ src_configure() {
$(use debug || echo " --with-internal-maximum-log-level=2")
$(use_enable default-mempool)
$(use_enable doc)
- $(use_enable mmx cpu-mmx)
- $(use_enable sse cpu-sse)
- $(use_enable sse2 cpu-sse2)
+ $(use_enable cpu_flags_x86_mmx cpu-mmx)
+ $(use_enable cpu_flags_x86_sse cpu-sse)
+ $(use_enable cpu_flags_x86_sse2 cpu-sse2)
$(use test && echo " --disable-amalgamation")
$(use_enable test e17)
$(use_enable test tests)
diff --git a/dev-libs/eina/eina-9999.ebuild b/dev-libs/eina/eina-9999.ebuild
index fe60709af0a5..4b17c81aff51 100644
--- a/dev-libs/eina/eina-9999.ebuild
+++ b/dev-libs/eina/eina-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/eina/eina-9999.ebuild,v 1.2 2013/11/11 18:28:34 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/eina/eina-9999.ebuild,v 1.3 2015/01/28 19:31:45 mgorny Exp $
EAPI="4"
@@ -18,7 +18,7 @@ inherit enlightenment
DESCRIPTION="Enlightenment's data types library (list, hash, etc) in C"
LICENSE="LGPL-2.1"
-IUSE="altivec debug default-mempool mmx sse sse2 static-libs test valgrind"
+IUSE="altivec debug default-mempool cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 static-libs test valgrind"
MEMPOOLS=(
@buddy
@@ -54,9 +54,9 @@ src_configure() {
$(use debug || echo " --with-internal-maximum-log-level=2")
$(use_enable default-mempool)
$(use_enable doc)
- $(use_enable mmx cpu-mmx)
- $(use_enable sse cpu-sse)
- $(use_enable sse2 cpu-sse2)
+ $(use_enable cpu_flags_x86_mmx cpu-mmx)
+ $(use_enable cpu_flags_x86_sse cpu-sse)
+ $(use_enable cpu_flags_x86_sse2 cpu-sse2)
$(use test && echo " --disable-amalgamation")
$(use_enable test e17)
$(use_enable test tests)