summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-03-28 22:43:04 +0000
committerPacho Ramos <pacho@gentoo.org>2013-03-28 22:43:04 +0000
commitd0059d9f9a995fff6917307bc3edd198f885e2ba (patch)
tree51ff55d3da37ab518d4d160c7e7b01e49cdae989 /dev-libs
parentStable for amd64, wrt bug #456512 (diff)
downloadgentoo-2-d0059d9f9a995fff6917307bc3edd198f885e2ba.tar.gz
gentoo-2-d0059d9f9a995fff6917307bc3edd198f885e2ba.tar.bz2
gentoo-2-d0059d9f9a995fff6917307bc3edd198f885e2ba.zip
Version bump for Gnome 3.8
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libgweather/ChangeLog7
-rw-r--r--dev-libs/libgweather/libgweather-3.8.0.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-libs/libgweather/ChangeLog b/dev-libs/libgweather/ChangeLog
index 1951bb1e353a..01a0ca4b89ed 100644
--- a/dev-libs/libgweather/ChangeLog
+++ b/dev-libs/libgweather/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libgweather
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/ChangeLog,v 1.89 2013/03/05 23:16:15 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/ChangeLog,v 1.90 2013/03/28 22:43:04 pacho Exp $
+
+*libgweather-3.8.0 (28 Mar 2013)
+
+ 28 Mar 2013; Pacho Ramos <pacho@gentoo.org> +libgweather-3.8.0.ebuild:
+ Version bump for Gnome 3.8
05 Mar 2013; Gilles Dartiguelongue <eva@gentoo.org>
-libgweather-3.4.1.ebuild:
diff --git a/dev-libs/libgweather/libgweather-3.8.0.ebuild b/dev-libs/libgweather/libgweather-3.8.0.ebuild
new file mode 100644
index 000000000000..11a85c17a1a2
--- /dev/null
+++ b/dev-libs/libgweather/libgweather-3.8.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/libgweather-3.8.0.ebuild,v 1.1 2013/03/28 22:43:04 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Library to access weather information from online services"
+HOMEPAGE="https://live.gnome.org/LibGWeather"
+
+LICENSE="GPL-2+"
+SLOT="2/3-1" # subslot = 3-(libgweather-3 soname suffix)
+IUSE="+introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+
+# libsoup-gnome is to be used because libsoup[gnome] might not
+# get libsoup-gnome installed by the time ${P} is built
+COMMON_DEPEND=">=x11-libs/gtk+-2.90.0:3[introspection?]
+ >=dev-libs/glib-2.35.1:2
+ >=net-libs/libsoup-2.34:2.4[gnome]
+ >=dev-libs/libxml2-2.6.0
+ >=sys-libs/timezone-data-2010k
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/gnome-applets-2.22.0
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS"
+ # Do not add --disable-all-translations-in-one-xml : it will enable them
+ G2CONF="${G2CONF}
+ --enable-locations-compression
+ --disable-static
+ $(use_enable introspection)"
+ gnome2_src_configure
+}