summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-06-09 03:15:01 +0000
committerJeroen Roovers <jer@gentoo.org>2009-06-09 03:15:01 +0000
commited9928305a9c43afd94a4bdfc7a07f7b336a5797 (patch)
tree42beb312453bf98d0a04d4e44fbb23b797a74d77 /dev-libs
parentmurrine-themes should pull in gtk-engines-murrine, not the other way around. ... (diff)
downloadgentoo-2-ed9928305a9c43afd94a4bdfc7a07f7b336a5797.tar.gz
gentoo-2-ed9928305a9c43afd94a4bdfc7a07f7b336a5797.tar.bz2
gentoo-2-ed9928305a9c43afd94a4bdfc7a07f7b336a5797.zip
Version bump thanks to Jason (bug #257780). Drop two accepted patches. Add partial (apparently rejected) AM_PATH_CHECK patch.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/check/ChangeLog9
-rw-r--r--dev-libs/check/check-0.9.6.ebuild28
-rw-r--r--dev-libs/check/files/check-0.9.6-AM_PATH_CHECK.patch12
3 files changed, 48 insertions, 1 deletions
diff --git a/dev-libs/check/ChangeLog b/dev-libs/check/ChangeLog
index c61564df39fb..17e3e121d47c 100644
--- a/dev-libs/check/ChangeLog
+++ b/dev-libs/check/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/check
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/check/ChangeLog,v 1.53 2009/04/29 11:33:52 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/check/ChangeLog,v 1.54 2009/06/09 03:15:00 jer Exp $
+
+*check-0.9.6 (09 Jun 2009)
+
+ 09 Jun 2009; Jeroen Roovers <jer@gentoo.org> +check-0.9.6.ebuild,
+ +files/check-0.9.6-AM_PATH_CHECK.patch:
+ Version bump thanks to Jason (bug #257780). Drop two accepted patches. Add
+ partial (apparently rejected) AM_PATH_CHECK patch.
29 Apr 2009; Raúl Porcel <armin76@gentoo.org> check-0.9.5-r1.ebuild:
m68k stable
diff --git a/dev-libs/check/check-0.9.6.ebuild b/dev-libs/check/check-0.9.6.ebuild
new file mode 100644
index 000000000000..5c15f00452de
--- /dev/null
+++ b/dev-libs/check/check-0.9.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/check/check-0.9.6.ebuild,v 1.1 2009/06/09 03:15:00 jer Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="A unit test framework for C"
+HOMEPAGE="http://sourceforge.net/projects/check/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-AM_PATH_CHECK.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ mv "${D}"/usr/share/doc/{${PN},${PF}} || die
+}
diff --git a/dev-libs/check/files/check-0.9.6-AM_PATH_CHECK.patch b/dev-libs/check/files/check-0.9.6-AM_PATH_CHECK.patch
new file mode 100644
index 000000000000..7bb306187206
--- /dev/null
+++ b/dev-libs/check/files/check-0.9.6-AM_PATH_CHECK.patch
@@ -0,0 +1,12 @@
+diff -Naur check-0.9.5-orig/doc/example/configure.ac check-0.9.5/doc/example/configure.ac
+--- check-0.9.5-orig/doc/example/configure.ac 2006-11-21 17:19:14.000000000 -0600
++++ check-0.9.5/doc/example/configure.ac 2008-12-04 21:45:13.000000000 -0600
+@@ -25,7 +25,7 @@
+ # CHECK_LIBS accordingly.
+ # AM_PATH_CHECK([MINIMUM-VERSION,
+ # [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]]])
+-AM_PATH_CHECK()
++PKG_CHECK_MODULES([check], [], [])
+
+ # Checks for header files.
+ AC_HEADER_STDC