summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2011-07-07 14:27:50 +0000
committerDane Smith <c1pher@gentoo.org>2011-07-07 14:27:50 +0000
commitfacf8dd537e38497c7816156f0e9fed7d3a7fc24 (patch)
tree95acb9cb6dee5e68025eade3c06563485d510fbc /dev-libs
parentkeyword ~x86-fbsd (diff)
downloadgentoo-2-facf8dd537e38497c7816156f0e9fed7d3a7fc24.tar.gz
gentoo-2-facf8dd537e38497c7816156f0e9fed7d3a7fc24.tar.bz2
gentoo-2-facf8dd537e38497c7816156f0e9fed7d3a7fc24.zip
dev-libs/opensc: Version bump wrt 374309.
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/opensc/ChangeLog9
-rw-r--r--dev-libs/opensc/files/opensc-0.12.1-crossbuild.patch38
-rw-r--r--dev-libs/opensc/opensc-0.12.1.ebuild68
3 files changed, 114 insertions, 1 deletions
diff --git a/dev-libs/opensc/ChangeLog b/dev-libs/opensc/ChangeLog
index e2c54d82beaa..1a1a3f446334 100644
--- a/dev-libs/opensc/ChangeLog
+++ b/dev-libs/opensc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/opensc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/opensc/ChangeLog,v 1.114 2011/07/03 17:13:16 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/opensc/ChangeLog,v 1.115 2011/07/07 14:27:49 c1pher Exp $
+
+*opensc-0.12.1 (07 Jul 2011)
+
+ 07 Jul 2011; Dane Smith <c1pher@gentoo.org> +opensc-0.12.1.ebuild,
+ +files/opensc-0.12.1-crossbuild.patch:
+ Version bump wrt bug 374309. Adjusted the existing crossbuild patch
+ for the new version. Removed no longer needed || die.
03 Jul 2011; Diego E. Pettenò <flameeyes@gentoo.org>
opensc-0.12.0-r2.ebuild, +files/opensc-0.12.0-crossbuild.patch:
diff --git a/dev-libs/opensc/files/opensc-0.12.1-crossbuild.patch b/dev-libs/opensc/files/opensc-0.12.1-crossbuild.patch
new file mode 100644
index 000000000000..008fd3c35700
--- /dev/null
+++ b/dev-libs/opensc/files/opensc-0.12.1-crossbuild.patch
@@ -0,0 +1,38 @@
+--- src/pkcs11/Makefile.am 2011-05-17 13:07:00.000000000 -0400
++++ Makefile.am.new 2011-07-07 10:03:28.399185928 -0400
+@@ -14,9 +14,10 @@
+ mechanism.c openssl.c framework-pkcs15.c \
+ framework-pkcs15init.c debug.c opensc-pkcs11.exports \
+ pkcs11-display.c pkcs11-display.h
+-OPENSC_PKCS11_LIBS = $(OPTIONAL_OPENSSL_LIBS) $(PTHREAD_LIBS) $(LTLIB_LIBS) \
++OPENSC_PKCS11_LIBS = \
+ $(top_builddir)/src/common/libcompat.la \
+- $(top_builddir)/src/libopensc/libopensc.la
++ $(top_builddir)/src/libopensc/libopensc.la \
++ $(OPTIONAL_OPENSSL_LIBS) $(PTHREAD_LIBS) $(LTLIB_LIBS)
+
+ opensc_pkcs11_la_SOURCES = $(OPENSC_PKCS11_SRC) $(OPENSC_PKCS11_INC) hack-disabled.c
+ opensc_pkcs11_la_LIBADD = $(OPENSC_PKCS11_LIBS)
+@@ -31,7 +32,7 @@
+ -module -shared -avoid-version -no-undefined
+
+ pkcs11_spy_la_SOURCES = pkcs11-spy.c pkcs11-display.c pkcs11-display.h pkcs11-spy.exports
+-pkcs11_spy_la_LIBADD = $(OPTIONAL_OPENSSL_LIBS) $(LTLIB_LIBS) $(top_builddir)/src/common/libpkcs11.la
++pkcs11_spy_la_LIBADD = $(top_builddir)/src/common/libpkcs11.la $(OPTIONAL_OPENSSL_LIBS) $(LTLIB_LIBS)
+ pkcs11_spy_la_LDFLAGS = $(AM_LDFLAGS) \
+ -export-symbols "$(srcdir)/pkcs11-spy.exports" \
+ -module -shared -avoid-version -no-undefined
+--- src/tools/Makefile.am 2011-05-17 13:07:00.000000000 -0400
++++ Makefile.am.new 2011-07-07 10:06:08.710185925 -0400
+@@ -24,8 +24,9 @@
+ pkcs15_tool_SOURCES = pkcs15-tool.c util.c
+ pkcs15_tool_LDADD = $(OPTIONAL_OPENSSL_LIBS)
+ pkcs11_tool_SOURCES = pkcs11-tool.c util.c
+-pkcs11_tool_LDADD = $(OPTIONAL_OPENSSL_LIBS) $(LTLIB_LIBS) \
+- $(top_builddir)/src/common/libpkcs11.la
++pkcs11_tool_LDADD = \
++ $(top_builddir)/src/common/libpkcs11.la \
++ $(OPTIONAL_OPENSSL_LIBS) $(LTLIB_LIBS)
+ pkcs15_crypt_SOURCES = pkcs15-crypt.c util.c
+ pkcs15_crypt_LDADD = $(OPTIONAL_OPENSSL_LIBS)
+ cryptoflex_tool_SOURCES = cryptoflex-tool.c util.c
diff --git a/dev-libs/opensc/opensc-0.12.1.ebuild b/dev-libs/opensc/opensc-0.12.1.ebuild
new file mode 100644
index 000000000000..9e732fde159e
--- /dev/null
+++ b/dev-libs/opensc/opensc-0.12.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/opensc/opensc-0.12.1.ebuild,v 1.1 2011/07/07 14:27:49 c1pher Exp $
+
+EAPI="4"
+
+inherit eutils autotools
+
+DESCRIPTION="Libraries and applications to access smartcards."
+HOMEPAGE="http://www.opensc-project.org/opensc/"
+
+SRC_URI="http://www.opensc-project.org/files/${PN}/${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc +pcsc-lite openct readline ssl zlib"
+
+# libtool is required at runtime for libltdl
+RDEPEND="sys-devel/libtool
+ zlib? ( sys-libs/zlib )
+ readline? ( sys-libs/readline )
+ ssl? ( dev-libs/openssl )
+ openct? ( >=dev-libs/openct-0.5.0 )
+ pcsc-lite? ( >=sys-apps/pcsc-lite-1.3.0 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt"
+
+REQUIRED_USE="
+ pcsc-lite? ( !openct )
+ openct? ( !pcsc-lite )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-crossbuild.patch
+ eautoreconf
+}
+
+src_configure() {
+ # disable everything, enable selectively
+ local myconf="--disable-pcsc --disable-openct --disable-ctapi"
+
+ if use pcsc-lite; then
+ myconf+=" --enable-pcsc"
+ elif use openct; then
+ myconf+=" --enable-openct"
+ else
+ myconf+=" --enable-ctapi"
+ fi
+
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --htmldir="/usr/share/doc/${PF}/html" \
+ --disable-static \
+ $(use_enable doc) \
+ $(use_enable openct) \
+ $(use_enable readline) \
+ $(use_enable zlib) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ find "${D}" -name '*.la' -delete
+
+ dodoc ChangeLog
+}