summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-11-09 02:17:40 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-11-09 02:17:40 +0000
commitfb505accca5ebb7bfe0db093c4820cc798e755fb (patch)
treed65d7a5c96d06578391dd953becc13ca0cf4b06a /dev-libs
parentbork with emake (diff)
downloadgentoo-2-fb505accca5ebb7bfe0db093c4820cc798e755fb.tar.gz
gentoo-2-fb505accca5ebb7bfe0db093c4820cc798e755fb.tar.bz2
gentoo-2-fb505accca5ebb7bfe0db093c4820cc798e755fb.zip
version update
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/lam-mpi/ChangeLog8
-rw-r--r--dev-libs/lam-mpi/files/digest-lam-mpi-6.5.71
-rw-r--r--dev-libs/lam-mpi/lam-mpi-6.5.7.ebuild56
3 files changed, 64 insertions, 1 deletions
diff --git a/dev-libs/lam-mpi/ChangeLog b/dev-libs/lam-mpi/ChangeLog
index 4e4230c07f45..fd67b17ee358 100644
--- a/dev-libs/lam-mpi/ChangeLog
+++ b/dev-libs/lam-mpi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/lam-mpi
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/lam-mpi/ChangeLog,v 1.3 2002/10/22 07:24:58 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/lam-mpi/ChangeLog,v 1.4 2002/11/09 02:17:40 george Exp $
+
+*lam-mpi-6.5.7.ebuild (08 Nov 2002)
+
+ 08 Nov 2002; George Shapovalov <george@gentoo.org> lam-mpi-6.5.7.ebuild, files/digest-lam-mpi-6.5.7 :
+
+ new version
*lam-mpi-6.5.6-r1.ebuild (21 Oct 2002)
diff --git a/dev-libs/lam-mpi/files/digest-lam-mpi-6.5.7 b/dev-libs/lam-mpi/files/digest-lam-mpi-6.5.7
new file mode 100644
index 000000000000..c886ff086a6d
--- /dev/null
+++ b/dev-libs/lam-mpi/files/digest-lam-mpi-6.5.7
@@ -0,0 +1 @@
+MD5 59c0cc8bc6ab1134ba435c2424cbe5e0 lam-6.5.7.tar.bz2 1349765
diff --git a/dev-libs/lam-mpi/lam-mpi-6.5.7.ebuild b/dev-libs/lam-mpi/lam-mpi-6.5.7.ebuild
new file mode 100644
index 000000000000..29d535c75186
--- /dev/null
+++ b/dev-libs/lam-mpi/lam-mpi-6.5.7.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/lam-mpi/lam-mpi-6.5.7.ebuild,v 1.1 2002/11/09 02:17:40 george Exp $
+
+IUSE=""
+
+Name="lam"
+S=${WORKDIR}/${Name}-${PV}
+
+DESCRIPTION="the LAM MPI parallel computing environment"
+SRC_URI="http://www.lam-mpi.org/download/files/${Name}-${PV}.tar.bz2"
+HOMEPAGE="http://www.lam-mpi.org"
+
+DEPEND="virtual/glibc"
+# we need ssh if we want to use it instead of rsh
+RDEPEND="net-misc/openssh"
+
+SLOT="6"
+KEYWORDS="~x86 ~sparc ~sparc64"
+LICENSE="as-is"
+
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/romio/util/
+ mv romioinstall.in romioinstall.in-orig
+ sed -e "s|docdir=\"\$datadir/lam/doc\"|docdir=\"${D}/usr/share/doc/${PF}\"|" romioinstall.in-orig >romioinstall.in
+
+}
+
+src_compile() {
+ econf --with-cflags="${CFLAGS}" \
+ --sysconfdir=/etc/lam-mpi \
+ --with-cxxflags="${CXXFLAGS}" --with-rsh="ssh -x" || die
+
+ # sometimes emake doesn't finish since it gets ahead of itself :)
+
+ make || die
+
+}
+
+src_install () {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man infodir=${D}/usr/share/info \
+ sysconfdir=${D}/etc/lam-mpi install || die
+
+ #need to correct the produced absolute symlink
+ cd ${D}/usr/include
+ rm mpi++.h
+ ln -sf mpi2c++/mpi++.h mpi++.h
+
+ dodoc README HISTORY LICENSE RELEASE_NOTES VERSION
+}
+