summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-12-29 02:51:41 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-12-29 02:51:41 +0000
commitfb849e0635e2f06d3533d74b25fa91113c873909 (patch)
tree5c2db78a52594461478671e508697154785f4df8 /dev-libs
parentBump #533518 (diff)
downloadgentoo-2-fb849e0635e2f06d3533d74b25fa91113c873909.tar.gz
gentoo-2-fb849e0635e2f06d3533d74b25fa91113c873909.tar.bz2
gentoo-2-fb849e0635e2f06d3533d74b25fa91113c873909.zip
Bump #533754
(Portage version: 2.2.15/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/pcc-libs/ChangeLog9
-rw-r--r--dev-libs/pcc-libs/pcc-libs-1.1.0.ebuild29
2 files changed, 36 insertions, 2 deletions
diff --git a/dev-libs/pcc-libs/ChangeLog b/dev-libs/pcc-libs/ChangeLog
index cfe38bb9b624..3c597e0fa381 100644
--- a/dev-libs/pcc-libs/ChangeLog
+++ b/dev-libs/pcc-libs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/pcc-libs
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/pcc-libs/ChangeLog,v 1.11 2013/10/13 12:48:25 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pcc-libs/ChangeLog,v 1.12 2014/12/29 02:51:41 patrick Exp $
+
+*pcc-libs-1.1.0 (29 Dec 2014)
+
+ 29 Dec 2014; Patrick Lauer <patrick@gentoo.org> +pcc-libs-1.1.0.ebuild:
+ Bump #533754
*pcc-libs-1.0.1_pre20131013 (13 Oct 2013)
diff --git a/dev-libs/pcc-libs/pcc-libs-1.1.0.ebuild b/dev-libs/pcc-libs/pcc-libs-1.1.0.ebuild
new file mode 100644
index 000000000000..42ec727f068d
--- /dev/null
+++ b/dev-libs/pcc-libs/pcc-libs-1.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pcc-libs/pcc-libs-1.1.0.ebuild,v 1.1 2014/12/29 02:51:41 patrick Exp $
+
+EAPI=5
+
+inherit eutils versionator
+
+DESCRIPTION="pcc compiler support libs"
+HOMEPAGE="http://pcc.ludd.ltu.se"
+
+SRC_URI="ftp://pcc.ludd.ltu.se/pub/pcc-releases/${P}.tgz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~amd64-fbsd"
+
+IUSE=""
+DEPEND=""
+RDEPEND="${DEPEND}"
+S=${WORKDIR}/${PN}-${PVR/*_pre/}/
+
+src_compile() {
+ # not parallel-safe yet
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}