summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-05-15 13:35:32 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-05-15 13:35:32 +0000
commitfd3b9eb3a89176a5dc1266f08e2216af2e7eaf80 (patch)
treeecdb07fb1dcaaa72f56f5227aeaddde226296cf4 /dev-libs
parentremove old (diff)
downloadgentoo-2-fd3b9eb3a89176a5dc1266f08e2216af2e7eaf80.tar.gz
gentoo-2-fd3b9eb3a89176a5dc1266f08e2216af2e7eaf80.tar.bz2
gentoo-2-fd3b9eb3a89176a5dc1266f08e2216af2e7eaf80.zip
Pass --with-glib=yes to ensure fribidi.pc has "Requires: glib-2.0" line wrt #345621. Only #include glib.h for dev-libs/glib >= 2.31 compability wrt #415721. Thanks to Thomas Sachau for reporting both bugs.
(Portage version: 2.2.0_alpha104/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/fribidi/ChangeLog10
-rw-r--r--dev-libs/fribidi/files/fribidi-0.19.2-glib-2.31.patch74
-rw-r--r--dev-libs/fribidi/files/fribidi-0.19.2-nodoc.patch4
-rw-r--r--dev-libs/fribidi/fribidi-0.19.2-r2.ebuild42
4 files changed, 127 insertions, 3 deletions
diff --git a/dev-libs/fribidi/ChangeLog b/dev-libs/fribidi/ChangeLog
index 1e0613b8e52e..fb0d7d56c178 100644
--- a/dev-libs/fribidi/ChangeLog
+++ b/dev-libs/fribidi/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/fribidi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/fribidi/ChangeLog,v 1.52 2012/05/15 13:01:48 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/fribidi/ChangeLog,v 1.53 2012/05/15 13:35:32 ssuominen Exp $
+
+*fribidi-0.19.2-r2 (15 May 2012)
+
+ 15 May 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +fribidi-0.19.2-r2.ebuild, +files/fribidi-0.19.2-glib-2.31.patch:
+ Pass --with-glib=yes to ensure fribidi.pc has "Requires: glib-2.0" line wrt
+ #345621. Only #include glib.h for dev-libs/glib >= 2.31 compability wrt
+ #415721. Thanks to Thomas Sachau for reporting both bugs.
15 May 2012; Alexis Ballier <aballier@gentoo.org> fribidi-0.19.2-r1.ebuild:
keyword ~amd64-fbsd
diff --git a/dev-libs/fribidi/files/fribidi-0.19.2-glib-2.31.patch b/dev-libs/fribidi/files/fribidi-0.19.2-glib-2.31.patch
new file mode 100644
index 000000000000..446a2f395bce
--- /dev/null
+++ b/dev-libs/fribidi/files/fribidi-0.19.2-glib-2.31.patch
@@ -0,0 +1,74 @@
+http://bugs.gentoo.org/318569
+http://bugs.gentoo.org/415721
+
+--- charset/fribidi-char-sets.c
++++ charset/fribidi-char-sets.c
+@@ -114,7 +114,7 @@
+ };
+
+ #if FRIBIDI_USE_GLIB+0
+-# include <glib/gstrfuncs.h>
++# include <glib.h>
+ # define fribidi_strcasecmp g_ascii_strcasecmp
+ #else /* !FRIBIDI_USE_GLIB */
+ static char
+--- lib/common.h
++++ lib/common.h
+@@ -57,7 +57,7 @@
+ # define SIZEOF_VOID_P GLIB_SIZEOF_VOID_P
+ # endif /* !SIZEOF_VOID_P */
+ # ifndef __FRIBIDI_DOC
+-# include <glib/gmem.h>
++# include <glib.h>
+ # endif /* !__FRIBIDI_DOC */
+ # ifndef fribidi_malloc
+ # define fribidi_malloc g_try_malloc
+@@ -65,12 +65,12 @@
+ # endif /* !fribidi_malloc */
+ # ifndef fribidi_assert
+ # ifndef __FRIBIDI_DOC
+-# include <glib/gmessages.h>
++# include <glib.h>
+ # endif /* !__FRIBIDI_DOC */
+ # define fribidi_assert g_assert
+ # endif /* !fribidi_assert */
+ # ifndef __FRIBIDI_DOC
+-# include <glib/gmacros.h>
++# include <glib.h>
+ # endif /* !__FRIBIDI_DOC */
+ # ifndef FRIBIDI_BEGIN_STMT
+ # define FRIBIDI_BEGIN_STMT G_STMT_START {
+--- lib/fribidi-common.h
++++ lib/fribidi-common.h
+@@ -62,7 +62,7 @@
+
+ #if FRIBIDI_USE_GLIB+0
+ # ifndef __FRIBIDI_DOC
+-# include <glib/gmacros.h>
++# include <glib.h>
+ # endif /* !__FRIBIDI_DOC */
+ # define FRIBIDI_BEGIN_DECLS G_BEGIN_DECLS
+ # define FRIBIDI_END_DECLS G_END_DECLS
+--- lib/fribidi-types.h
++++ lib/fribidi-types.h
+@@ -40,8 +40,7 @@
+
+ #if FRIBIDI_USE_GLIB+0
+ # ifndef __FRIBIDI_DOC
+-# include <glib/gtypes.h>
+-# include <glib/gunicode.h>
++# include <glib.h>
+ # endif /* !__FRIBIDI_DOC */
+ # define FRIBIDI_INT8_LOCAL gint8
+ # define FRIBIDI_INT16_LOCAL gint16
+--- lib/mem.h
++++ lib/mem.h
+@@ -42,7 +42,7 @@
+ #if FRIBIDI_USE_GLIB+0
+
+ #ifndef __FRIBIDI_DOC
+-# include <glib/gmem.h>
++# include <glib.h>
+ #endif /* !__FRIBIDI_DOC */
+
+ #define FriBidiMemChunk GMemChunk
diff --git a/dev-libs/fribidi/files/fribidi-0.19.2-nodoc.patch b/dev-libs/fribidi/files/fribidi-0.19.2-nodoc.patch
index b8cb2645c1ac..8649db285528 100644
--- a/dev-libs/fribidi/files/fribidi-0.19.2-nodoc.patch
+++ b/dev-libs/fribidi/files/fribidi-0.19.2-nodoc.patch
@@ -1,5 +1,5 @@
---- fribidi-0.19.2.orig/Makefile.am 2005-08-26 03:35:34.000000000 +0900
-+++ fribidi-0.19.2/Makefile.am 2010-05-11 17:36:38.000000000 +0900
+--- Makefile.am
++++ Makefile.am
@@ -9,7 +9,7 @@
##############################################################################
diff --git a/dev-libs/fribidi/fribidi-0.19.2-r2.ebuild b/dev-libs/fribidi/fribidi-0.19.2-r2.ebuild
new file mode 100644
index 000000000000..ad9bea589d11
--- /dev/null
+++ b/dev-libs/fribidi/fribidi-0.19.2-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/fribidi/fribidi-0.19.2-r2.ebuild,v 1.1 2012/05/15 13:35:32 ssuominen Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="A free implementation of the unicode bidirectional algorithm"
+HOMEPAGE="http://fribidi.org/"
+SRC_URI="http://fribidi.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/glib-2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS NEWS README ChangeLog THANKS TODO"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-glib-2.31.patch \
+ "${FILESDIR}"/${P}-nodoc.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ # --with-glib=yes is required for #345621 to ensure "Requires: glib-2.0" is
+ # present in /usr/lib/pkgconfig/fribidi.pc
+ econf \
+ $(use_enable static-libs static) \
+ --with-glib=yes
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}