summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-05-09 05:55:32 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-05-09 05:55:32 +0000
commit754fecb3a0b150bebfb0a8898b5244b9a00ead7c (patch)
treec40a367fe067433839eb3c96a504c630f1321aca /dev-lisp/cl-blowfish/cl-blowfish-0.6.ebuild
parentTaking out ucs2 patch since it caused crashing. Looking into new patch. (Man... (diff)
downloadgentoo-2-754fecb3a0b150bebfb0a8898b5244b9a00ead7c.tar.gz
gentoo-2-754fecb3a0b150bebfb0a8898b5244b9a00ead7c.tar.bz2
gentoo-2-754fecb3a0b150bebfb0a8898b5244b9a00ead7c.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp/cl-blowfish/cl-blowfish-0.6.ebuild')
-rw-r--r--dev-lisp/cl-blowfish/cl-blowfish-0.6.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-lisp/cl-blowfish/cl-blowfish-0.6.ebuild b/dev-lisp/cl-blowfish/cl-blowfish-0.6.ebuild
new file mode 100644
index 000000000000..d37f7ecc213e
--- /dev/null
+++ b/dev-lisp/cl-blowfish/cl-blowfish-0.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-blowfish/cl-blowfish-0.6.ebuild,v 1.1 2004/05/09 05:55:32 mkennedy Exp $
+
+inherit common-lisp eutils
+
+DEB_PV=1
+
+DESCRIPTION="Common Lisp implementation of the Blowfish encryption algorithm."
+HOMEPAGE="http://packages.debian.org/unstable/devel/cl-blowfish.html http://members.optusnet.com.au/apicard/"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-blowfish/cl-blowfish_${PV}.orig.tar.gz
+ http://ftp.debian.org/debian/pool/main/c/cl-blowfish/cl-blowfish_${PV}-${DEB_PV}.diff.gz"
+
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=blowfish
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${PN}_${PV}-${DEB_PV}.diff
+}
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ do-debian-credits
+}