summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-11-03 16:14:17 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-11-03 16:14:17 +0000
commit85f6b84a90f5279d21fe521da0ea34c260232a45 (patch)
tree504c58fc8c6f532db3da3b3e63dbe63b882d49de /dev-lisp/cl-ironclad/cl-ironclad-0.10.ebuild
parentUpdate for incoming ocaml-3.09. (diff)
downloadgentoo-2-85f6b84a90f5279d21fe521da0ea34c260232a45.tar.gz
gentoo-2-85f6b84a90f5279d21fe521da0ea34c260232a45.tar.bz2
gentoo-2-85f6b84a90f5279d21fe521da0ea34c260232a45.zip
New upstream version.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'dev-lisp/cl-ironclad/cl-ironclad-0.10.ebuild')
-rw-r--r--dev-lisp/cl-ironclad/cl-ironclad-0.10.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-lisp/cl-ironclad/cl-ironclad-0.10.ebuild b/dev-lisp/cl-ironclad/cl-ironclad-0.10.ebuild
new file mode 100644
index 000000000000..3b37682c4487
--- /dev/null
+++ b/dev-lisp/cl-ironclad/cl-ironclad-0.10.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-ironclad/cl-ironclad-0.10.ebuild,v 1.1 2005/11/03 16:14:17 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="Ironclad is a Common Lisp library similar to OpenSSL, GNU TLS or Crypto++"
+HOMEPAGE="http://www.cliki.net/Ironclad"
+SRC_URI="http://www.cs.rice.edu/~froydnj/lisp/ironclad_${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND=""
+
+CLPACKAGE=ironclad
+
+S=${WORKDIR}/ironclad_${PV}
+
+src_install() {
+ common-lisp-install *.{lisp,asd}
+ common-lisp-system-symlink
+ insinto $CLSOURCEROOT/ironclad/test-vectors
+ doins test-vectors/*.lisp
+ dodoc README TODO NEWS LICENSE
+}