summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-08-05 04:14:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-08-05 04:14:02 +0000
commit13e28b71ca78475d9d9e6d4d18067536c1ff0b10 (patch)
tree783a8974a2f213dd4434f5e59b3bfb3864af2976 /dev-lisp/cl-linedit/cl-linedit-0.15.12.ebuild
parentEbuild for working Celestia (Manifest recommit) (diff)
downloadgentoo-2-13e28b71ca78475d9d9e6d4d18067536c1ff0b10.tar.gz
gentoo-2-13e28b71ca78475d9d9e6d4d18067536c1ff0b10.tar.bz2
gentoo-2-13e28b71ca78475d9d9e6d4d18067536c1ff0b10.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp/cl-linedit/cl-linedit-0.15.12.ebuild')
-rw-r--r--dev-lisp/cl-linedit/cl-linedit-0.15.12.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-lisp/cl-linedit/cl-linedit-0.15.12.ebuild b/dev-lisp/cl-linedit/cl-linedit-0.15.12.ebuild
new file mode 100644
index 000000000000..2ebc229e74cd
--- /dev/null
+++ b/dev-lisp/cl-linedit/cl-linedit-0.15.12.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-linedit/cl-linedit-0.15.12.ebuild,v 1.1 2004/08/05 04:14:02 mkennedy Exp $
+
+inherit common-lisp eutils
+
+DESCRIPTION="Linedit is a readline-style library written in Common Lisp that provides customizable line-editing features."
+HOMEPAGE="http://www.common-lisp.net/project/linedit/"
+SRC_URI="http://common-lisp.net/project/linedit/files/linedit_${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp
+ dev-lisp/cl-terminfo
+ dev-lisp/cl-uffi
+ dev-lisp/cl-osicat"
+
+CLPACKAGE=linedit
+
+S=${WORKDIR}/linedit_${PV}
+
+src_unpack() {
+ unpack ${A}
+ # adds uffi-loader.lisp, removes building .so files
+ epatch ${FILESDIR}/${PV}-linedit.asd-uffi-glue-gentoo.patch
+ cp ${FILESDIR}/${PV}-Makefile ${S}/Makefile
+}
+
+src_compile() {
+ make || die
+}
+
+src_install() {
+ common-lisp-install *.lisp linedit.asd version.lisp-expr
+ common-lisp-system-symlink
+ dodoc LICENSE
+ exeinto /usr/lib/linedit
+ doexe *.so
+}