summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-02-12 09:13:21 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-02-12 09:13:21 +0000
commit43e3c27dace2a5d95561cae575e8e8d0dff3f0c5 (patch)
treeb8f70a003c2da92e9f475a0fe908686227fc6069 /dev-lisp/cl-rsm-random/cl-rsm-random-1.1-r1.ebuild
parentBump to 0.5 (Manifest recommit) (diff)
downloadgentoo-2-43e3c27dace2a5d95561cae575e8e8d0dff3f0c5.tar.gz
gentoo-2-43e3c27dace2a5d95561cae575e8e8d0dff3f0c5.tar.bz2
gentoo-2-43e3c27dace2a5d95561cae575e8e8d0dff3f0c5.zip
Fire in the hole!
Diffstat (limited to 'dev-lisp/cl-rsm-random/cl-rsm-random-1.1-r1.ebuild')
-rw-r--r--dev-lisp/cl-rsm-random/cl-rsm-random-1.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-lisp/cl-rsm-random/cl-rsm-random-1.1-r1.ebuild b/dev-lisp/cl-rsm-random/cl-rsm-random-1.1-r1.ebuild
new file mode 100644
index 000000000000..03bf749b38a6
--- /dev/null
+++ b/dev-lisp/cl-rsm-random/cl-rsm-random-1.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-rsm-random/cl-rsm-random-1.1-r1.ebuild,v 1.1 2004/02/12 09:13:20 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="R. Scott McIntire's Common Lisp Random Number Library"
+HOMEPAGE="http://packages.debian.org/unstable/devel/cl-rsm-random.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-rsm-random/cl-rsm-random_${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp
+ dev-lisp/cl-uffi"
+
+CLPACKAGE=rsm-random
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ make linux || die
+}
+
+src_install() {
+ exeinto /usr/lib/rsm-random
+ doexe random.so
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ dodoc copying copyright
+ dohtml *.html *.jpg
+ do-debian-credits
+}