summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-07-22 19:25:22 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-07-22 19:25:22 +0000
commit7c0287e02dbb976d3c14b52e8c12ada27639eeac (patch)
tree427091e77b77479d8adbde105dd676f6e0e0e234 /dev-lisp/clisp/files
parentversion bump (diff)
downloadgentoo-2-7c0287e02dbb976d3c14b52e8c12ada27639eeac.tar.gz
gentoo-2-7c0287e02dbb976d3c14b52e8c12ada27639eeac.tar.bz2
gentoo-2-7c0287e02dbb976d3c14b52e8c12ada27639eeac.zip
.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-lisp/clisp/files')
-rw-r--r--dev-lisp/clisp/files/2.34/README.Gentoo11
-rw-r--r--dev-lisp/clisp/files/2.34/clisp.sh (renamed from dev-lisp/clisp/files/clisp.sh)2
-rw-r--r--dev-lisp/clisp/files/2.34/fastcgi-Makefile.in-gentoo.patch17
-rw-r--r--dev-lisp/clisp/files/2.34/glibc-linux.lisp-sigpause-gentoo.patch15
-rw-r--r--dev-lisp/clisp/files/2.34/install-clc.lisp15
-rw-r--r--dev-lisp/clisp/files/clisp-2.30-gentoo.patch32
-rw-r--r--dev-lisp/clisp/files/clisp-2.30-linux.lisp-upstream.patch122
-rw-r--r--dev-lisp/clisp/files/digest-clisp-2.341
8 files changed, 60 insertions, 155 deletions
diff --git a/dev-lisp/clisp/files/2.34/README.Gentoo b/dev-lisp/clisp/files/2.34/README.Gentoo
new file mode 100644
index 000000000000..6bec925fb0d3
--- /dev/null
+++ b/dev-lisp/clisp/files/2.34/README.Gentoo
@@ -0,0 +1,11 @@
+ -*-outline-*-
+
+* Gentoo Specific Notes
+
+The CLISP port for Gentoo uses Common Lisp Controller related code
+(install-clc.lisp and clisp.sh) from Debian. This code contains the following
+copyright:
+
+ ;;;; Copyright (c) 2004 Kevin M. Rosenberg
+ ;;;; GNU GPL v2 license
+
diff --git a/dev-lisp/clisp/files/clisp.sh b/dev-lisp/clisp/files/2.34/clisp.sh
index 286dbb6a81fb..f5ed6a1d8fce 100644
--- a/dev-lisp/clisp/files/clisp.sh
+++ b/dev-lisp/clisp/files/2.34/clisp.sh
@@ -35,7 +35,7 @@ case $1 in
shift
while [ -x $builder ] && [ ! -z "$1" ] ; do
echo ...rebuilding $1
- $builder -norc -q -Efile ISO-8859-1 -M $old_mem -x "
+ $builder -norc -q -M $old_mem -x "
(let ((*compile-print* nil)
(*compile-progress* nil)
(*compile-verbose* nil)
diff --git a/dev-lisp/clisp/files/2.34/fastcgi-Makefile.in-gentoo.patch b/dev-lisp/clisp/files/2.34/fastcgi-Makefile.in-gentoo.patch
new file mode 100644
index 000000000000..902e1ac267c7
--- /dev/null
+++ b/dev-lisp/clisp/files/2.34/fastcgi-Makefile.in-gentoo.patch
@@ -0,0 +1,17 @@
+diff -ur clisp-2.34.original/modules/fastcgi/Makefile.in clisp-2.34/modules/fastcgi/Makefile.in
+--- clisp-2.34.original/modules/fastcgi/Makefile.in 2004-03-03 08:41:54.000000000 -0600
++++ clisp-2.34/modules/fastcgi/Makefile.in 2004-03-20 00:02:37.235191912 -0600
+@@ -22,10 +22,10 @@
+ $(CLISP) -c fastcgi.lisp
+
+ fastcgi.o: fastcgi.c
+- $(CC) $(CPPFLAGS) $(CFLAGS) $(INCLUDES) -I.. -c fastcgi.c
++ $(CC) $(CPPFLAGS) $(CFLAGS) -I.. -c fastcgi.c
+
+ fastcgi_wrappers.o: fastcgi_wrappers.c
+- $(CC) $(CPPFLAGS) $(CFLAGS) $(INCLUDES) -I.. -c fastcgi_wrappers.c
++ $(CC) $(CPPFLAGS) $(CFLAGS) -I.. -c fastcgi_wrappers.c
+
+ # Make a module
+ clisp-module : all
+
diff --git a/dev-lisp/clisp/files/2.34/glibc-linux.lisp-sigpause-gentoo.patch b/dev-lisp/clisp/files/2.34/glibc-linux.lisp-sigpause-gentoo.patch
new file mode 100644
index 000000000000..e7f6dd69a786
--- /dev/null
+++ b/dev-lisp/clisp/files/2.34/glibc-linux.lisp-sigpause-gentoo.patch
@@ -0,0 +1,15 @@
+diff -U4 --recursive clisp-2.34-orig/modules/bindings/glibc/linux.lisp clisp-2.34/modules/bindings/glibc/linux.lisp
+--- clisp-2.34-orig/modules/bindings/glibc/linux.lisp 2004-07-27 11:51:00.403973848 -0400
++++ clisp-2.34/modules/bindings/glibc/linux.lisp 2004-07-27 11:51:39.937963768 -0400
+@@ -34,8 +34,11 @@
+ (def-c-type ulonglong uint64)
+ (define-modify-macro orf () logior)
+ (define-modify-macro andf () logand)
+
++; Needed to choose sigpause version
++(c-lines "#define __FAVOR_BSD~%~%")
++
+ ; ============================= <stddef.h> ====================================
+
+ (c-lines "#include <stddef.h>~%")
+
diff --git a/dev-lisp/clisp/files/2.34/install-clc.lisp b/dev-lisp/clisp/files/2.34/install-clc.lisp
new file mode 100644
index 000000000000..06cb217d32cf
--- /dev/null
+++ b/dev-lisp/clisp/files/2.34/install-clc.lisp
@@ -0,0 +1,15 @@
+;;;; -*- Mode: Lisp; Package: CL-USER -*-
+;;;; Copyright (c) 2004 Kevin M. Rosenberg
+;;;; GNU GPL v2 license
+
+(in-package #:cl-user)
+
+(handler-case
+ (load "/usr/share/common-lisp/source/common-lisp-controller/common-lisp-controller.lisp")
+ (error (e)
+ (format t "Error during loading of common-lisp-controller.lisp: ~A~%" e)))
+
+(handler-case
+ (common-lisp-controller:init-common-lisp-controller-v4 "clisp")
+ (error (e)
+ (format t "Error during init-common-lisp-controller-v4: ~A~%" e)))
diff --git a/dev-lisp/clisp/files/clisp-2.30-gentoo.patch b/dev-lisp/clisp/files/clisp-2.30-gentoo.patch
deleted file mode 100644
index a3c8d5b2350f..000000000000
--- a/dev-lisp/clisp/files/clisp-2.30-gentoo.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff -ur clisp-2.30~/modules/wildcard/Makefile.in clisp-2.30/modules/wildcard/Makefile.in
---- clisp-2.30~/modules/wildcard/Makefile.in 2000-03-31 18:17:50.000000000 -0600
-+++ clisp-2.30/modules/wildcard/Makefile.in 2003-03-07 11:41:22.000000000 -0600
-@@ -24,7 +24,7 @@
- $(CC) $(CFLAGS) -I$(INCLUDES) -c wildcard.c
-
- fnmatch.o : fnmatch.c fnmatch.h
-- $(CC) $(CFLAGS) -I. -DHAVE_CONFIG_H -D_LIBC -c fnmatch.c
-+ $(CC) $(CFLAGS) -I. -DHAVE_CONFIG_H -DLIBC -c fnmatch.c
-
- # Make a module
- clisp-module : all
-Only in clisp-2.30/modules/wildcard: Makefile.in~
-diff -ur clisp-2.30~/modules/wildcard/fnmatch.c clisp-2.30/modules/wildcard/fnmatch.c
---- clisp-2.30~/modules/wildcard/fnmatch.c 1998-07-22 15:22:52.000000000 -0500
-+++ clisp-2.30/modules/wildcard/fnmatch.c 2003-03-07 11:41:14.000000000 -0600
-@@ -37,7 +37,7 @@
- program understand `configure --with-gnu-libc' and omit the object files,
- it is simpler to just do this in the source for each such file. */
-
--#if defined (_LIBC) || !defined (__GNU_LIBRARY__)
-+#if defined (LIBC) || !defined (__GNU_LIBRARY__)
-
-
- # if defined (STDC_HEADERS) || !defined (isascii)
-@@ -238,4 +238,4 @@
- # undef FOLD
- }
-
--#endif /* _LIBC or not __GNU_LIBRARY__. */
-+#endif /* LIBC or not __GNU_LIBRARY__. */
-Only in clisp-2.30/modules/wildcard: fnmatch.c~
diff --git a/dev-lisp/clisp/files/clisp-2.30-linux.lisp-upstream.patch b/dev-lisp/clisp/files/clisp-2.30-linux.lisp-upstream.patch
deleted file mode 100644
index b6e3ed363bab..000000000000
--- a/dev-lisp/clisp/files/clisp-2.30-linux.lisp-upstream.patch
+++ /dev/null
@@ -1,122 +0,0 @@
-===================================================================
-RCS file: /cvsroot/clisp/clisp/modules/bindings/linuxlibc6/linux.lisp,v
-retrieving revision 1.16
-retrieving revision 1.18
-diff -u -r1.16 -r1.18
---- clisp/clisp/modules/bindings/linuxlibc6/linux.lisp 2002/07/09 21:28:04 1.16 clisp_2_30-2002-09-15
-+++ clisp/clisp/modules/bindings/linuxlibc6/linux.lisp 2003/02/09 23:27:40 1.18 HEAD
-@@ -403,8 +403,11 @@
- ; ------------------------------ <errnos.h> -----------------------------------
-
- (def-call-out __errno_location (:arguments) (:return-type (c-ptr int)))
-+;; both are broken:
- ;; (define-symbol-macro errno (deref (foreign-value (__errno_location))))
--(def-c-var errno (:type ffi:int))
-+;; *** - FFI::%DEREF: argument is not a foreign variable: 22
-+;; (def-c-var errno (:type ffi:int))
-+;; link error: "undefined reference to `errno'"
-
- ; ------------------------------ <errno.h> ------------------------------------
-
-@@ -506,7 +509,7 @@
- (defconstant PIPE_BUF 4096)
- )
-
--;;; ----------------------------- <local_lim.h> ---------------------------------
-+;;; ----------------------------- <local_lim.h> -------------------------------
-
- (defconstant _POSIX_THREAD_KEYS_MAX 128)
- (defconstant PTHREAD_KEYS_MAX 1024)
-@@ -518,7 +521,10 @@
- ;;; ---------------------------- <posix1_lim.h> ------------------------------
-
- (defconstant SSIZE_MAX INT_MAX)
--(defconstant NGROUPS_MAX _POSIX_NGROUPS_MAX)
-+;; #ifndef NGROUPS_MAX
-+;; # define NGROUPS_MAX _POSIX_NGROUPS_MAX
-+;; #endif
-+;; (defconstant NGROUPS_MAX _POSIX_NGROUPS_MAX)
-
- ;;; ---------------------------- <posix2_lim.h> ------------------------------
-
-@@ -620,7 +626,7 @@
- (defconstant EXIT_FAILURE 1)
- (defconstant EXIT_SUCCESS 0)
-
--(def-call-out __ctype_get_mb_cur_max (:arguments) (:return-type int))
-+(def-call-out __ctype_get_mb_cur_max (:arguments) (:return-type size_t))
- (define-symbol-macro MB_CUR_MAX (__ctype_get_mb_cur_max))
-
- (def-call-out atof (:arguments (nptr c-string)) (:return-type double-float))
-@@ -657,10 +663,10 @@
- (def-call-out random (:arguments) (:return-type int32_t))
- (def-call-out srandom (:arguments (seed uint)) (:return-type nil))
- (def-call-out initstate
-- (:arguments (seed uint) (statebuf c-pointer) (statelen size_t))
-- (:return-type c-pointer))
--(def-call-out setstate (:arguments (statebuf c-pointer))
-- (:return-type c-pointer))
-+ (:arguments (seed uint) (statebuf c-string) (statelen size_t))
-+ (:return-type c-string))
-+(def-call-out setstate (:arguments (statebuf c-string))
-+ (:return-type c-string))
-
- ;; (def-c-struct random_data ...)
- (def-call-out random_r
-@@ -691,8 +697,8 @@
- (:return-type long))
- (def-call-out srand48 (:arguments (seedval long))
- (:return-type nil))
--(def-call-out seed48 (:arguments (seed16v (c-ptr (c-array ushort 3))))
-- (:return-type (c-ptr (c-array ushort 3)) :none))
-+(def-call-out seed48 (:arguments (seed16v (c-array ushort 3)))
-+ (:return-type (c-ptr ushort) :none))
- (def-call-out lcong48 (:arguments (param (c-ptr (c-array ushort 7))))
- (:return-type nil))
-
-@@ -755,7 +761,7 @@
- (def-call-out setenv
- (:arguments (name c-string) (value c-string) (replace boolean))
- (:return-type int))
--(def-call-out unsetenv (:arguments (name c-string)) (:return-type nil))
-+(def-call-out unsetenv (:arguments (name c-string)) (:return-type int))
-
- (def-call-out clearenv (:arguments) (:return-type int))
-
-@@ -778,7 +784,7 @@
- (:arguments (name c-string)
- (resolved (c-ptr (c-array-max character #.PATH_MAX))
- :out :alloca))
-- (:return-type (c-ptr (c-array-max character #.PATH_MAX))))
-+ (:return-type c-string))
-
- (def-c-type comparison_fn_t
- (c-function (:arguments (p1 c-pointer) (p2 c-pointer))
-@@ -1169,14 +1175,19 @@
-
- (def-c-var environ (:type (c-array-ptr c-string)) (:read-only t))
-
--;(def-call-out execve
--; (:arguments (path c-string) (argv c-pointer) (envp c-pointer)) ; ??
--; (:return-type int))
--;(def-call-out fexecve
--; (:arguments (fd int) (argv c-pointer) (envp c-pointer)) ; ??
--; (:return-type int)) ; is a stub (see <gnu/stubs.h>)
--;(def-call-out execv (:arguments (path c-string) (argv c-pointer)) ; ??
--; (:return-type int))
-+(def-call-out execv
-+ (:arguments (path c-string) (argv (c-array-ptr c-string)))
-+ (:return-type int)
-+ (:name "execv"))
-+(def-call-out execve
-+ (:arguments (path c-string) (argv (c-array-ptr c-string))
-+ (envp (c-array-ptr c-string)))
-+ (:return-type int)
-+ (:name "execv"))
-+(def-call-out execvp
-+ (:arguments (file c-string) (argv (c-array-ptr c-string)))
-+ (:return-type int)
-+ (:name "execvp"))
-
- (def-call-out execle0
- (:arguments (path c-string) (argv0 c-string) (null c-string)
diff --git a/dev-lisp/clisp/files/digest-clisp-2.34 b/dev-lisp/clisp/files/digest-clisp-2.34
new file mode 100644
index 000000000000..cd5424c2e086
--- /dev/null
+++ b/dev-lisp/clisp/files/digest-clisp-2.34
@@ -0,0 +1 @@
+MD5 68b20ad2d13bdc544e57000e38c856de clisp-2.34.tar.bz2 8000158