summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-04-13 22:05:00 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-04-13 22:05:00 +0000
commitae9bbda603a9da24b3cd39f2a44516130dcbf8e7 (patch)
tree74defb3db538022b3d29ab52240da2bc5892ccda /dev-lisp/gauche
parentFixes #957 (diff)
downloadgentoo-2-ae9bbda603a9da24b3cd39f2a44516130dcbf8e7.tar.gz
gentoo-2-ae9bbda603a9da24b3cd39f2a44516130dcbf8e7.tar.bz2
gentoo-2-ae9bbda603a9da24b3cd39f2a44516130dcbf8e7.zip
Gauche 0.5.2 scheme environment
Diffstat (limited to 'dev-lisp/gauche')
-rw-r--r--dev-lisp/gauche/ChangeLog12
-rw-r--r--dev-lisp/gauche/files/digest-gauche-0.5.21
-rw-r--r--dev-lisp/gauche/gauche-0.5.2.ebuild34
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-lisp/gauche/ChangeLog b/dev-lisp/gauche/ChangeLog
new file mode 100644
index 000000000000..c0e82b7f12db
--- /dev/null
+++ b/dev-lisp/gauche/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-lisp/gauche
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gauche/ChangeLog,v 1.1 2002/04/13 22:05:00 karltk Exp $
+
+*gauche-0.5.2 (12 Apr 2002)
+
+ 12 Apr 2002; Karl Trygve Kalleberg <karltk@gentoo.org> gauche-0.5.2.ebuild files/digest-gauche-0.5.2:
+
+ Gauche is an R5RS Scheme implementation developed to be a handy script
+ interpreter, which allows programmers and system administrators to write
+ small to large scripts for their daily chores. Quick startup, built-in
+ system interface, native multilingual support are some of my goals.
diff --git a/dev-lisp/gauche/files/digest-gauche-0.5.2 b/dev-lisp/gauche/files/digest-gauche-0.5.2
new file mode 100644
index 000000000000..abbeea290582
--- /dev/null
+++ b/dev-lisp/gauche/files/digest-gauche-0.5.2
@@ -0,0 +1 @@
+MD5 233a581627a462dcff73b869bfbcb960 Gauche-0.5.2.tgz 1373721
diff --git a/dev-lisp/gauche/gauche-0.5.2.ebuild b/dev-lisp/gauche/gauche-0.5.2.ebuild
new file mode 100644
index 000000000000..730495becfab
--- /dev/null
+++ b/dev-lisp/gauche/gauche-0.5.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gauche/gauche-0.5.2.ebuild,v 1.1 2002/04/13 22:05:00 karltk Exp $
+
+S=${WORKDIR}/Gauche-${PV}
+DESCRIPTION="A Unix system friendly scheme interpreter"
+SRC_URI="http://prdownloads.sourceforge.net/gauche/Gauche-${PV}.tgz"
+HOMEPAGE="http://gauche.sf.net"
+
+DEPEND="virtual/glibc"
+RDEPEND="$DEPEND"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+ #make || die
+}
+
+src_install () {
+# make DESTDIR=${D} install || die
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+ dodoc COPYING INSTALL ChangeLog VERSION
+ doman doc/gosh.1 doc/gauche-config.1
+ dodoc doc/README
+}