summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-10-31 22:13:23 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-10-31 22:13:23 +0000
commit6494050d1b450565fff4a29927050e1fd8062ed4 (patch)
treed41612bb61f24d105f5dbdb40db5120e5783b868 /dev-lisp
parentmove to net-wireless (diff)
downloadgentoo-2-6494050d1b450565fff4a29927050e1fd8062ed4.tar.gz
gentoo-2-6494050d1b450565fff4a29927050e1fd8062ed4.tar.bz2
gentoo-2-6494050d1b450565fff4a29927050e1fd8062ed4.zip
Fixes #8289.
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/drscheme/ChangeLog45
-rw-r--r--dev-lisp/drscheme/drscheme-202.ebuild61
-rw-r--r--dev-lisp/drscheme/files/digest-drscheme-2021
3 files changed, 107 insertions, 0 deletions
diff --git a/dev-lisp/drscheme/ChangeLog b/dev-lisp/drscheme/ChangeLog
new file mode 100644
index 000000000000..3a9c6dc3e64d
--- /dev/null
+++ b/dev-lisp/drscheme/ChangeLog
@@ -0,0 +1,45 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/drscheme/ChangeLog,v 1.1 2002/10/31 22:13:23 karltk Exp $
+
+*<PACKAGE_NAME>-<PACKAGE_VERSION>-<PACKAGE_RELEASE> (DD MMM YYYY)
+
+ DD MMM YYYY; YOUR_NAME <YOUR_EMAIL> changed_file1, changed_file2 :
+ Initial import. Ebuild submitted by submitter_name <submitter_email>.
+ Note that the "changed_file" listing is optional if you are simply bumping
+ the rev of the ebuild and are only making changes to the .ebuild file
+ itself. Also note that we now have a single unified paragraph rather than
+ having the first line separated from the rest by a newline. Everything
+ should be in one block like this. (note by drobbins, 16 Jul 2002)
+
+ DD MMM YYYY; YOUR_NAME <YOUR_EMAIL> changed_file1, changed_file2: this is
+ an earlier ChangeLog enty.
+
+-- Explanation of ChangeLog format:
+
+ This changelog is targetted to users. This means that the comments should be
+ well explained and written in clean English.
+
+ Every new version or revision of the package should be marked by a '*'
+ seperator line as above. Changes since the last revision have to be added to
+ the top of the file, underneath the initial copyright and cvs header
+ comments, in exactly the same format as this comment.
+
+ This means that you start with header line that has the following format,
+ indented two spaces:
+
+ DD MMM YYYY; your_name <your_email> changed_file1, changed_file2: Your
+ explanation should follow. It should be indented and wrapped at a line width
+ of 80 characters. The changed_files can be omitted if they are obvious; for
+ example, if you are only modifying the .ebuild file and committing a new rev
+ of a package. Any details about what exactly changed in the code should be
+ added as a message when the changes are committed to cvs, not in this file.
+
+-- A word regarding credit:
+
+ Please add credit information ("ebuild submitted by ...", "patch submitted
+ by ...") to the ChangeLog. Do not add this information to the ebuilds
+ themselves.
+
+ And remember: Give credit where credit is due. We're all doing this for
+ free, so the best we can hope (and expect!) to receive is credit.
diff --git a/dev-lisp/drscheme/drscheme-202.ebuild b/dev-lisp/drscheme/drscheme-202.ebuild
new file mode 100644
index 000000000000..3e9ad2cef353
--- /dev/null
+++ b/dev-lisp/drscheme/drscheme-202.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/drscheme/drscheme-202.ebuild,v 1.1 2002/10/31 22:13:23 karltk Exp $
+
+S=${WORKDIR}/plt
+DESCRIPTION="DrScheme programming environment. Includes mzscheme."
+HOMEPAGE="http://www.plt-scheme.org/software/drscheme/"
+SRC_URI="mirror://gentoo/plt.src.x-202.tar.gz"
+DEPEND=">=sys-devel/gcc-2.95.3-r7
+ virtual/x11
+ opengl? ( virtual/opengl )"
+RDEPEND="virtual/x11
+ opengl? ( virtual/opengl )"
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86"
+IUSE=""
+
+src_compile() {
+ cd ${S}/src
+
+ econf \
+ --prefix=/usr/share/drscheme/
+
+ make || die
+}
+
+mysed() {
+ file=${D}/$1
+ mv ${file} ${file}.orig
+ sed s.${D}./. < ${file}.orig> ${file}
+ chmod a+x ${file}
+ rm ${file}.orig
+}
+
+src_install () {
+ dodir /usr/bin
+ dodir /usr/share/drscheme
+
+ cd ${S}/src
+ sed -e 's/cp -p/cp/' Makefile > Makefile.new
+ mv Makefile.new Makefile
+ echo -e "n\n" | make prefix=${D}/usr/share/drscheme install || die
+ dodoc README
+ cd ${D}/usr/share/drscheme/man/man1
+ doman *
+ rm -rf ${D}/usr/share/drscheme/man
+
+ for x in background-help-desk drscheme games help-desk mzc \
+ setup-plt tex2page web-server web-server-monitor \
+ web-server-text
+ do
+ mysed /usr/share/drscheme/bin/${x}
+ done
+
+ cd ${D}/usr/share/drscheme/bin
+ for x in *
+ do
+ dosym /usr/share/drscheme/bin/${file} /usr/bin/${file}
+ done
+}
diff --git a/dev-lisp/drscheme/files/digest-drscheme-202 b/dev-lisp/drscheme/files/digest-drscheme-202
new file mode 100644
index 000000000000..54602dfd5bef
--- /dev/null
+++ b/dev-lisp/drscheme/files/digest-drscheme-202
@@ -0,0 +1 @@
+MD5 cdc393660094aca6d65b4899673b6fe0 plt.src.x-202.tar.gz 6128207