summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2012-02-11 14:58:16 +0000
committerAndrey Grozin <grozin@gentoo.org>2012-02-11 14:58:16 +0000
commit77ca3c2e62b11f51e2a50ab158038e8b306a428c (patch)
tree2a383b24eb5ec16fff115baac7e2c4eaba302b5c /dev-lisp
parentDo not call env-update in pkg_postinst (bug #402339). (diff)
downloadgentoo-2-77ca3c2e62b11f51e2a50ab158038e8b306a428c.tar.gz
gentoo-2-77ca3c2e62b11f51e2a50ab158038e8b306a428c.tar.bz2
gentoo-2-77ca3c2e62b11f51e2a50ab158038e8b306a428c.zip
Version bump
(Portage version: 2.2.0_alpha85/cvs/Linux i686)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/ecls/ChangeLog11
-rw-r--r--dev-lisp/ecls/ecls-12.2.1.ebuild (renamed from dev-lisp/ecls/ecls-10.2.1.ebuild)39
-rw-r--r--dev-lisp/ecls/files/12.2.1-headers-gentoo.patch (renamed from dev-lisp/ecls/files/10.2.1-headers-gentoo.patch)0
3 files changed, 34 insertions, 16 deletions
diff --git a/dev-lisp/ecls/ChangeLog b/dev-lisp/ecls/ChangeLog
index dfe9d12c611c..0b8e02113873 100644
--- a/dev-lisp/ecls/ChangeLog
+++ b/dev-lisp/ecls/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lisp/ecls
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.40 2011/03/07 23:00:23 ulm Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.41 2012/02/11 14:58:16 grozin Exp $
+
+*ecls-12.2.1 (11 Feb 2012)
+
+ 11 Feb 2012; Andrey Grozin <grozin@gentoo.org>
+ +files/12.2.1-headers-gentoo.patch, -files/10.2.1-headers-gentoo.patch,
+ -ecls-10.2.1.ebuild, +ecls-12.2.1.ebuild:
+ Version bump
07 Mar 2011; Ulrich Mueller <ulm@gentoo.org> ecls-11.1.1-r1.ebuild:
Avoid autodetection of the etags program. Make sure that with USE=emacs,
diff --git a/dev-lisp/ecls/ecls-10.2.1.ebuild b/dev-lisp/ecls/ecls-12.2.1.ebuild
index 9cca1a46da2e..c8209b8e1ffe 100644
--- a/dev-lisp/ecls/ecls-10.2.1.ebuild
+++ b/dev-lisp/ecls/ecls-12.2.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-10.2.1.ebuild,v 1.2 2010/12/17 20:18:31 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-12.2.1.ebuild,v 1.1 2012/02/11 14:58:16 grozin Exp $
EAPI=3
-inherit eutils multilib
+inherit eutils multilib
MY_P=ecl-${PV}
DESCRIPTION="ECL is an embeddable Common Lisp implementation."
@@ -14,16 +14,25 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz"
LICENSE="BSD LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="debug doc precisegc +threads +unicode X"
+IUSE="debug emacs gengc precisegc threads +unicode X"
RDEPEND="dev-libs/gmp
virtual/libffi
>=dev-libs/boehm-gc-7.1[threads?]"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ app-text/texi2html
+ emacs? ( virtual/emacs >=app-admin/eselect-emacs-1.12 )"
PDEPEND="dev-lisp/gentoo-init"
S="${WORKDIR}"/${MY_P}
+pkg_setup() {
+ if use gengc || use precisegc; then
+ ewarn "USE flags gengc and precisegc are experimental"
+ ewarn "Don't use them if you want a stable ecl"
+ fi
+}
+
src_prepare() {
epatch "${FILESDIR}"/${PV}-headers-gentoo.patch
}
@@ -33,7 +42,7 @@ src_configure() {
--with-system-gmp \
--enable-boehm=system \
--enable-longdouble \
- --enable-gengc \
+ $(use_enable gengc) \
$(use_enable precisegc) \
$(use_with debug debug-cflags) \
$(use_enable threads) \
@@ -44,13 +53,18 @@ src_configure() {
}
src_compile() {
- #parallel fails
- emake -j1 || die "Compilation failed"
- if use doc; then
- pushd build/doc
- emake || die "Building docs failed"
+ if use emacs; then
+ local ETAGS=$(eselect --brief etags list | sed -ne '/emacs/{p;q}')
+ [[ -n ${ETAGS} ]] || die "No etags implementation found"
+ pushd build || die
+ emake ETAGS=${ETAGS} TAGS || die
popd
+ else
+ touch build/TAGS
fi
+
+ #parallel fails
+ emake -j1 || die "Compilation failed"
}
src_install () {
@@ -61,8 +75,5 @@ src_install () {
pushd build/doc
newman ecl.man ecl.1
newman ecl-config.man ecl-config.1
- if use doc; then
- doinfo ecl{,dev}.info || die "Installing info docs failed"
- fi
popd
}
diff --git a/dev-lisp/ecls/files/10.2.1-headers-gentoo.patch b/dev-lisp/ecls/files/12.2.1-headers-gentoo.patch
index 635fc5d4afde..635fc5d4afde 100644
--- a/dev-lisp/ecls/files/10.2.1-headers-gentoo.patch
+++ b/dev-lisp/ecls/files/12.2.1-headers-gentoo.patch