summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2013-05-19 05:13:01 +0000
committerAndrey Grozin <grozin@gentoo.org>2013-05-19 05:13:01 +0000
commiteb845feb6eada2b7552e2bd243c40548e7b3626a (patch)
treeee71be58743556526a6e64652918e2458ae496c2 /dev-lisp
parent2.2.0_alpha176 version bump. This includes all of the fixes in 2.1.12.1. (diff)
downloadgentoo-2-eb845feb6eada2b7552e2bd243c40548e7b3626a.tar.gz
gentoo-2-eb845feb6eada2b7552e2bd243c40548e7b3626a.tar.bz2
gentoo-2-eb845feb6eada2b7552e2bd243c40548e7b3626a.zip
Version bump
(Portage version: 2.2.0_alpha175/cvs/Linux i686, signed Manifest commit with key 0x3AFFCE974D34BD8C!)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/asdf/ChangeLog7
-rw-r--r--dev-lisp/asdf/asdf-3.0.1.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-lisp/asdf/ChangeLog b/dev-lisp/asdf/ChangeLog
index 6958e8450f68..b6b4b4b4bb94 100644
--- a/dev-lisp/asdf/ChangeLog
+++ b/dev-lisp/asdf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/asdf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/asdf/ChangeLog,v 1.8 2013/04/25 03:04:24 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/asdf/ChangeLog,v 1.9 2013/05/19 05:13:01 grozin Exp $
+
+*asdf-3.0.1 (19 May 2013)
+
+ 19 May 2013; Andrey Grozin <grozin@gentoo.org> +asdf-3.0.1.ebuild:
+ Version bump
25 Apr 2013; Andrey Grozin <grozin@gentoo.org> asdf-2.33-r4.ebuild:
DEPEND on <texinfo-5.0 (bug #467146)
diff --git a/dev-lisp/asdf/asdf-3.0.1.ebuild b/dev-lisp/asdf/asdf-3.0.1.ebuild
new file mode 100644
index 000000000000..19365717b0d5
--- /dev/null
+++ b/dev-lisp/asdf/asdf-3.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/asdf/asdf-3.0.1.ebuild,v 1.1 2013/05/19 05:13:01 grozin Exp $
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="ASDF is Another System Definition Facility for Common Lisp"
+HOMEPAGE="http://common-lisp.net/project/asdf/"
+SRC_URI="http://common-lisp.net/project/${PN}/archives/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+SLOT="0/${PVR}"
+
+DEPEND="!dev-lisp/cl-${PN}
+ !dev-lisp/asdf-binary-locations
+ !dev-lisp/gentoo-init
+ !<dev-lisp/asdf-2.33-r3
+ doc? ( <sys-apps/texinfo-5.0 virtual/texi2dvi )"
+RDEPEND=""
+PDEPEND="~dev-lisp/uiop-${PV}"
+
+S="${WORKDIR}"
+
+src_compile() {
+ make
+ use doc && make doc
+}
+
+src_install() {
+ insinto /usr/share/common-lisp/source/${PN}
+ doins -r build version.lisp-expr
+ dodoc README TODO
+ dohtml doc/*.{html,css,ico,png}
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/${PN}.pdf
+ fi
+
+ insinto /etc/common-lisp
+ doins "${FILESDIR}"/gentoo-init.lisp "${FILESDIR}"/source-registry.conf
+}