summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2005-06-21 20:32:50 +0000
committerSimon Stelling <blubb@gentoo.org>2005-06-21 20:32:50 +0000
commitf20059875e00bb04943b74265d400d80ea0ffd98 (patch)
tree0a2a6194103e9aec31da21ad32edfadccec845cc /dev-lisp
parentSecurity Bump per bug #96243, updated metadata (diff)
downloadgentoo-2-f20059875e00bb04943b74265d400d80ea0ffd98.tar.gz
gentoo-2-f20059875e00bb04943b74265d400d80ea0ffd98.tar.bz2
gentoo-2-f20059875e00bb04943b74265d400d80ea0ffd98.zip
bug 90911
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/clisp/ChangeLog6
-rw-r--r--dev-lisp/clisp/clisp-2.33.2-r2.ebuild3
-rw-r--r--dev-lisp/clisp/files/2.33.2/compilefix.patch17
3 files changed, 24 insertions, 2 deletions
diff --git a/dev-lisp/clisp/ChangeLog b/dev-lisp/clisp/ChangeLog
index a20c18e62710..5c7042a04dff 100644
--- a/dev-lisp/clisp/ChangeLog
+++ b/dev-lisp/clisp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lisp/clisp
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.35 2005/06/14 23:17:21 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.36 2005/06/21 20:32:50 blubb Exp $
+
+ 21 Jun 2005; Simon Stelling <blubb@gentoo.org>
+ +files/2.33.2/compilefix.patch, clisp-2.33.2-r2.ebuild:
+ fix bug 90911
14 Jun 2005; <mkennedy@gentoo.org> clisp-2.33.2-r2.ebuild:
Keywording ~sparc
diff --git a/dev-lisp/clisp/clisp-2.33.2-r2.ebuild b/dev-lisp/clisp/clisp-2.33.2-r2.ebuild
index a7f7888080f7..34db0763737e 100644
--- a/dev-lisp/clisp/clisp-2.33.2-r2.ebuild
+++ b/dev-lisp/clisp/clisp-2.33.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.33.2-r2.ebuild,v 1.5 2005/06/14 23:17:21 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.33.2-r2.ebuild,v 1.6 2005/06/21 20:32:50 blubb Exp $
inherit flag-o-matic common-lisp-common-2 eutils
@@ -30,6 +30,7 @@ src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${PV}/fastcgi-Makefile.in-gentoo.patch || die
epatch ${FILESDIR}/${PV}/glibc-linux.lisp-sigpause-gentoo.patch || die
+ epatch ${FILESDIR}/${PV}/compilefix.patch || die
}
src_compile() {
diff --git a/dev-lisp/clisp/files/2.33.2/compilefix.patch b/dev-lisp/clisp/files/2.33.2/compilefix.patch
new file mode 100644
index 000000000000..507c72c22747
--- /dev/null
+++ b/dev-lisp/clisp/files/2.33.2/compilefix.patch
@@ -0,0 +1,17 @@
+--- clisp-2.33.2/src/genclisph.d.orig 2004-05-27 09:43:38.000000000 -0500
++++ clisp-2.33.2/src/genclisph.d 2005-05-09 14:24:44.000000000 -0500
+@@ -891,13 +891,13 @@
+ printf("#define sstring_length(ptr) sarray_length(ptr)\n");
+ printf("#define Sstring_length(obj) sstring_length(TheSstring(obj))\n");
+ printf("extern bool string_equal (object string1, object string2);\n");
+- /*
+ #ifdef TYPECODES
+ printf("#define Array_type_simple_bit_vector(atype) (%d+((atype)<<%d)",Array_type_sbvector,TB0);
+ if (TB0+1 != TB1) printf("+((atype)&%d)",bit(TB0+1)-bit(TB1));
+ if (TB1+1 != TB2) printf("+((atype)&%d)",bit(TB1+1)-bit(TB2));
+ printf(")\n");
+ #endif
++ /*
+ sprintf(buf,"struct { XRECORD_HEADER gcv_object_t pack_external_symbols%s; gcv_object_t pack_internal_symbols%s; gcv_object_t pack_shadowing_symbols%s; gcv_object_t pack_use_list%s; gcv_object_t pack_used_by_list%s; gcv_object_t pack_name%s; gcv_object_t pack_nicknames%s; } *",attribute_aligned_object,attribute_aligned_object,attribute_aligned_object,attribute_aligned_object,attribute_aligned_object,attribute_aligned_object,attribute_aligned_object);
+ emit_typedef(buf,"Package");
+ */