summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-05-09 16:54:26 +0000
committerTim Harder <radhermit@gentoo.org>2013-05-09 16:54:26 +0000
commit852eb6de09642b5698c0d08f07fcc6b41bbb54ae (patch)
tree1bb58ea921fb7d34f254a7a5bc9e14fd8478e4af /dev-lua
parentMake sure prepare phase from both eclasses are run (reported by ibqn), drop old. (diff)
downloadgentoo-2-852eb6de09642b5698c0d08f07fcc6b41bbb54ae.tar.gz
gentoo-2-852eb6de09642b5698c0d08f07fcc6b41bbb54ae.tar.bz2
gentoo-2-852eb6de09642b5698c0d08f07fcc6b41bbb54ae.zip
Revbump and convert to autotools build (fixes bug #469182).
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luacrypto/ChangeLog8
-rw-r--r--dev-lua/luacrypto/files/luacrypto-0.3.2-lualibdir.patch11
-rw-r--r--dev-lua/luacrypto/luacrypto-0.3.2-r1.ebuild39
3 files changed, 57 insertions, 1 deletions
diff --git a/dev-lua/luacrypto/ChangeLog b/dev-lua/luacrypto/ChangeLog
index 1228149527a2..ee3709c17703 100644
--- a/dev-lua/luacrypto/ChangeLog
+++ b/dev-lua/luacrypto/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lua/luacrypto
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lua/luacrypto/ChangeLog,v 1.1 2013/05/08 23:29:36 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luacrypto/ChangeLog,v 1.2 2013/05/09 16:54:26 radhermit Exp $
+
+*luacrypto-0.3.2-r1 (09 May 2013)
+
+ 09 May 2013; Tim Harder <radhermit@gentoo.org> +luacrypto-0.3.2-r1.ebuild,
+ +files/luacrypto-0.3.2-lualibdir.patch:
+ Revbump and convert to autotools build (fixes bug #469182).
*luacrypto-0.3.2 (08 May 2013)
diff --git a/dev-lua/luacrypto/files/luacrypto-0.3.2-lualibdir.patch b/dev-lua/luacrypto/files/luacrypto-0.3.2-lualibdir.patch
new file mode 100644
index 000000000000..461e066865c2
--- /dev/null
+++ b/dev-lua/luacrypto/files/luacrypto-0.3.2-lualibdir.patch
@@ -0,0 +1,11 @@
+--- luacrypto-0.3.2/configure.ac
++++ luacrypto-0.3.2/configure.ac
+@@ -31,7 +31,7 @@
+ PKG_CHECK_MODULES([LUA], [lua])
+
+ # lua libdir
+-LUALIBDIR="`$PKGCONFIG --variable=libdir lua`"
++LUALIBDIR="`$PKGCONFIG --variable=INSTALL_CMOD lua`"
+
+ # dest of headers
+ CRYPTOINC="${includedir}/${PACKAGE_NAME}"
diff --git a/dev-lua/luacrypto/luacrypto-0.3.2-r1.ebuild b/dev-lua/luacrypto/luacrypto-0.3.2-r1.ebuild
new file mode 100644
index 000000000000..6439fd0bb8ff
--- /dev/null
+++ b/dev-lua/luacrypto/luacrypto-0.3.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luacrypto/luacrypto-0.3.2-r1.ebuild,v 1.1 2013/05/09 16:54:26 radhermit Exp $
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="Lua frontend to OpenSSL"
+HOMEPAGE="http://mkottman.github.io/luacrypto/ https://github.com/mkottman/luacrypto/"
+SRC_URI="https://github.com/mkottman/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-lang/lua-5.1
+ dev-libs/openssl:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-test.patch
+ epatch "${FILESDIR}"/${P}-lualibdir.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf --htmldir=/usr/share/doc/${PF}/html
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}