summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-02 19:19:00 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-02 19:19:00 +0000
commit530cd47c92247b4fc0129ee7f379a0e96acea991 (patch)
tree2784ba1549d2d56516a52b2d581755c5d77d91d8 /dev-ml/camlp5
parentMarking amarok-1.4.7-r2 ppc64 for bug 204046 (diff)
downloadgentoo-2-530cd47c92247b4fc0129ee7f379a0e96acea991.tar.gz
gentoo-2-530cd47c92247b4fc0129ee7f379a0e96acea991.tar.bz2
gentoo-2-530cd47c92247b4fc0129ee7f379a0e96acea991.zip
version bump
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'dev-ml/camlp5')
-rw-r--r--dev-ml/camlp5/ChangeLog7
-rw-r--r--dev-ml/camlp5/camlp5-5.07.ebuild54
-rw-r--r--dev-ml/camlp5/files/digest-camlp5-5.073
3 files changed, 63 insertions, 1 deletions
diff --git a/dev-ml/camlp5/ChangeLog b/dev-ml/camlp5/ChangeLog
index 8ecc459595a3..41d08a128b97 100644
--- a/dev-ml/camlp5/ChangeLog
+++ b/dev-ml/camlp5/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/camlp5
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.13 2008/01/02 18:20:50 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.14 2008/01/02 19:18:59 aballier Exp $
+
+*camlp5-5.07 (02 Jan 2008)
+
+ 02 Jan 2008; Alexis Ballier <aballier@gentoo.org> +camlp5-5.07.ebuild:
+ version bump
02 Jan 2008; Alexis Ballier <aballier@gentoo.org> -camlp5-5.05.ebuild:
remove old
diff --git a/dev-ml/camlp5/camlp5-5.07.ebuild b/dev-ml/camlp5/camlp5-5.07.ebuild
new file mode 100644
index 000000000000..495ee26bc11f
--- /dev/null
+++ b/dev-ml/camlp5/camlp5-5.07.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/camlp5-5.07.ebuild,v 1.1 2008/01/02 19:18:59 aballier Exp $
+
+inherit multilib findlib eutils
+
+EAPI="1"
+
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="http://pauillac.inria.fr/~ddr/camlp5/"
+SRC_URI="http://pauillac.inria.fr/~ddr/camlp5/distrib/src/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.09"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_compile() {
+ ./configure \
+ -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/$(get_libdir)/ocaml \
+ -mandir /usr/share/man || die "configure failed"
+
+ emake -j1 || die "emake failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "Compiling native code programs failed"
+ emake -j1 opt.opt || die "Compiling native code programs failed"
+ fi
+
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ # findlib support
+ insinto "$(ocamlfind printconf destdir)/${PN}"
+ doins etc/META || die "failed to install META file for findlib support"
+
+ use doc && dohtml -r doc/*
+
+ dodoc CHANGES DEVEL ICHANGES README UPGRADING MODE
+}
diff --git a/dev-ml/camlp5/files/digest-camlp5-5.07 b/dev-ml/camlp5/files/digest-camlp5-5.07
new file mode 100644
index 000000000000..089924012b3e
--- /dev/null
+++ b/dev-ml/camlp5/files/digest-camlp5-5.07
@@ -0,0 +1,3 @@
+MD5 0fec937e7d84b4f0c44b07522e443cf1 camlp5-5.07.tgz 629672
+RMD160 6004bdd5bdcd36ba5658ec637d33a12c84e19b64 camlp5-5.07.tgz 629672
+SHA256 9476012c98f8086d7ce34be1a98df4198f80ede5f0e0a58f6d3d254e1b85eb92 camlp5-5.07.tgz 629672