summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-06-21 12:43:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-06-21 12:43:29 +0000
commit6bcacdbee6907bf4f894dc76f205043726c0156b (patch)
treef525be6b882812166872c2e0d3bd97ccf2c8a2fa /dev-ml/camlzip
parentVersion bump (diff)
downloadgentoo-2-6bcacdbee6907bf4f894dc76f205043726c0156b.tar.gz
gentoo-2-6bcacdbee6907bf4f894dc76f205043726c0156b.tar.bz2
gentoo-2-6bcacdbee6907bf4f894dc76f205043726c0156b.zip
version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/camlzip')
-rw-r--r--dev-ml/camlzip/ChangeLog7
-rw-r--r--dev-ml/camlzip/camlzip-1.04.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-ml/camlzip/ChangeLog b/dev-ml/camlzip/ChangeLog
index 78b5e4455f53..e997a0211c0a 100644
--- a/dev-ml/camlzip/ChangeLog
+++ b/dev-ml/camlzip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/camlzip
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlzip/ChangeLog,v 1.15 2009/06/21 12:35:21 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlzip/ChangeLog,v 1.16 2009/06/21 12:43:29 aballier Exp $
+
+*camlzip-1.04 (21 Jun 2009)
+
+ 21 Jun 2009; Alexis Ballier <aballier@gentoo.org> +camlzip-1.04.ebuild:
+ version bump
21 Jun 2009; Alexis Ballier <aballier@gentoo.org> camlzip-1.03-r1.ebuild:
define eapi before inherit and assign rdepend explicitly
diff --git a/dev-ml/camlzip/camlzip-1.04.ebuild b/dev-ml/camlzip/camlzip-1.04.ebuild
new file mode 100644
index 000000000000..d7173e6c1d02
--- /dev/null
+++ b/dev-ml/camlzip/camlzip-1.04.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlzip/camlzip-1.04.ebuild,v 1.1 2009/06/21 12:43:29 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
+HOMEPAGE="http://cristal.inria.fr/~xleroy/software.html#camlzip"
+SRC_URI="http://caml.inria.fr/distrib/bazar-ocaml/${P}.tar.gz"
+
+SLOT="1"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
+ >=sys-libs/zlib-1.1.3"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.03-Makefile-findlib.patch"
+ sed -e "s/VERSION/${PV}/" "${FILESDIR}/META" >> META
+}
+
+src_compile() {
+ emake all || die "Failed at compilation step !!!"
+ if use ocamlopt; then
+ emake allopt || die "Failed at ML compilation step !!!"
+ fi
+}
+
+src_install() {
+ findlib_src_install
+
+ dodoc README Changes
+}