summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-04-14 18:34:52 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-04-14 18:34:52 +0000
commitaff4aa2ebdb4103d94178908d13f8fd7d80576d0 (patch)
tree10e247634bd4692ef0d083dae4d8f992917a2eb9 /dev-ml/camomile
parentAdd prefix support and keywords (diff)
downloadgentoo-2-aff4aa2ebdb4103d94178908d13f8fd7d80576d0.tar.gz
gentoo-2-aff4aa2ebdb4103d94178908d13f8fd7d80576d0.tar.bz2
gentoo-2-aff4aa2ebdb4103d94178908d13f8fd7d80576d0.zip
version bump
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/camomile')
-rw-r--r--dev-ml/camomile/ChangeLog9
-rw-r--r--dev-ml/camomile/camomile-0.8.2.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-ml/camomile/ChangeLog b/dev-ml/camomile/ChangeLog
index fd1e80bfb7e4..f54fc4e47951 100644
--- a/dev-ml/camomile/ChangeLog
+++ b/dev-ml/camomile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/camomile
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/ChangeLog,v 1.24 2010/11/05 10:32:44 phajdan.jr Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/ChangeLog,v 1.25 2011/04/14 18:34:52 aballier Exp $
+
+*camomile-0.8.2 (14 Apr 2011)
+
+ 14 Apr 2011; Alexis Ballier <aballier@gentoo.org> +camomile-0.8.2.ebuild:
+ version bump
05 Nov 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
camomile-0.8.1.ebuild:
diff --git a/dev-ml/camomile/camomile-0.8.2.ebuild b/dev-ml/camomile/camomile-0.8.2.ebuild
new file mode 100644
index 000000000000..7350aebcc8ef
--- /dev/null
+++ b/dev-ml/camomile/camomile-0.8.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/camomile-0.8.2.ebuild,v 1.1 2011/04/14 18:34:52 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+DESCRIPTION="Camomile is a comprehensive Unicode library for ocaml."
+HOMEPAGE="http://camomile.sourceforge.net/"
+SRC_URI="mirror://sourceforge/camomile/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug +ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_compile() {
+ emake -j1 byte unidata unimaps charmap_data locale_data || die "failed to build"
+ if use ocamlopt; then
+ emake -j1 opt || die "failed to build native code"
+ fi
+}
+
+src_install() {
+ dodir /usr/bin
+ findlib_src_install DATADIR="${D}/usr/share" BINDIR="${D}/usr/bin"
+}