summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-07-13 22:20:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-07-13 22:20:29 +0000
commit77748920b2f9890d93cdc7c5790a6ea981aecd6e (patch)
tree74ce345055aa782e4e3331acb538da3c989c38d7 /dev-ml/findlib
parentVersion bump to 6.1.5 (diff)
downloadgentoo-2-77748920b2f9890d93cdc7c5790a6ea981aecd6e.tar.gz
gentoo-2-77748920b2f9890d93cdc7c5790a6ea981aecd6e.tar.bz2
gentoo-2-77748920b2f9890d93cdc7c5790a6ea981aecd6e.zip
remove old
(Portage version: 2.2.0_alpha117/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/findlib')
-rw-r--r--dev-ml/findlib/ChangeLog5
-rw-r--r--dev-ml/findlib/findlib-1.3.2.ebuild77
2 files changed, 4 insertions, 78 deletions
diff --git a/dev-ml/findlib/ChangeLog b/dev-ml/findlib/ChangeLog
index 213acbb76cf0..496d8d5848ff 100644
--- a/dev-ml/findlib/ChangeLog
+++ b/dev-ml/findlib/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/findlib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/ChangeLog,v 1.87 2012/07/13 22:18:36 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/ChangeLog,v 1.88 2012/07/13 22:20:29 aballier Exp $
+
+ 13 Jul 2012; Alexis Ballier <aballier@gentoo.org> -findlib-1.3.2.ebuild:
+ remove old
*findlib-1.3.3 (13 Jul 2012)
diff --git a/dev-ml/findlib/findlib-1.3.2.ebuild b/dev-ml/findlib/findlib-1.3.2.ebuild
deleted file mode 100644
index bd605f196272..000000000000
--- a/dev-ml/findlib/findlib-1.3.2.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/findlib-1.3.2.ebuild,v 1.1 2012/06/10 20:17:01 aballier Exp $
-
-EAPI=2
-
-inherit multilib
-
-RESTRICT="installsources"
-
-DESCRIPTION="OCaml tool to find/use non-standard packages."
-HOMEPAGE="http://projects.camlcity.org/projects/findlib.html"
-SRC_URI="http://download.camlcity.org/download/${P}.tar.gz"
-IUSE="doc +ocamlopt tk"
-
-LICENSE="MIT"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
-
-DEPEND=">=dev-lang/ocaml-4.00.0_alpha[ocamlopt?,tk?]"
-RDEPEND="${DEPEND}"
-
-ocamlfind_destdir="/usr/$(get_libdir)/ocaml"
-stublibs="${ocamlfind_destdir}/stublibs"
-
-src_configure() {
- local myconf
- use tk && myconf="-with-toolbox"
- ./configure -bindir /usr/bin -mandir /usr/share/man \
- -sitelib ${ocamlfind_destdir} \
- -config ${ocamlfind_destdir}/findlib/findlib.conf \
- ${myconf} || die "configure failed"
-}
-
-src_compile() {
- emake all || die
- if use ocamlopt; then
- emake opt || die # optimized code
- else
- # If using bytecode we dont want to strip the binary as it would remove the
- # bytecode and only leave ocamlrun...
- export STRIP_MASK="*/bin/*"
- fi
-}
-
-src_install() {
- dodir `ocamlc -where`
-
- emake prefix="${D}" install || die
-
- dodir "${stublibs}"
-
- cd "${S}/doc"
- dodoc QUICKSTART README DOCINFO
- use doc && dohtml -r ref-html guide-html
-}
-
-check_stublibs() {
- local ocaml_stdlib=`ocamlc -where`
- local ldconf="${ocaml_stdlib}/ld.conf"
-
- if [ ! -e ${ldconf} ]
- then
- echo "${ocaml_stdlib}" > ${ldconf}
- echo "${ocaml_stdlib}/stublibs" >> ${ldconf}
- fi
-
- if [ -z `grep -e ${stublibs} ${ldconf}` ]
- then
- echo ${stublibs} >> ${ldconf}
- fi
-}
-
-pkg_postinst() {
- check_stublibs
-}