summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-12-08 12:13:06 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-12-08 12:13:06 +0000
commit6d01bcff30f785aa209b68544c7939eb766e5d94 (patch)
tree32fa8910f6515738f12776bea28645774dbce84b /dev-ml/js_of_ocaml
parentFinish Prefix support, add Patches for Darwin and Solaris, add Prefix keywords (diff)
downloadgentoo-2-6d01bcff30f785aa209b68544c7939eb766e5d94.tar.gz
gentoo-2-6d01bcff30f785aa209b68544c7939eb766e5d94.tar.bz2
gentoo-2-6d01bcff30f785aa209b68544c7939eb766e5d94.zip
version bump, bug #446140 by Jacques-Pascal Deplaix
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/js_of_ocaml')
-rw-r--r--dev-ml/js_of_ocaml/ChangeLog7
-rw-r--r--dev-ml/js_of_ocaml/js_of_ocaml-1.3.2.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-ml/js_of_ocaml/ChangeLog b/dev-ml/js_of_ocaml/ChangeLog
index 9202ab5a8999..be446daf1c8f 100644
--- a/dev-ml/js_of_ocaml/ChangeLog
+++ b/dev-ml/js_of_ocaml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/js_of_ocaml
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/js_of_ocaml/ChangeLog,v 1.1 2012/08/03 13:52:24 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/js_of_ocaml/ChangeLog,v 1.2 2012/12/08 12:13:06 aballier Exp $
+
+*js_of_ocaml-1.3.2 (08 Dec 2012)
+
+ 08 Dec 2012; Alexis Ballier <aballier@gentoo.org> +js_of_ocaml-1.3.2.ebuild:
+ version bump, bug #446140 by Jacques-Pascal Deplaix
*js_of_ocaml-1.2 (03 Aug 2012)
diff --git a/dev-ml/js_of_ocaml/js_of_ocaml-1.3.2.ebuild b/dev-ml/js_of_ocaml/js_of_ocaml-1.3.2.ebuild
new file mode 100644
index 000000000000..94458320b6c4
--- /dev/null
+++ b/dev-ml/js_of_ocaml/js_of_ocaml-1.3.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/js_of_ocaml/js_of_ocaml-1.3.2.ebuild,v 1.1 2012/12/08 12:13:06 aballier Exp $
+
+EAPI=4
+
+inherit findlib
+
+DESCRIPTION="A compiler from OCaml bytecode to javascript"
+HOMEPAGE="http://ocsigen.org/js_of_ocaml/"
+SRC_URI="http://www.ocsigen.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt doc +deriving-ocsigen"
+
+DEPEND=">=dev-lang/ocaml-3.12[ocamlopt?]
+ >=dev-ml/lwt-2.3.0
+ deriving-ocsigen? ( >=dev-ml/deriving-ocsigen-0.3 )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ use ocamlopt || echo "BEST := byte" >> Makefile.conf
+ use deriving-ocsigen || echo "DERIVING :=" >> Makefile.conf
+ echo "BINDIR := ${ED}/usr/bin" >> Makefile.conf
+}
+
+src_compile() {
+ emake
+ use doc && emake doc
+}
+
+src_install() {
+ findlib_src_preinst
+ emake install
+ dodoc CHANGES README
+ use doc && dohtml -r doc/api-html
+}