summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-12-17 18:00:58 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-12-17 18:00:58 +0000
commitc82f9de5dea919749ecf5601dba63fc335e6129a (patch)
treeab3bd8593d7df417620361024e0d2c243808d362 /dev-ml/ocamlnet/ocamlnet-2.2.9-r1.ebuild
parentamd64 stable (diff)
downloadgentoo-2-c82f9de5dea919749ecf5601dba63fc335e6129a.tar.gz
gentoo-2-c82f9de5dea919749ecf5601dba63fc335e6129a.tar.bz2
gentoo-2-c82f9de5dea919749ecf5601dba63fc335e6129a.zip
Import a patch from Stefano Zacchiroli (debian) to force building with camlp5 now that is has findlib support, this fixes the build with ocaml 3.10
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'dev-ml/ocamlnet/ocamlnet-2.2.9-r1.ebuild')
-rw-r--r--dev-ml/ocamlnet/ocamlnet-2.2.9-r1.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/dev-ml/ocamlnet/ocamlnet-2.2.9-r1.ebuild b/dev-ml/ocamlnet/ocamlnet-2.2.9-r1.ebuild
new file mode 100644
index 000000000000..8899ae4518fe
--- /dev/null
+++ b/dev-ml/ocamlnet/ocamlnet-2.2.9-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-2.2.9-r1.ebuild,v 1.1 2007/12/17 18:00:58 aballier Exp $
+
+inherit eutils findlib
+
+DESCRIPTION="Modules for OCaml application-level Internet protocols"
+HOMEPAGE="http://ocamlnet.sourceforge.net"
+SRC_URI="mirror://sourceforge/ocamlnet/${P}.tar.gz"
+
+LICENSE="as-is GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk ssl tk httpd"
+
+# the auth-dh compile flag has been disabled as well, since it depends on
+# ocaml-cryptgps, which is not available.
+
+DEPEND="!dev-ml/equeue
+ !dev-ml/rpc
+ !dev-ml/netclient
+ >=dev-ml/findlib-1.0
+ >=dev-ml/pcre-ocaml-5
+ >=dev-ml/camlp5-5.05
+ gtk? ( >=dev-ml/lablgtk-2 )
+ ssl? ( dev-ml/ocaml-ssl )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if use tk && ! built_with_use 'dev-lang/ocaml' tk ;
+ then die "If you want to enable tcl/tk, you need to rebuild dev-lang/ocaml with the 'tk' USE flag";
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/build_w_camlp5.dpatch"
+}
+
+ocamlnet_use_with() {
+ if use $1; then
+ echo "-with-$2"
+ else
+ echo "-without-$2"
+ fi
+}
+
+ocamlnet_use_enable() {
+ if use $1; then
+ echo "-enable-$2"
+ else
+ echo "-disable-$2"
+ fi
+}
+
+src_compile() {
+ ./configure \
+ -bindir /usr/bin \
+ -datadir /usr/share/${PN} \
+ $(ocamlnet_use_enable gtk gtk2) \
+ $(ocamlnet_use_enable ssl ssl) \
+ $(ocamlnet_use_enable tk tcl) \
+ $(ocamlnet_use_with httpd nethttpd) \
+ || die "Error : econf failed!"
+
+ emake -j1 all opt || die "make failed"
+}
+
+src_install() {
+ findlib_src_install
+}