summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-06-26 17:09:28 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-06-26 17:09:28 +0000
commitcd43df9971032994044b8ba0b7e489342aeb13f3 (patch)
treefdd4dda6b15a2dd17a809e096013a11b77dbf8a4 /dev-ml/ocamlnet
parentSet myself (binki) as unrealircd's maintainer. (diff)
downloadgentoo-2-cd43df9971032994044b8ba0b7e489342aeb13f3.tar.gz
gentoo-2-cd43df9971032994044b8ba0b7e489342aeb13f3.tar.bz2
gentoo-2-cd43df9971032994044b8ba0b7e489342aeb13f3.zip
version bump
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/ocamlnet')
-rw-r--r--dev-ml/ocamlnet/ChangeLog7
-rw-r--r--dev-ml/ocamlnet/ocamlnet-3.3.3.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/dev-ml/ocamlnet/ChangeLog b/dev-ml/ocamlnet/ChangeLog
index 3251dc9727fd..8c48732db73e 100644
--- a/dev-ml/ocamlnet/ChangeLog
+++ b/dev-ml/ocamlnet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocamlnet
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.49 2011/05/09 08:42:19 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.50 2011/06/26 17:09:28 aballier Exp $
+
+*ocamlnet-3.3.3 (26 Jun 2011)
+
+ 26 Jun 2011; Alexis Ballier <aballier@gentoo.org> +ocamlnet-3.3.3.ebuild:
+ version bump
09 May 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> ocamlnet-3.2.1.ebuild:
x86 stable wrt bug #363617
diff --git a/dev-ml/ocamlnet/ocamlnet-3.3.3.ebuild b/dev-ml/ocamlnet/ocamlnet-3.3.3.ebuild
new file mode 100644
index 000000000000..ce54502c5bce
--- /dev/null
+++ b/dev-ml/ocamlnet/ocamlnet-3.3.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-3.3.3.ebuild,v 1.1 2011/06/26 17:09:28 aballier Exp $
+
+EAPI="2"
+
+inherit eutils findlib
+
+MY_P=${P/_beta/test}
+DESCRIPTION="Modules for OCaml application-level Internet protocols"
+HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
+SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
+
+LICENSE="as-is GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="cryptokit gtk ssl tk httpd +ocamlopt +pcre zip"
+RESTRICT="installsources"
+
+# the auth-dh compile flag has been disabled as well, since it depends on
+# ocaml-cryptgps, which is not available.
+
+DEPEND=">=dev-ml/findlib-1.0
+ pcre? ( >=dev-ml/pcre-ocaml-5 )
+ >=dev-lang/ocaml-3.10.2[tk?,ocamlopt?]
+ cryptokit? ( dev-ml/cryptokit )
+ gtk? ( >=dev-ml/lablgtk-2 )
+ ssl? ( >=dev-ml/ocaml-ssl-0.4 )
+ zip? ( dev-ml/camlzip )
+ "
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+ocamlnet_use_with() {
+ if use $1; then
+ echo "-with-$2"
+ else
+ echo "-without-$2"
+ fi
+}
+
+ocamlnet_use_enable() {
+ if use $1; then
+ echo "-enable-$2"
+ else
+ echo "-disable-$2"
+ fi
+}
+
+src_configure() {
+ ./configure \
+ -bindir /usr/bin \
+ -datadir /usr/share/${PN} \
+ $(ocamlnet_use_enable cryptokit crypto) \
+ $(ocamlnet_use_enable gtk gtk2) \
+ $(ocamlnet_use_enable pcre pcre) \
+ $(ocamlnet_use_enable ssl ssl) \
+ $(ocamlnet_use_enable tk tcl) \
+ $(ocamlnet_use_enable zip zip) \
+ $(ocamlnet_use_with httpd nethttpd) \
+ || die "Error : econf failed!"
+}
+
+src_compile() {
+ emake -j1 all || die "make failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "make failed"
+ fi
+}
+
+src_install() {
+ export STRIP_MASK="*/bin/*"
+ findlib_src_install
+}