summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-04-14 18:40:49 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-04-14 18:40:49 +0000
commite1018d21d9d0f284210f5edbf4fe0866a9923048 (patch)
tree879948f82982065b5a118109cae15cabb2bfe337 /dev-ml/ocamlnet
parentVersion bump. (diff)
downloadgentoo-2-e1018d21d9d0f284210f5edbf4fe0866a9923048.tar.gz
gentoo-2-e1018d21d9d0f284210f5edbf4fe0866a9923048.tar.bz2
gentoo-2-e1018d21d9d0f284210f5edbf4fe0866a9923048.zip
remove old
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/ocamlnet')
-rw-r--r--dev-ml/ocamlnet/ChangeLog6
-rw-r--r--dev-ml/ocamlnet/ocamlnet-3.0.3.ebuild72
-rw-r--r--dev-ml/ocamlnet/ocamlnet-3.1.ebuild72
-rw-r--r--dev-ml/ocamlnet/ocamlnet-3.2.ebuild72
4 files changed, 5 insertions, 217 deletions
diff --git a/dev-ml/ocamlnet/ChangeLog b/dev-ml/ocamlnet/ChangeLog
index 29998dc8b212..973f90229bbf 100644
--- a/dev-ml/ocamlnet/ChangeLog
+++ b/dev-ml/ocamlnet/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ml/ocamlnet
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.45 2011/02/22 13:59:49 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.46 2011/04/14 18:40:49 aballier Exp $
+
+ 14 Apr 2011; Alexis Ballier <aballier@gentoo.org> -ocamlnet-3.0.3.ebuild,
+ -ocamlnet-3.1.ebuild, -ocamlnet-3.2.ebuild:
+ remove old
*ocamlnet-3.2.1 (22 Feb 2011)
diff --git a/dev-ml/ocamlnet/ocamlnet-3.0.3.ebuild b/dev-ml/ocamlnet/ocamlnet-3.0.3.ebuild
deleted file mode 100644
index af6dec39079b..000000000000
--- a/dev-ml/ocamlnet/ocamlnet-3.0.3.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-3.0.3.ebuild,v 1.1 2010/11/07 16:51:40 aballier Exp $
-
-EAPI="2"
-
-inherit eutils findlib
-
-MY_P=${P/_beta/test}
-DESCRIPTION="Modules for OCaml application-level Internet protocols"
-HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
-SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
-
-LICENSE="as-is GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-IUSE="gtk ssl tk httpd +ocamlopt zip"
-RESTRICT="installsources"
-
-# the auth-dh compile flag has been disabled as well, since it depends on
-# ocaml-cryptgps, which is not available.
-
-DEPEND=">=dev-ml/findlib-1.0
- >=dev-ml/pcre-ocaml-5
- >=dev-lang/ocaml-3.10.2[tk?,ocamlopt?]
- gtk? ( >=dev-ml/lablgtk-2 )
- ssl? ( >=dev-ml/ocaml-ssl-0.4 )
- zip? ( dev-ml/camlzip )
- "
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-ocamlnet_use_with() {
- if use $1; then
- echo "-with-$2"
- else
- echo "-without-$2"
- fi
-}
-
-ocamlnet_use_enable() {
- if use $1; then
- echo "-enable-$2"
- else
- echo "-disable-$2"
- fi
-}
-
-src_configure() {
- ./configure \
- -bindir /usr/bin \
- -datadir /usr/share/${PN} \
- $(ocamlnet_use_enable gtk gtk2) \
- $(ocamlnet_use_enable ssl ssl) \
- $(ocamlnet_use_enable tk tcl) \
- $(ocamlnet_use_enable zip zip) \
- $(ocamlnet_use_with httpd nethttpd) \
- || die "Error : econf failed!"
-}
-
-src_compile() {
- emake -j1 all || die "make failed"
- if use ocamlopt; then
- emake -j1 opt || die "make failed"
- fi
-}
-
-src_install() {
- export STRIP_MASK="*/bin/*"
- findlib_src_install
-}
diff --git a/dev-ml/ocamlnet/ocamlnet-3.1.ebuild b/dev-ml/ocamlnet/ocamlnet-3.1.ebuild
deleted file mode 100644
index b4ebc3597244..000000000000
--- a/dev-ml/ocamlnet/ocamlnet-3.1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-3.1.ebuild,v 1.1 2010/11/24 15:09:11 aballier Exp $
-
-EAPI="2"
-
-inherit eutils findlib
-
-MY_P=${P/_beta/test}
-DESCRIPTION="Modules for OCaml application-level Internet protocols"
-HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
-SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
-
-LICENSE="as-is GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-IUSE="gtk ssl tk httpd +ocamlopt zip"
-RESTRICT="installsources"
-
-# the auth-dh compile flag has been disabled as well, since it depends on
-# ocaml-cryptgps, which is not available.
-
-DEPEND=">=dev-ml/findlib-1.0
- >=dev-ml/pcre-ocaml-5
- >=dev-lang/ocaml-3.10.2[tk?,ocamlopt?]
- gtk? ( >=dev-ml/lablgtk-2 )
- ssl? ( >=dev-ml/ocaml-ssl-0.4 )
- zip? ( dev-ml/camlzip )
- "
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-ocamlnet_use_with() {
- if use $1; then
- echo "-with-$2"
- else
- echo "-without-$2"
- fi
-}
-
-ocamlnet_use_enable() {
- if use $1; then
- echo "-enable-$2"
- else
- echo "-disable-$2"
- fi
-}
-
-src_configure() {
- ./configure \
- -bindir /usr/bin \
- -datadir /usr/share/${PN} \
- $(ocamlnet_use_enable gtk gtk2) \
- $(ocamlnet_use_enable ssl ssl) \
- $(ocamlnet_use_enable tk tcl) \
- $(ocamlnet_use_enable zip zip) \
- $(ocamlnet_use_with httpd nethttpd) \
- || die "Error : econf failed!"
-}
-
-src_compile() {
- emake -j1 all || die "make failed"
- if use ocamlopt; then
- emake -j1 opt || die "make failed"
- fi
-}
-
-src_install() {
- export STRIP_MASK="*/bin/*"
- findlib_src_install
-}
diff --git a/dev-ml/ocamlnet/ocamlnet-3.2.ebuild b/dev-ml/ocamlnet/ocamlnet-3.2.ebuild
deleted file mode 100644
index 71a8f8ef6a7c..000000000000
--- a/dev-ml/ocamlnet/ocamlnet-3.2.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-3.2.ebuild,v 1.1 2010/12/23 15:56:11 aballier Exp $
-
-EAPI="2"
-
-inherit eutils findlib
-
-MY_P=${P/_beta/test}
-DESCRIPTION="Modules for OCaml application-level Internet protocols"
-HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
-SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
-
-LICENSE="as-is GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-IUSE="gtk ssl tk httpd +ocamlopt zip"
-RESTRICT="installsources"
-
-# the auth-dh compile flag has been disabled as well, since it depends on
-# ocaml-cryptgps, which is not available.
-
-DEPEND=">=dev-ml/findlib-1.0
- >=dev-ml/pcre-ocaml-5
- >=dev-lang/ocaml-3.10.2[tk?,ocamlopt?]
- gtk? ( >=dev-ml/lablgtk-2 )
- ssl? ( >=dev-ml/ocaml-ssl-0.4 )
- zip? ( dev-ml/camlzip )
- "
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-ocamlnet_use_with() {
- if use $1; then
- echo "-with-$2"
- else
- echo "-without-$2"
- fi
-}
-
-ocamlnet_use_enable() {
- if use $1; then
- echo "-enable-$2"
- else
- echo "-disable-$2"
- fi
-}
-
-src_configure() {
- ./configure \
- -bindir /usr/bin \
- -datadir /usr/share/${PN} \
- $(ocamlnet_use_enable gtk gtk2) \
- $(ocamlnet_use_enable ssl ssl) \
- $(ocamlnet_use_enable tk tcl) \
- $(ocamlnet_use_enable zip zip) \
- $(ocamlnet_use_with httpd nethttpd) \
- || die "Error : econf failed!"
-}
-
-src_compile() {
- emake -j1 all || die "make failed"
- if use ocamlopt; then
- emake -j1 opt || die "make failed"
- fi
-}
-
-src_install() {
- export STRIP_MASK="*/bin/*"
- findlib_src_install
-}