summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-01-19 12:36:16 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-01-19 12:36:16 +0000
commit96c2b857d9ebe5a2408c886feaee6939e1e3a8a5 (patch)
treebf70df196c4ff1fca82116f5ebc9809815a322c3 /dev-ml/res/res-4.0.4.ebuild
parentarm stable, bug #497758 (diff)
downloadgentoo-2-96c2b857d9ebe5a2408c886feaee6939e1e3a8a5.tar.gz
gentoo-2-96c2b857d9ebe5a2408c886feaee6939e1e3a8a5.tar.bz2
gentoo-2-96c2b857d9ebe5a2408c886feaee6939e1e3a8a5.zip
version bump
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/res/res-4.0.4.ebuild')
-rw-r--r--dev-ml/res/res-4.0.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/res/res-4.0.4.ebuild b/dev-ml/res/res-4.0.4.ebuild
new file mode 100644
index 000000000000..bb34be860c64
--- /dev/null
+++ b/dev-ml/res/res-4.0.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/res/res-4.0.4.ebuild,v 1.1 2014/01/19 12:36:16 aballier Exp $
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Resizable Array and Buffer modules for O'Caml"
+HOMEPAGE="http://bitbucket.org/mmottl/res"
+SRC_URI="https://bitbucket.org/mmottl/res/downloads/${P}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}